summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-01 08:16:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-01 08:16:39 +0000
commitd7a836286344848946f2a7612ebe28e65ddf15d3 (patch)
tree1f0c29e7176ca2e393eff9dfe21ea7598f8447af /sys-libs/glibc
parentworks on amd64 (diff)
downloadhistorical-d7a836286344848946f2a7612ebe28e65ddf15d3.tar.gz
historical-d7a836286344848946f2a7612ebe28e65ddf15d3.tar.bz2
historical-d7a836286344848946f2a7612ebe28e65ddf15d3.zip
only depend on sys-libs/timezone-data with native glibc #113920
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/Manifest8
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild21
2 files changed, 9 insertions, 20 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index f6c4f5c5b2d4..8718d241a450 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -137,13 +137,13 @@ MD5 0f7e5c131179718e7d9c26e77ee26460 glibc-2.3.5-r3.ebuild 38907
MD5 1cb57f1757c26c0e0286cb0ef6c36171 glibc-2.3.5.20050421.ebuild 40152
MD5 48b60115273ba9fa755a6ef94fe8c3b6 glibc-2.3.5.20050722.ebuild 39299
MD5 9c15c32a0bbef91769c4fd0c0d7a66c3 glibc-2.3.5.ebuild 40143
-MD5 eb6575db85582f440333c8f79e5a1ca1 glibc-2.3.6-r1.ebuild 42013
+MD5 980bdc2069ab4a4f95ea0b2bff20ae89 glibc-2.3.6-r1.ebuild 41623
MD5 c1860f958f09de634ae4e2e0b0377bd9 glibc-2.3.6.ebuild 40082
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDjjN5ugEuf3OQ0akRAslWAJ4u8C4sgE6ECmGawbCez8/ueQQ3xQCdG4+p
-f83JZcheLsGx0saHmC/JSUs=
-=gzG+
+iD8DBQFDjrH8gIKl8Uu19MoRAhymAJ0eSY9k/jdZ9/oNfx9qj1pC6NUBiACfWBmy
+jrJpNDcLtQ9cG6/osOa8o48=
+=Px0y
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index b39193dc3f7e..d4cb25822af5 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.3 2005/11/18 03:52:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.4 2005/12/01 08:16:39 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -505,11 +505,6 @@ toolchain-glibc_src_install() {
for dir in $(get_all_libdirs); do
rm -rf ${D}/usr/${dir}/gconv &> /dev/null
done
-
- einfo "Installing Timezone data..."
- make PARALLELMFLAGS="${MAKEOPTS} -j1" \
- install_root=${D} \
- timezone/install-others || die
fi
# Is this next line actually needed or does the makefile get it right?
@@ -1076,23 +1071,15 @@ fi
# we'll handle stripping ourself #46186
RESTRICT="nostrip multilib-pkg-force"
-# We need new cleanup attribute support from gcc for NPTL among things ...
-# We also need linux26-headers if using NPTL. Including kernel headers is
-# incredibly unreliable, and this new linux-headers release from plasmaroo
-# should work with userspace apps, at least on amd64 and ppc64.
-#
# We need a new-enough binutils for as-needed
DEPEND=">=sys-devel/gcc-3.3.3
nptl? ( >=sys-kernel/linux-headers-2.6.5 )
>=sys-devel/binutils-2.16.1
>=sys-devel/gcc-config-1.3.12
virtual/os-headers
- sys-libs/timezone-data
nls? ( sys-devel/gettext )
selinux? ( !build? ( sys-libs/libselinux ) )"
-
RDEPEND="virtual/os-headers
- sys-libs/timezone-data
nls? ( sys-devel/gettext )
selinux? ( !build? ( sys-libs/libselinux ) )"
@@ -1100,12 +1087,15 @@ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
DEPEND="${DEPEND} ${CATEGORY}/gcc"
if [[ ${CATEGORY} == *-linux* ]] ; then
- if [[ ${CATEGORY/mips} != ${CATEGORY} ]] ; then
+ if [[ ${CATEGORY} == cross-mips* ]] ; then
DEPEND="${DEPEND} >=${CATEGORY}/mips-headers-2.6.10"
else
DEPEND="${DEPEND} ${CATEGORY}/linux-headers"
fi
fi
+else
+ DEPEND="${DEPEND} sys-libs/timezone-data"
+ RDEPEND="${RDEPEND} sys-libs/timezone-data"
fi
pkg_setup() {
@@ -1132,7 +1122,6 @@ pkg_setup() {
die "nptlonly without nptl"
fi
-
# give some sort of warning about the nptl logic changes...
if want_nptl && want_linuxthreads ; then