summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-12 07:01:05 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-12 07:01:05 +0000
commita0077bd8baed60af6936e3b8dec92c08f6f5aff8 (patch)
tree5e943f938cb3d0b1a6689e26cdfb5e3472e959a2 /sys-libs/lwp
parentRemoved RDEPEND=${DEPEND} (diff)
downloadhistorical-a0077bd8baed60af6936e3b8dec92c08f6f5aff8.tar.gz
historical-a0077bd8baed60af6936e3b8dec92c08f6f5aff8.tar.bz2
historical-a0077bd8baed60af6936e3b8dec92c08f6f5aff8.zip
Removed RDEPEND=${DEPEND}
Diffstat (limited to 'sys-libs/lwp')
-rw-r--r--sys-libs/lwp/lwp-1.9.ebuild29
1 files changed, 8 insertions, 21 deletions
diff --git a/sys-libs/lwp/lwp-1.9.ebuild b/sys-libs/lwp/lwp-1.9.ebuild
index 87fce14b18ba..382f6bc369a2 100644
--- a/sys-libs/lwp/lwp-1.9.ebuild
+++ b/sys-libs/lwp/lwp-1.9.ebuild
@@ -1,36 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/lwp/lwp-1.9.ebuild,v 1.1 2002/07/23 21:48:04 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lwp/lwp-1.9.ebuild,v 1.2 2002/11/12 06:59:02 vapier Exp $
-DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl."
-
-# Appearantly maintained by the Coda people
-HOMEPAGE="http://www.coda.cs.cmu.edu"
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl."
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
-#actually "GNU Library General Public Licence Version 2"
LICENSE="LGPL-2.1"
-
-# Nothing listed in the docs for dependencies that I noticed
-DEPEND="virtual/glibc"
-RDEPEND=${DEPEND}
-
SLOT="1"
KEYWORDS="x86"
-SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
-
-S=${WORKDIR}/${P}
+DEPEND="virtual/glibc"
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
- emake || die
+ econf
+ emake || die "make failed"
}
-src_install () {
+src_install() {
# does not seems to consistently use DESTDIR where it needs to, but I could be wrong too
# make DESTDIR=${D} install || die
make \