summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-12 23:47:49 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-12 23:47:49 +0000
commit495db330fee0e9e5755f11f8d1b57f4f9fa3bea9 (patch)
tree2408ef84f1d5597c3994451653d29cc1bf0ea8a5 /sys-libs/newlib
parentCleanup old files. (diff)
downloadhistorical-495db330fee0e9e5755f11f8d1b57f4f9fa3bea9.tar.gz
historical-495db330fee0e9e5755f11f8d1b57f4f9fa3bea9.tar.bz2
historical-495db330fee0e9e5755f11f8d1b57f4f9fa3bea9.zip
old
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/newlib-1.14.0.ebuild76
-rw-r--r--sys-libs/newlib/newlib-1.15.0.ebuild74
-rw-r--r--sys-libs/newlib/newlib-1.16.0.ebuild74
-rw-r--r--sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild75
4 files changed, 0 insertions, 299 deletions
diff --git a/sys-libs/newlib/newlib-1.14.0.ebuild b/sys-libs/newlib/newlib-1.14.0.ebuild
deleted file mode 100644
index 63303dac88ac..000000000000
--- a/sys-libs/newlib/newlib-1.14.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.14.0.ebuild,v 1.7 2008/10/27 06:59:51 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-# Handle the case where we want newlib on glibc ...
-if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
- export CTARGET=${CHOST%%-*}-pc-linux-newlib
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="http://sourceware.org/newlib/"
-SRC_URI="ftp://sources.redhat.com/pub/newlib/${P}.tar.gz
- mirror://gentoo/${P}-spu.patch.bz2"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="nls threads unicode multilib crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-RDEPEND=""
-
-NEWLIBBUILD="${WORKDIR}/build"
-
-src_unpack() {
- unpack ${A}
- epatch "${WORKDIR}"/${P}-spu.patch
- mkdir -p "${NEWLIBBUILD}"
-}
-
-src_compile() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- # hardwired to avoid breakages
- [[ $(tc-is-softfloat) == "no" ]] \
- && myconf="--disable-newlib-hw-fp" \
- || myconf="--enable-newlib-hw-fp"
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-threads" \
- || myconf="${myconf} $(use_enable threads)"
-
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- $(use_enable multilib) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- # minor hack to keep things clean
- rm -fR "${D}"/usr/info
-}
diff --git a/sys-libs/newlib/newlib-1.15.0.ebuild b/sys-libs/newlib/newlib-1.15.0.ebuild
deleted file mode 100644
index ddb5e6e874b2..000000000000
--- a/sys-libs/newlib/newlib-1.15.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.15.0.ebuild,v 1.8 2008/10/27 06:59:51 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-# Handle the case where we want newlib on glibc ...
-if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
- export CTARGET=${CHOST%%-*}-pc-linux-newlib
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="http://sourceware.org/newlib/"
-SRC_URI="ftp://sources.redhat.com/pub/newlib/${P}.tar.gz"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="nls threads unicode crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-RDEPEND=""
-
-NEWLIBBUILD="${WORKDIR}/build"
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${NEWLIBBUILD}"
-}
-
-src_compile() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- # hardwired to avoid breakages
- [[ $(tc-is-softfloat) != "no" ]] \
- && myconf="--disable-newlib-hw-fp" \
- || myconf="--enable-newlib-hw-fp"
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-threads" \
- || myconf="${myconf} $(use_enable threads)"
-
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}
diff --git a/sys-libs/newlib/newlib-1.16.0.ebuild b/sys-libs/newlib/newlib-1.16.0.ebuild
deleted file mode 100644
index 062212464fea..000000000000
--- a/sys-libs/newlib/newlib-1.16.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.16.0.ebuild,v 1.2 2008/10/27 06:59:51 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-# Handle the case where we want newlib on glibc ...
-if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
- export CTARGET=${CHOST%%-*}-pc-linux-newlib
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="http://sourceware.org/newlib/"
-SRC_URI="ftp://sources.redhat.com/pub/newlib/${P}.tar.gz"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="nls threads unicode crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-RDEPEND=""
-
-NEWLIBBUILD="${WORKDIR}/build"
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${NEWLIBBUILD}"
-}
-
-src_compile() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- # hardwired to avoid breakages
- [[ $(tc-is-softfloat) != "no" ]] \
- && myconf="--disable-newlib-hw-fp" \
- || myconf="--enable-newlib-hw-fp"
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-threads" \
- || myconf="${myconf} $(use_enable threads)"
-
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
-# env -uRESTRICT CHOST=${CTARGET} prepallstrip
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}
diff --git a/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild b/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild
deleted file mode 100644
index 5a7425a0d581..000000000000
--- a/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild,v 1.2 2008/10/27 06:59:51 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-# Handle the case where we want newlib on glibc ...
-if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
- export CTARGET=${CHOST%%-*}-pc-linux-newlib
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="http://sourceware.org/newlib/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="nls threads unicode crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-RDEPEND=""
-
-NEWLIBBUILD="${WORKDIR}/build"
-S="${WORKDIR}/newlib"
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${NEWLIBBUILD}"
-}
-
-src_compile() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- # hardwired to avoid breakages
- [[ $(tc-is-softfloat) != "no" ]] \
- && myconf="--disable-newlib-hw-fp" \
- || myconf="--enable-newlib-hw-fp"
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-threads" \
- || myconf="${myconf} $(use_enable threads)"
-
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
-# env -uRESTRICT CHOST=${CTARGET} prepallstrip
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}