summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-02 18:11:37 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-02 18:11:37 +0000
commit928ef4dfee6e361b57427464d1d6c86d9d61ef5c (patch)
tree75552b900e17a6cfcffb9d35b37f9c2aac61adbe /sys-libs/ss
parentStable for HPPA (bug #239301). (diff)
downloadhistorical-928ef4dfee6e361b57427464d1d6c86d9d61ef5c.tar.gz
historical-928ef4dfee6e361b57427464d1d6c86d9d61ef5c.tar.bz2
historical-928ef4dfee6e361b57427464d1d6c86d9d61ef5c.zip
old
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.2 x86_64
Diffstat (limited to 'sys-libs/ss')
-rw-r--r--sys-libs/ss/files/ss-1.40.3-check.patch27
-rw-r--r--sys-libs/ss/files/ss-1.40.4-check.patch11
-rw-r--r--sys-libs/ss/ss-1.40.10.ebuild83
-rw-r--r--sys-libs/ss/ss-1.40.4.ebuild74
-rw-r--r--sys-libs/ss/ss-1.40.6.ebuild73
-rw-r--r--sys-libs/ss/ss-1.40.8.ebuild76
6 files changed, 0 insertions, 344 deletions
diff --git a/sys-libs/ss/files/ss-1.40.3-check.patch b/sys-libs/ss/files/ss-1.40.3-check.patch
deleted file mode 100644
index 779edb822ae6..000000000000
--- a/sys-libs/ss/files/ss-1.40.3-check.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- lib/ss/Makefile.in
-+++ lib/ss/Makefile.in
-@@ -5,6 +5,7 @@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
- VPATH = @srcdir@
-+builddir = @builddir@
- top_builddir = ../..
- my_dir = lib/ss
- INSTALL = @INSTALL@
-@@ -163,14 +163,14 @@
- $(DESTDIR)$(man1dir)/mk_cmds.1
- $(RM) -rf $(DESTDIR)$(includedir)/ss $(DESTDIR)$(datadir)/ss
-
--test_ss: test_ss.o test_cmd.o $(LIBEXT2FS) $(LIBSS) $(LIBCOM_ERR)
-+test_ss: test_ss.o test_cmd.o $(LIBSS) $(LIBCOM_ERR)
- @echo " LD $@"
- @$(CC) -o $@ test_ss.o test_cmd.o $(ALL_CFLAGS) \
- $(LIBSS) $(LIBCOM_ERR)
-
- check:: all test_ss
- @echo " RUN TEST test_ss"
-- @(test_ss -f $(srcdir)/test_script >& test_out; exit 0)
-+ @($(builddir)/test_ss -f $(srcdir)/test_script >& test_out; exit 0)
- @if ! diff test_out $(srcdir)/test_script_expected > test.diff; then \
- echo "Regression test for ss library failed!"; exit 1 ; fi
-
diff --git a/sys-libs/ss/files/ss-1.40.4-check.patch b/sys-libs/ss/files/ss-1.40.4-check.patch
deleted file mode 100644
index 147690809b48..000000000000
--- a/sys-libs/ss/files/ss-1.40.4-check.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/ss/Makefile.in
-+++ lib/ss/Makefile.in
-@@ -163,7 +163,7 @@
- $(DESTDIR)$(man1dir)/mk_cmds.1
- $(RM) -rf $(DESTDIR)$(includedir)/ss $(DESTDIR)$(datadir)/ss
-
--test_ss: test_ss.o test_cmd.o $(LIBEXT2FS) $(LIBSS) $(LIBCOM_ERR)
-+test_ss: test_ss.o test_cmd.o $(LIBSS) $(LIBCOM_ERR)
- @echo " LD $@"
- @$(CC) -o $@ test_ss.o test_cmd.o $(ALL_CFLAGS) \
- $(LIBSS) $(LIBCOM_ERR)
diff --git a/sys-libs/ss/ss-1.40.10.ebuild b/sys-libs/ss/ss-1.40.10.ebuild
deleted file mode 100644
index ae23232e3295..000000000000
--- a/sys-libs/ss/ss-1.40.10.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.10.ebuild,v 1.4 2008/08/26 18:45:44 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Subsystem command parsing library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="~sys-libs/com_err-${PV}
- !sys-libs/e2fsprogs-libs"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-env_setup() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-
- # make sure we error out if com_err is attempted to be built
- rm -f lib/et/*.c
- # since we've split out com_err/ss into their own ebuilds, we
- # need to fake out the local files. let the toolchain find them.
- mkdir tc || die
- echo "GROUP ( libcom_err.a )" > tc/libcom_err.a
- echo "GROUP ( libcom_err.so )" > tc/libcom_err.so
- sed -i \
- -e '/^LIBCOM_ERR/s:$(LIB):$(top_builddir)/tc:' \
- MCONFIG.in || die
- ln -s $(type -P compile_et) lib/et/compile_et
-}
-
-src_compile() {
- env_setup
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable nls) \
- || die
- emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
-}
-
-src_test() {
- env_setup
- emake -j1 -C lib/ss check || die "make check failed"
-}
-
-src_install() {
- env_setup
-
- dodir /usr/share/man/man1
- emake -C lib/ss DESTDIR="${D}" install || die
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
- dolib.a lib/libss.a || die "dolib.a"
- gen_usr_ldscript libss.so
-}
diff --git a/sys-libs/ss/ss-1.40.4.ebuild b/sys-libs/ss/ss-1.40.4.ebuild
deleted file mode 100644
index 1f2db5b17473..000000000000
--- a/sys-libs/ss/ss-1.40.4.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.4.ebuild,v 1.8 2008/08/26 18:45:44 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Subsystem command parsing library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="~sys-libs/com_err-${PV}
- !sys-libs/e2fsprogs-libs"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-env_setup() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40.4-check.patch #201762
-}
-
-src_compile() {
- env_setup
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable nls) \
- || die
- emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
-}
-
-src_test() {
- env_setup
-
- ln -s $(${CC} -print-file-name=libcom_err.so) lib/libcom_err.so
- emake -j1 -C lib/ss check || die "make check failed"
-}
-
-src_install() {
- env_setup
-
- dodir /usr/share/man/man1
- make -C lib/ss DESTDIR="${D}" install || die
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
- dolib.a lib/libss.a || die "dolib.a"
- gen_usr_ldscript libss.so
-}
diff --git a/sys-libs/ss/ss-1.40.6.ebuild b/sys-libs/ss/ss-1.40.6.ebuild
deleted file mode 100644
index 3a849752552b..000000000000
--- a/sys-libs/ss/ss-1.40.6.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.6.ebuild,v 1.6 2008/08/26 18:45:44 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Subsystem command parsing library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="~sys-libs/com_err-${PV}
- !sys-libs/e2fsprogs-libs"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-env_setup() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-}
-
-src_compile() {
- env_setup
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable nls) \
- || die
- emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
-}
-
-src_test() {
- env_setup
-
- ln -s $(${CC} -print-file-name=libcom_err.so) lib/libcom_err.so
- emake -j1 -C lib/ss check || die "make check failed"
-}
-
-src_install() {
- env_setup
-
- dodir /usr/share/man/man1
- make -C lib/ss DESTDIR="${D}" install || die
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
- dolib.a lib/libss.a || die "dolib.a"
- gen_usr_ldscript libss.so
-}
diff --git a/sys-libs/ss/ss-1.40.8.ebuild b/sys-libs/ss/ss-1.40.8.ebuild
deleted file mode 100644
index ab30e4bb2dde..000000000000
--- a/sys-libs/ss/ss-1.40.8.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.8.ebuild,v 1.8 2008/08/26 18:45:44 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Subsystem command parsing library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="~sys-libs/com_err-${PV}
- !sys-libs/e2fsprogs-libs"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-env_setup() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-
- # since we've split out com_err/ss into their own ebuilds, we
- # need to fake out the local files. let the toolchain find them.
- echo "GROUP ( /usr/$(get_libdir)/libcom_err.a )" > lib/libcom_err.a
- echo "GROUP ( /usr/$(get_libdir)/libcom_err.so )" > lib/libcom_err.so
-}
-
-src_compile() {
- env_setup
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable nls) \
- || die
- emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
-}
-
-src_test() {
- env_setup
- emake -j1 -C lib/ss check || die "make check failed"
-}
-
-src_install() {
- env_setup
-
- dodir /usr/share/man/man1
- emake -C lib/ss DESTDIR="${D}" install || die
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
- dolib.a lib/libss.a || die "dolib.a"
- gen_usr_ldscript libss.so
-}