summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2002-12-09 15:41:08 +0000
committerJon Portnoy <avenj@gentoo.org>2002-12-09 15:41:08 +0000
commit005b52ecdd1428867ffed57f0b4928082ab4d742 (patch)
tree6027ad1c987f312eba26a1e3f64c277e60db0072 /sys-libs
parentnew libraries as a dep for flightgear (diff)
downloadhistorical-005b52ecdd1428867ffed57f0b4928082ab4d742.tar.gz
historical-005b52ecdd1428867ffed57f0b4928082ab4d742.tar.bz2
historical-005b52ecdd1428867ffed57f0b4928082ab4d742.zip
Added a patch to fix bug #11762
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog8
-rw-r--r--sys-libs/readline/files/digest-readline-4.3-r43
-rw-r--r--sys-libs/readline/files/readline4.3-mbutil.patch68
-rw-r--r--sys-libs/readline/readline-4.3-r4.ebuild78
4 files changed, 156 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 626366a8c2d1..921bf1080bf6 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/readline
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.9 2002/12/09 04:37:29 manson Exp $
+# $Header:
+
+*readline-4.3-r4 (09 Dec 2002)
+ 09 Dec 2002; Jon Portnoy <avenj@gentoo.org> readline-4.3-r4.ebuild :
+
+ Added a patch from upstream maintainer to fix bug:
+ http://bugs.gentoo.org/show_bug.cgi?id=11762
\* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
diff --git a/sys-libs/readline/files/digest-readline-4.3-r4 b/sys-libs/readline/files/digest-readline-4.3-r4
new file mode 100644
index 000000000000..3ce983e2b2f1
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-4.3-r4
@@ -0,0 +1,3 @@
+MD5 f86f7cb717ab321fe15f1bbcb058c11e readline-4.3.tar.gz 961662
+MD5 aacf1c41717f305ab5ce45e9d028821d readline43-001 1126
+MD5 8df4bf2c7e77e05c4ecd949b9b5dedf3 readline43-002 738
diff --git a/sys-libs/readline/files/readline4.3-mbutil.patch b/sys-libs/readline/files/readline4.3-mbutil.patch
new file mode 100644
index 000000000000..4b765ad25ec0
--- /dev/null
+++ b/sys-libs/readline/files/readline4.3-mbutil.patch
@@ -0,0 +1,68 @@
+*** ../readline-4.3/mbutil.c Tue Jun 4 11:54:29 2002
+--- mbutil.c Mon Aug 5 11:20:39 2002
+***************
+*** 206,210 ****
+ {
+ /* shorted to compose multibyte char */
+! memset (ps, 0, sizeof(mbstate_t));
+ return -2;
+ }
+--- 206,211 ----
+ {
+ /* shorted to compose multibyte char */
+! if (ps)
+! memset (ps, 0, sizeof(mbstate_t));
+ return -2;
+ }
+***************
+*** 213,217 ****
+ /* invalid to compose multibyte char */
+ /* initialize the conversion state */
+! memset (ps, 0, sizeof(mbstate_t));
+ return -1;
+ }
+--- 214,219 ----
+ /* invalid to compose multibyte char */
+ /* initialize the conversion state */
+! if (ps)
+! memset (ps, 0, sizeof(mbstate_t));
+ return -1;
+ }
+***************
+*** 226,232 ****
+ int
+ _rl_compare_chars (buf1, pos1, ps1, buf2, pos2, ps2)
+! char *buf1, *buf2;
+! mbstate_t *ps1, *ps2;
+! int pos1, pos2;
+ {
+ int i, w1, w2;
+--- 228,237 ----
+ int
+ _rl_compare_chars (buf1, pos1, ps1, buf2, pos2, ps2)
+! char *buf1;
+! int pos1;
+! mbstate_t *ps1;
+! char *buf2;
+! int pos2;
+! mbstate_t *ps2;
+ {
+ int i, w1, w2;
+***************
+*** 277,282 ****
+ /* clear the state of the byte sequence, because
+ in this case effect of mbstate is undefined */
+! memset (ps, 0, sizeof (mbstate_t));
+ }
+ else
+ pos += tmp;
+--- 282,290 ----
+ /* clear the state of the byte sequence, because
+ in this case effect of mbstate is undefined */
+! if (ps)
+! memset (ps, 0, sizeof (mbstate_t));
+ }
++ else if (tmp == 0)
++ pos++;
+ else
+ pos += tmp;
diff --git a/sys-libs/readline/readline-4.3-r4.ebuild b/sys-libs/readline/readline-4.3-r4.ebuild
new file mode 100644
index 000000000000..0e6b35ddc71e
--- /dev/null
+++ b/sys-libs/readline/readline-4.3-r4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+# Official patches
+PLEVEL="x001 x002"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Another cute console display library"
+SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+# We must be sertain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+DEPEND=">=sys-apps/bash-2.05b-r2
+ >=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ for x in ${PLEVEL//x}
+ do
+ patch -p0 < ${DISTDIR}/${PN}${PV/\.}-${x} || die
+ done
+ cat ${FILESDIR}/readline4.3-mbutil.patch | patch -p0
+
+
+}
+
+src_compile() {
+
+ econf --with-curses || die
+
+ emake || die
+ cd shlib
+ emake || die
+}
+
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+ cd ${S}/shlib
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+
+ cd ${S}
+
+ dodir /lib
+ mv ${D}/usr/lib/*.so* ${D}/lib
+ # bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ # end bug #4411
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so
+ # Needed because make install uses ${D} for the link
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so.4
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so.4
+ chmod 755 ${D}/lib/*.${PV/a/}
+
+ dodoc CHANGELOG CHANGES COPYING MANIFEST README USAGE
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+