summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-05-26 10:18:51 +0000
committerPreston A. Elder <prez@gentoo.org>2002-05-26 10:18:51 +0000
commitd722a72b076f8475bdd753868fe10e4b3e02a94d (patch)
tree25311f5029c38cc6004f337537c2b691b5eaeab0 /sys-libs
parentFixed for gcc 3.1 (diff)
downloadhistorical-d722a72b076f8475bdd753868fe10e4b3e02a94d.tar.gz
historical-d722a72b076f8475bdd753868fe10e4b3e02a94d.tar.bz2
historical-d722a72b076f8475bdd753868fe10e4b3e02a94d.zip
Added ncurses-5.2.20020511-r1 which compiles with gcc 3.1
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ChangeLog8
-rw-r--r--sys-libs/ncurses/files/digest-ncurses-5.2.20020511-r12
-rw-r--r--sys-libs/ncurses/files/ncurses-5.2.20020511-gcc31.patch23
-rw-r--r--sys-libs/ncurses/ncurses-5.2.20020511-r1.ebuild99
4 files changed, 131 insertions, 1 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index f3541304cf12..c3f25bc65e91 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/ncurses
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.5 2002/05/18 05:13:39 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.6 2002/05/26 10:18:51 prez Exp $
+
+*ncurses-5.2.20020511-r1 (26 May 2002)
+
+ 26 May 2002; Preston A. Elder <prez@gentoo.org> :
+
+ Added patch to make it work with gcc 3.1
*ncurses-5.2.20020511 (18 May 2002)
diff --git a/sys-libs/ncurses/files/digest-ncurses-5.2.20020511-r1 b/sys-libs/ncurses/files/digest-ncurses-5.2.20020511-r1
new file mode 100644
index 000000000000..54cb37a390cb
--- /dev/null
+++ b/sys-libs/ncurses/files/digest-ncurses-5.2.20020511-r1
@@ -0,0 +1,2 @@
+MD5 464d6a49010cf2a6eb9ce59a264d4d47 ncurses-5.2.tar.gz 1743818
+MD5 09ddc8b2eee779d2ddd8504547da5822 ncurses-5.2.20020511.diff.bz2 650642
diff --git a/sys-libs/ncurses/files/ncurses-5.2.20020511-gcc31.patch b/sys-libs/ncurses/files/ncurses-5.2.20020511-gcc31.patch
new file mode 100644
index 000000000000..e351790f4bfa
--- /dev/null
+++ b/sys-libs/ncurses/files/ncurses-5.2.20020511-gcc31.patch
@@ -0,0 +1,23 @@
+diff -urNd ncurses-5.2/c++/cursesw.cc ncurses-5.2/c++/cursesw.cc.new
+--- ncurses-5.2/c++/cursesw.cc Sat May 25 12:23:26 2002
++++ ncurses-5.2/c++/cursesw.cc.new Sat May 25 12:22:51 2002
+@@ -51,8 +51,7 @@
+ char buf[BUFSIZ];
+ int result = wgetstr(w, buf);
+ if (result == OK) {
+- strstreambuf ss(buf, sizeof(buf));
+- result = ss.vscan(fmt, (_IO_va_list)args);
++ result = vsscanf(buf, fmt, args);
+ }
+ va_end(args);
+ return result;
+@@ -73,8 +72,7 @@
+ if (result == OK) {
+ result = wgetstr(w, buf);
+ if (result == OK) {
+- strstreambuf ss(buf, sizeof(buf));
+- result = ss.vscan(fmt, (_IO_va_list)args);
++ result = vsscanf(buf, fmt, args);
+ }
+ }
+ va_end(args);
diff --git a/sys-libs/ncurses/ncurses-5.2.20020511-r1.ebuild b/sys-libs/ncurses/ncurses-5.2.20020511-r1.ebuild
new file mode 100644
index 000000000000..05c695cb9ef4
--- /dev/null
+++ b/sys-libs/ncurses/ncurses-5.2.20020511-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.2.20020511-r1.ebuild,v 1.1 2002/05/26 10:18:51 prez Exp $
+
+MY_PV=${PV%.*}
+
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="Linux console display libarary"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${PN}-${MY_PV}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/${PN}-${PV}.diff.bz2"
+ #ftp://dickey.his.com/${PN}/${PV}/patch-${MY_PV}-20020427.sh.gz
+ #ftp://dickey.his.com/${PN}/${PV}/${PN}-${MY_PV}-20020429.patch.gz
+ #ftp://dickey.his.com/${PN}/${PV}/${PN}-${MY_PV}-20020511.patch.gz"
+HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+DEPEND="virtual/glibc"
+LICENSE="MIT"
+SLOT="5"
+
+src_unpack() {
+ unpack ${PN}-${MY_PV}.tar.gz ; cd ${S}
+ #this is how the gentoo patch was created. avoids a dependency
+ #on sharutils for uudecode :/
+ #( zcat ${DISTDIR}/patch-${MY_PV}-20020427.sh.gz | sh ) || die
+ #( zcat ${DISTDIR}/${PN}-${MY_PV}-20020429.patch.gz | patch -p1 ) || die
+ #( zcat ${DISTDIR}/${PN}-${MY_PV}-20020511.patch.gz | patch -p1 ) || die
+ #this is the generated patch..
+ ( bzcat ${DISTDIR}/${PN}-${PV}.diff.bz2 | patch -p1 ) || die
+}
+
+src_compile() {
+ [ -z "$DEBUGBUILD" ] && myconf="${myconf} --without-debug"
+
+ rm -rf test
+ ./configure \
+ --prefix=/usr \
+ --libdir=/lib \
+ --mandir=/usr/share/man \
+ --enable-symlinks \
+ --enable-termcap \
+ --with-shared \
+ --with-rcs-ids \
+ --host=${CHOST} ${myconf} || die
+
+ echo "all:" > test/Makefile
+
+ patch -p1 <${FILESDIR}/ncurses-5.2.20020511-gcc31.patch
+
+ #emake still doesn't work circa 25 Mar 2002
+ make || die
+}
+
+src_install() {
+ dodir /usr/lib
+ echo "install:" >> ${S}/test/Makefile
+ make DESTDIR=${D} install || die
+
+ cd ${D}/lib
+ ln -s libncurses.a libcurses.a
+ chmod 755 ${D}/lib/*.${MY_PV}
+ dodir /usr/lib
+ mv libform* libmenu* libpanel* ../usr/lib
+ mv *.a ../usr/lib
+
+ #with this fix, the default xterm has color as it should
+ cd ${D}/usr/share/terminfo/x
+ mv xterm xterm.orig
+ ln -s xterm-color xterm
+
+ if [ -n "`use build`" ]
+ then
+ cd ${D}
+ rm -rf usr/share/man
+ cd usr/share/terminfo
+ cp -a l/linux n/nxterm v/vt100 ${T}
+ rm -rf *
+ mkdir l x v
+ cp -a ${T}/linux l
+ cp -a ${T}/nxterm x/xterm
+ cp -a ${T}/vt100 v
+ cd ${D}/usr/lib
+ #bash compilation requires static libncurses libraries, so
+ #this breaks the "build a new build image" system. We now
+ #need to remove libncurses.a from the build image manually.
+ #rm *.a
+ else
+ cd ${S}
+ dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
+ dodoc doc/*.doc
+ dohtml -r doc/html/
+# docinto html/ada
+# dodoc doc/html/ada/*.htm
+# docinto html/ada/files
+# dodoc doc/html/ada/files/*.htm
+# docinto html/ada/funcs
+# dodoc doc/html/ada/funcs/*.htm
+# docinto html/man
+# dodoc doc/html/man/*.html
+ fi
+}