summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-14 22:37:27 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-14 22:37:27 +0000
commit3f69c8391e8971e194ff6767ceb18831e84de363 (patch)
tree46fa5e14ac4e80c2084705674cfaf099b7b819da /sys-power/cpudyn/cpudyn-0.99.0.ebuild
parentMoved sys-apps/nvram-reboot to sys-power/nvram-reboot (diff)
downloadhistorical-3f69c8391e8971e194ff6767ceb18831e84de363.tar.gz
historical-3f69c8391e8971e194ff6767ceb18831e84de363.tar.bz2
historical-3f69c8391e8971e194ff6767ceb18831e84de363.zip
Moved from sys-apps/cpudyn to sys-power/cpudyn.
Diffstat (limited to 'sys-power/cpudyn/cpudyn-0.99.0.ebuild')
-rw-r--r--sys-power/cpudyn/cpudyn-0.99.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-power/cpudyn/cpudyn-0.99.0.ebuild b/sys-power/cpudyn/cpudyn-0.99.0.ebuild
new file mode 100644
index 000000000000..eecad06eebb5
--- /dev/null
+++ b/sys-power/cpudyn/cpudyn-0.99.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/cpudyn-0.99.0.ebuild,v 1.1 2005/03/14 22:37:27 ciaranm Exp $
+
+inherit eutils
+
+DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
+HOMEPAGE="http://mnm.uib.es/~gallir/${PN}/"
+SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc amd64"
+IUSE=""
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir gentoo
+ cp debian/cpudyn.conf gentoo
+ cp ${FILESDIR}/cpudyn.init gentoo/cpudyn.init
+ epatch ${FILESDIR}/${PN}-0.99.0-init_conf_updates.patch
+}
+
+src_compile() {
+ emake cpudynd || die "Compilation failed."
+}
+
+src_install() {
+ into /
+ exeinto /etc/init.d
+ newexe gentoo/cpudyn.init cpudyn
+ insinto /etc/conf.d
+ newins gentoo/cpudyn.conf cpudyn
+
+ into /usr
+ doman cpudynd.8
+ dosbin cpudynd
+ dodoc INSTALL README VERSION changelog COPYING
+ dohtml *.html
+}
+
+pkg_postinst() {
+ einfo "Configuration file is /etc/conf.d/cpudyn."
+}