summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-07-10 19:41:09 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-07-10 19:41:09 +0000
commit47b5e2a4968d871ba1f2db00d60fc0779a1a811a (patch)
treef8ea684629027c8ce6b2f3ab67b9f5bf0fb62b38 /sys-process/cronie/cronie-1.4.8.ebuild
parentunused useflag (diff)
downloadhistorical-47b5e2a4968d871ba1f2db00d60fc0779a1a811a.tar.gz
historical-47b5e2a4968d871ba1f2db00d60fc0779a1a811a.tar.bz2
historical-47b5e2a4968d871ba1f2db00d60fc0779a1a811a.zip
Fixed bug #365651, bug #374011 and added myself as maintainer
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'sys-process/cronie/cronie-1.4.8.ebuild')
-rw-r--r--sys-process/cronie/cronie-1.4.8.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-process/cronie/cronie-1.4.8.ebuild b/sys-process/cronie/cronie-1.4.8.ebuild
new file mode 100644
index 000000000000..35d31fb3cb3f
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.8.ebuild,v 1.1 2011/07/10 19:41:09 polynomial-c Exp $
+
+EAPI="3"
+
+inherit cron eutils pam
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="inotify pam"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" econf \
+ $(use_with inotify ) \
+ $(use_with pam ) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.2-initd" cronie
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ dodoc NEWS AUTHORS README
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}