summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-20 19:32:33 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-20 19:32:33 +0000
commit25d6cdc94687eb757db06142a6541995bed8ecf8 (patch)
tree1b30826e4ef5d59190ab1b823d1935d5c810377e /virtual
parentVersion bump, thanks to proxy maintainer Vincent Hardy. (diff)
downloadhistorical-25d6cdc94687eb757db06142a6541995bed8ecf8.tar.gz
historical-25d6cdc94687eb757db06142a6541995bed8ecf8.tar.bz2
historical-25d6cdc94687eb757db06142a6541995bed8ecf8.zip
Initial ebuild by me for #392179 by Michal Pytasz.
Package-Manager: portage-2.2.0_alpha81/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'virtual')
-rw-r--r--virtual/opencl/ChangeLog10
-rw-r--r--virtual/opencl/Manifest13
-rw-r--r--virtual/opencl/metadata.xml5
-rw-r--r--virtual/opencl/opencl-0.ebuild19
4 files changed, 47 insertions, 0 deletions
diff --git a/virtual/opencl/ChangeLog b/virtual/opencl/ChangeLog
new file mode 100644
index 000000000000..9cd2fe9f29f6
--- /dev/null
+++ b/virtual/opencl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for virtual/opencl
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/ChangeLog,v 1.1 2011/12/20 19:32:33 vapier Exp $
+
+*opencl-0 (20 Dec 2011)
+
+ 20 Dec 2011; Mike Frysinger <vapier@gentoo.org> +opencl-0.ebuild,
+ +metadata.xml:
+ Initial ebuild by me for #392179 by Michal Pytasz.
+
diff --git a/virtual/opencl/Manifest b/virtual/opencl/Manifest
new file mode 100644
index 000000000000..63fdaa09f351
--- /dev/null
+++ b/virtual/opencl/Manifest
@@ -0,0 +1,13 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+EBUILD opencl-0.ebuild 557 RMD160 11787ff9d697aad4c437b7e110b55c9a32607ef8 SHA1 9e802a2a9c0797a7bafc37df9c98f14a73ae5464 SHA256 9a5cd5d6f98301fb90a1ae9c86b6425a4f64a3a994908e5a7f3d7623f0d8fe25
+MISC ChangeLog 365 RMD160 f9544dafdaaad3f332b47054e0259b0f99671d45 SHA1 7fcfad7ef46291bf11313e0cf4b4ae4a5e17ed55 SHA256 92997e6b50194ab32a68d16c45f2f08b636a11fe4a16cc2f163f32eba8acf226
+MISC metadata.xml 156 RMD160 c1274bdccf57603d580de0075ba07a35b7509560 SHA1 6f78f604e3d079d39189b40aaaa1ddb06182ad91 SHA256 5101ab0d4cc8c7125eea733c44e86962769bd77acaf53b69223b9cadcdd29055
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iF4EAREIAAYFAk7w4tsACgkQaC/OocHi7JaZiwD/Z8bGwDIJn4GifoZybr4LdDLx
+xWdsN9/YrRNX4H60dxwA/11qi8TR1/K65Zmx0hHseHuRKYQCOH/YicaoRZJ8zPOK
+=gHs6
+-----END PGP SIGNATURE-----
diff --git a/virtual/opencl/metadata.xml b/virtual/opencl/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/virtual/opencl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/virtual/opencl/opencl-0.ebuild b/virtual/opencl/opencl-0.ebuild
new file mode 100644
index 000000000000..1318ce2d5b93
--- /dev/null
+++ b/virtual/opencl/opencl-0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/opencl-0.ebuild,v 1.1 2011/12/20 19:32:33 vapier Exp $
+
+EAPI="4"
+
+DESCRIPTION="Virtual for OpenCL implementations"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+CARDS=( fglrx nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+REQUIRED_USE="|| ( ${IUSE} )"
+
+RDEPEND="|| (
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers >=dev-util/nvidia-cuda-toolkit-3.1 )
+ video_cards_fglrx? ( x11-drivers/ati-drivers[opencl] )
+ )"