summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-07-01 19:43:17 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-07-01 19:43:17 +0000
commit5b47ca362251bc5317d6f61eb2c621903cd9e609 (patch)
tree48b3556e46473f08771a998cb8feb94c4933fd0a /www-apache
parentversion bump wrt #229977 (diff)
downloadhistorical-5b47ca362251bc5317d6f61eb2c621903cd9e609.tar.gz
historical-5b47ca362251bc5317d6f61eb2c621903cd9e609.tar.bz2
historical-5b47ca362251bc5317d6f61eb2c621903cd9e609.zip
version bump wrt #230139
Package-Manager: portage-2.2_pre8/cvs/Linux 2.6.22-vs2.2.0.6-gentoo x86_64
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_security/ChangeLog8
-rw-r--r--www-apache/mod_security/mod_security-2.5.5.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/www-apache/mod_security/ChangeLog b/www-apache/mod_security/ChangeLog
index 1e3c92f99304..8e691525f611 100644
--- a/www-apache/mod_security/ChangeLog
+++ b/www-apache/mod_security/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_security
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.14 2008/06/01 12:40:31 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.15 2008/07/01 19:43:17 hollow Exp $
+
+*mod_security-2.5.5 (01 Jul 2008)
+
+ 01 Jul 2008; Benedikt Böhm <hollow@gentoo.org>
+ +mod_security-2.5.5.ebuild:
+ version bump wrt #230139
*mod_security-2.5.4 (01 Jun 2008)
diff --git a/www-apache/mod_security/mod_security-2.5.5.ebuild b/www-apache/mod_security/mod_security-2.5.5.ebuild
new file mode 100644
index 000000000000..b5e23df485db
--- /dev/null
+++ b/www-apache/mod_security/mod_security-2.5.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.5.5.ebuild,v 1.1 2008/07/01 19:43:17 hollow Exp $
+
+inherit apache-module
+
+MY_P=${P/mod_security-/modsecurity-apache_}
+MY_P=${MY_P/_rc/-rc}
+
+DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="lua"
+
+DEPEND="dev-libs/libxml2
+ lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
+APACHE2_MOD_CONF="2.1.2/99_mod_security"
+APACHE2_MOD_DEFINE="SECURITY"
+
+need_apache2
+
+src_compile() {
+ cd apache2
+
+ econf --with-apxs="${APXS}" \
+ --without-curl \
+ $(use_with lua) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ apache-module_src_install
+
+ # install rules updater
+ newbin tools/rules-updater.pl rules-updater
+
+ # install documentation
+ dodoc CHANGES
+ newdoc rules/CHANGELOG CHANGES.crs
+ newdoc rules/README README.crs
+ dohtml doc/*.html doc/*.gif doc/*.jpg doc/*.css doc/*.pdf
+ insinto /usr/share/doc/${P}/html/
+ doins -r doc/html-multipage
+
+ # Prepare the core ruleset
+ sed -i -e 's:logs/:/var/log/apache2/:g' "${S}"/rules/*.conf
+ for i in "${S}"/rules/*.conf; do
+ mv $i ${i/modsecurity_crs_/}
+ done
+
+ # Install core ruleset
+ insinto ${APACHE_MODULES_CONFDIR}/mod_security/
+ doins "${S}"/rules/*.conf
+}