summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-12-09 10:01:47 +0000
committerTim Harder <radhermit@gentoo.org>2010-12-09 10:01:47 +0000
commit8340da8f2ce04e2e9f042b931849e064e6a9d892 (patch)
tree298bc20d34090038b3358cd058be57051bbf3f1d /www-apps/ampache/ampache-3.5.4.ebuild
parentx86 stable wrt bug #347061 (diff)
downloadhistorical-8340da8f2ce04e2e9f042b931849e064e6a9d892.tar.gz
historical-8340da8f2ce04e2e9f042b931849e064e6a9d892.tar.bz2
historical-8340da8f2ce04e2e9f042b931849e064e6a9d892.zip
Version bump (bug #307263 by Adam Grissom). Add USE flags to install optional dependencies for the default transcoding support (bug #249306 by Vytautas Jakutis).
Package-Manager: portage-2.2.0_alpha7/cvs/Linux x86_64
Diffstat (limited to 'www-apps/ampache/ampache-3.5.4.ebuild')
-rw-r--r--www-apps/ampache/ampache-3.5.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/ampache/ampache-3.5.4.ebuild b/www-apps/ampache/ampache-3.5.4.ebuild
new file mode 100644
index 000000000000..1180776b6730
--- /dev/null
+++ b/www-apps/ampache/ampache-3.5.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.5.4.ebuild,v 1.1 2010/12/09 10:01:47 radhermit Exp $
+
+EAPI="2"
+
+inherit webapp depend.php
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface."
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="aac flac mp3 ogg transcode"
+
+RDEPEND="dev-lang/php[gd,hash,iconv,mysql,session,unicode,xml,zlib]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ transcode? ( media-sound/lame
+ aac? ( || ( media-libs/faad2 media-sound/alac_decoder ) )
+ flac? ( media-libs/flac )
+ mp3? ( media-sound/mp3splt )
+ ogg? ( media-sound/mp3splt media-sound/vorbis-tools )
+ )"
+DEPEND=""
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Install and upgrade instructions can be found here:"
+ elog " /usr/share/doc/${P}/INSTALL.gz"
+ elog " /usr/share/doc/${P}/MIGRATION.gz"
+ webapp_pkg_postinst
+}