summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-15 22:02:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-15 22:02:23 +0000
commit6c9d3ab143ae3e73aa6a50e6ee6e9a4015b15407 (patch)
tree4a263bb160556cbb8efa5fdced5eb3118258b043 /www-apps/roundup/roundup-1.4.16.ebuild
parentDelete older ebuilds. (diff)
downloadhistorical-6c9d3ab143ae3e73aa6a50e6ee6e9a4015b15407.tar.gz
historical-6c9d3ab143ae3e73aa6a50e6ee6e9a4015b15407.tar.bz2
historical-6c9d3ab143ae3e73aa6a50e6ee6e9a4015b15407.zip
Version bump. Don't install useless and partially broken roundup script.
Package-Manager: portage-2.2_rc96_p20/cvs/Linux x86_64
Diffstat (limited to 'www-apps/roundup/roundup-1.4.16.ebuild')
-rw-r--r--www-apps/roundup/roundup-1.4.16.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/roundup/roundup-1.4.16.ebuild b/www-apps/roundup/roundup-1.4.16.ebuild
new file mode 100644
index 000000000000..172b08211d7a
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/roundup-1.4.16.ebuild,v 1.1 2010/10/15 22:02:23 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces."
+HOMEPAGE="http://roundup.sourceforge.net http://pypi.python.org/pypi/roundup"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/db-3.2.9"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+src_install() {
+ distutils_src_install
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.ini file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}