summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-09-12 03:46:59 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-09-12 03:46:59 +0000
commitb6b424ef1ea5c615b33584a37f8914806246ce81 (patch)
tree5903fe0b4d29e0f8a8ee2ce16e87f26131a43879 /www-apps/tikiwiki
parentStable x86; bug #132536 (diff)
downloadhistorical-b6b424ef1ea5c615b33584a37f8914806246ce81.tar.gz
historical-b6b424ef1ea5c615b33584a37f8914806246ce81.tar.bz2
historical-b6b424ef1ea5c615b33584a37f8914806246ce81.zip
Version bump
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'www-apps/tikiwiki')
-rw-r--r--www-apps/tikiwiki/ChangeLog7
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.53
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.5.ebuild83
3 files changed, 92 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index f5cdcc534444..c34bacbc8ca8 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.32 2006/07/09 21:11:39 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.33 2006/09/12 03:46:59 rl03 Exp $
+
+*tikiwiki-1.9.5 (12 Sep 2006)
+
+ 12 Sep 2006; Renat Lumpau <rl03@gentoo.org> +tikiwiki-1.9.5.ebuild:
+ Version bump
09 Jul 2006; Renat Lumpau <rl03@gentoo.org> -tikiwiki-1.9.3.2.ebuild,
tikiwiki-1.9.4.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.5 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.5
new file mode 100644
index 000000000000..1fd4a55ed8c8
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.5
@@ -0,0 +1,3 @@
+MD5 70b8be361c95b93fb0d71aa2beba2efc tikiwiki-1.9.5.tar.bz2 5940653
+RMD160 9617995c6b9300ae2585648b507880342f1f25cb tikiwiki-1.9.5.tar.bz2 5940653
+SHA256 1ed2290a9342282b87cbf32989a263f1bcbef3a9e90584c2a1483d5f8cbf6d06 tikiwiki-1.9.5.tar.bz2 5940653
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.5.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.5.ebuild
new file mode 100644
index 000000000000..c9819d22a4ee
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.5.ebuild,v 1.1 2006/09/12 03:46:59 rl03 Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/php
+ mysql? ( >=dev-db/mysql-4 )
+ postgres? ( dev-db/postgresql )
+ graphviz? ( media-gfx/graphviz )
+"
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* ${D}/${MY_HTDOCSDIR}
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned ${MY_HTDOCSDIR}
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned ${MY_HTDOCSDIR}/${DIRENTRY}
+ done
+ done
+ webapp_serverowned ${MY_HTDOCSDIR}/tiki-install.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}
+
+pkg_config() {
+ elog "Type in your MySQL root password to create an empty tiki database:"
+ mysqladmin -u root -p create tikiwiki
+}
+
+pkg_postinst() {
+ elog "To setup a MySQL database, run:"
+ elog "\"emerge --config =${PF}\""
+ elog "If you are using PostgreSQL, consult your documentation"
+ webapp_pkg_postinst
+}