summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-11-24 19:14:58 +0000
committerDon Seiler <rizzo@gentoo.org>2004-11-24 19:14:58 +0000
commitbb5a112bcad537bf63ccbaf721ff60b3ed39177f (patch)
treeef853e23faec33dfb74127ab257a6d50dd4dce65 /www-apps
parentbump (diff)
downloadhistorical-bb5a112bcad537bf63ccbaf721ff60b3ed39177f.tar.gz
historical-bb5a112bcad537bf63ccbaf721ff60b3ed39177f.tar.bz2
historical-bb5a112bcad537bf63ccbaf721ff60b3ed39177f.zip
Version bump
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpwebsite/ChangeLog7
-rw-r--r--www-apps/phpwebsite/Manifest8
-rw-r--r--www-apps/phpwebsite/files/digest-phpwebsite-0.10.01
-rw-r--r--www-apps/phpwebsite/phpwebsite-0.10.0.ebuild43
4 files changed, 55 insertions, 4 deletions
diff --git a/www-apps/phpwebsite/ChangeLog b/www-apps/phpwebsite/ChangeLog
index ba572f2aec6d..eeec72a48791 100644
--- a/www-apps/phpwebsite/ChangeLog
+++ b/www-apps/phpwebsite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/phpwebsite
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/ChangeLog,v 1.12 2004/11/24 09:00:57 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/ChangeLog,v 1.13 2004/11/24 19:14:57 rizzo Exp $
+
+*phpwebsite-0.10.0 (24 Nov 2004)
+
+ 24 Nov 2004; Don Seiler <rizzo@gentoo.org> +phpwebsite-0.10.0.ebuild:
+ Version bump
06 Nov 2004; Joseph Jezak <josejx@gentoo.org>
phpwebsite-0.9.3_p4-r2.ebuild:
diff --git a/www-apps/phpwebsite/Manifest b/www-apps/phpwebsite/Manifest
index c79c417573d5..53216dc91664 100644
--- a/www-apps/phpwebsite/Manifest
+++ b/www-apps/phpwebsite/Manifest
@@ -1,7 +1,9 @@
-MD5 97c45fab88dfe99b03c33df458775605 ChangeLog 4603
+MD5 8c706cf9d9d48e5e098270ee968762be ChangeLog 4724
MD5 ecbb5a02001856289bc050635b8d8394 metadata.xml 522
+MD5 468a346903bb2b14f46837ffad41bb46 phpwebsite-0.10.0.ebuild 1434
MD5 ca75e49de177c3027396292eccf0328b phpwebsite-0.9.3_p4-r1.ebuild 1636
MD5 4591aa9f72c7737a453f241999fb0343 phpwebsite-0.9.3_p4-r2.ebuild 1855
-MD5 823ff723bde0deb5142a1753183467fd files/digest-phpwebsite-0.9.3_p4-r1 157
-MD5 9db128d972b5f4cbbda4723ba50699d7 files/postinstall-en.txt 466
MD5 6ddbbfb4f4e1e5c4d8bf717835d3c2d8 files/digest-phpwebsite-0.9.3_p4-r2 239
+MD5 dab689c75fd084b695c69c427aa758b8 files/digest-phpwebsite-0.10.0 75
+MD5 9db128d972b5f4cbbda4723ba50699d7 files/postinstall-en.txt 466
+MD5 823ff723bde0deb5142a1753183467fd files/digest-phpwebsite-0.9.3_p4-r1 157
diff --git a/www-apps/phpwebsite/files/digest-phpwebsite-0.10.0 b/www-apps/phpwebsite/files/digest-phpwebsite-0.10.0
new file mode 100644
index 000000000000..598ec0e85c53
--- /dev/null
+++ b/www-apps/phpwebsite/files/digest-phpwebsite-0.10.0
@@ -0,0 +1 @@
+MD5 6d433111d1a40b6e94c0a33bd7f01a8f phpwebsite-0.10.0-full.tar.gz 4615559
diff --git a/www-apps/phpwebsite/phpwebsite-0.10.0.ebuild b/www-apps/phpwebsite/phpwebsite-0.10.0.ebuild
new file mode 100644
index 000000000000..8d46ea989683
--- /dev/null
+++ b/www-apps/phpwebsite/phpwebsite-0.10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/phpwebsite-0.10.0.ebuild,v 1.1 2004/11/24 19:14:57 rizzo Exp $
+
+inherit webapp
+
+MY_PV="${PV/_p/-}"
+DESCRIPTION="phpWebSite Content Management System"
+HOMEPAGE="http://phpwebsite.appstate.edu"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}-full.tar.gz"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+RDEPEND="virtual/httpd-php
+ >=dev-db/mysql-3.23.23"
+
+DEPEND="${DEPEND} ${RDEPEND} >=net-www/webapp-config-1.10-r5"
+
+S="${WORKDIR}/${PN}-${MY_PV}-full"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="docs/CREDITS.txt docs/REQUIREMENTS.txt docs/UNINSTALL.txt docs/THEMES.txt docs/LICENSE.txt docs/README.txt docs/PEARERRORS.txt docs/sample.config.php docs/INSTALL.txt docs/CONVERSION.txt docs/UPGRADE.txt docs/KNOWNISSUES.txt"
+ dodoc ${docs}
+
+ einfo "Installing main files"
+ cp -r * ${D}${MY_HTDOCSDIR}
+
+ #webapp_configfile ${MY_HTDOCSDIR}/conf/config.php
+
+ # Files that need to be owned by webserver
+ webapp_serverowned ${MY_HTDOCSDIR}/conf
+ webapp_serverowned ${MY_HTDOCSDIR}/files
+ webapp_serverowned ${MY_HTDOCSDIR}/images
+ webapp_serverowned ${MY_HTDOCSDIR}/images/mod
+ webapp_serverowned ${MY_HTDOCSDIR}/images/mod/controlpanel
+ webapp_serverowned ${MY_HTDOCSDIR}/mod
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}