summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-04-25 12:44:50 +0000
committerJeroen Roovers <jer@gentoo.org>2013-04-25 12:44:50 +0000
commitc677153c28122a8c3a71ae978d0520b9a6baae9f (patch)
tree9880e9be5618ed009ebf035ddd2bdd80433e005f /www-client/dillo/dillo-3.0.3.ebuild
parentdev-tcltk/tkimg: Add patch for libpng-1.6, thanks Johan Hattne, #465828 (diff)
downloadhistorical-c677153c28122a8c3a71ae978d0520b9a6baae9f.tar.gz
historical-c677153c28122a8c3a71ae978d0520b9a6baae9f.tar.bz2
historical-c677153c28122a8c3a71ae978d0520b9a6baae9f.zip
Version bump.
Package-Manager: portage-2.2.0_alpha173/cvs/Linux x86_64 Manifest-Sign-Key: 0xA792A613
Diffstat (limited to 'www-client/dillo/dillo-3.0.3.ebuild')
-rw-r--r--www-client/dillo/dillo-3.0.3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/www-client/dillo/dillo-3.0.3.ebuild b/www-client/dillo/dillo-3.0.3.ebuild
new file mode 100644
index 000000000000..aa170eb3f19d
--- /dev/null
+++ b/www-client/dillo/dillo-3.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-3.0.3.ebuild,v 1.1 2013/04/25 12:44:42 jer Exp $
+
+EAPI=5
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="http://www.dillo.org/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +gif ipv6 +jpeg +png ssl"
+
+RDEPEND="sys-libs/zlib
+ >=x11-libs/fltk-1.3:1[-cairo]
+ jpeg? ( virtual/jpeg )
+ png? ( >=media-libs/libpng-1.2:0 )
+ ssl? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}2-inbuf.patch
+}
+
+src_configure() {
+ append-ldflags "-L/usr/$(get_libdir)/fltk"
+
+ econf \
+ $(use_enable gif) \
+ $(use_enable ipv6) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable ssl) \
+ --docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ dodir /etc
+ default
+
+ use doc && dohtml html/*
+ dodoc AUTHORS ChangeLog README NEWS
+ dodoc doc/*.txt doc/README
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Dillo
+}
+
+pkg_postinst() {
+ elog "Dillo has installed a default configuration into /etc/dillo/dillorc"
+ elog "You can copy this to ~/.dillo/ and customize it"
+}