summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-12-05 22:03:41 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-12-05 22:03:41 +0000
commit7fa458a913a48ba8a3ac407ff7264dda80a4304b (patch)
tree57b3f17759676c9b5043ea8e8a6b3ed6956af207 /www-client/seamonkey-bin
parentDisable the automatic fortify patch for some older linux hosts, bug 289757 (diff)
downloadhistorical-7fa458a913a48ba8a3ac407ff7264dda80a4304b.tar.gz
historical-7fa458a913a48ba8a3ac407ff7264dda80a4304b.tar.bz2
historical-7fa458a913a48ba8a3ac407ff7264dda80a4304b.zip
Ebuild improvements
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64
Diffstat (limited to 'www-client/seamonkey-bin')
-rw-r--r--www-client/seamonkey-bin/ChangeLog5
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild18
2 files changed, 20 insertions, 3 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 0ae385ab485e..9a614fca3cda 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.108 2011/11/23 23:01:00 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.109 2011/12/05 22:01:56 polynomial-c Exp $
+
+ 05 Dec 2011; Lars Wendler <polynomial-c@gentoo.org> seamonkey-bin-2.5.ebuild:
+ Ebuild improvements.
23 Nov 2011; Lars Wendler <polynomial-c@gentoo.org> seamonkey-bin-2.5.ebuild:
Use nsplugins.eclass to handle the plugins directory.
diff --git a/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild b/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild
index 46da44f2d618..6f1823913beb 100644
--- a/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild
+++ b/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild,v 1.2 2011/11/23 23:01:00 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild,v 1.3 2011/12/05 22:01:56 polynomial-c Exp $
EAPI="4"
-inherit eutils mozilla-launcher multilib mozextension pax-utils nsplugins
+inherit eutils mozilla-launcher multilib mozextension pax-utils nsplugins fdo-mime gnome2-utils
LANGS=(be ca cs de en-GB en-US es-AR es-ES fi fr gl hu it
ja lt nb-NO nl pl pt-PT ru sk sv-SE tr zh-CN)
@@ -142,3 +142,17 @@ EOF
# Required in order to use plugins and even run seamonkey on hardened.
pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/{seamonkey,seamonkey-bin,plugin-container}
}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}