summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-02-06 22:02:52 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-02-06 22:02:52 +0000
commitda82745522a5953847193f13435129b90b777d9d (patch)
tree484edc32196cf4d5737f754bf1055f0ba6c1d2b7 /www-misc/zoneminder/files
parentMake USE=doc build work (fix dependencies) and USE=-doc not build the docs, f... (diff)
downloadhistorical-da82745522a5953847193f13435129b90b777d9d.tar.gz
historical-da82745522a5953847193f13435129b90b777d9d.tar.bz2
historical-da82745522a5953847193f13435129b90b777d9d.zip
Version bump
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'www-misc/zoneminder/files')
-rw-r--r--www-misc/zoneminder/files/Makefile.am.patch13
-rw-r--r--www-misc/zoneminder/files/conf.d6
-rw-r--r--www-misc/zoneminder/files/digest-zoneminder-1.22.01
-rw-r--r--www-misc/zoneminder/files/init.d21
-rw-r--r--www-misc/zoneminder/files/postinstall-2.txt20
-rw-r--r--www-misc/zoneminder/files/postupgrade.txt12
6 files changed, 73 insertions, 0 deletions
diff --git a/www-misc/zoneminder/files/Makefile.am.patch b/www-misc/zoneminder/files/Makefile.am.patch
new file mode 100644
index 000000000000..f8fe519889a5
--- /dev/null
+++ b/www-misc/zoneminder/files/Makefile.am.patch
@@ -0,0 +1,13 @@
+--- Makefile.am 2005-12-21 06:59:46.000000000 -0500
++++ Makefile.am.patched 2006-01-17 09:28:15.000000000 -0500
+@@ -22,8 +22,8 @@ EXTRA_DIST = \
+ # Yes, you are correct. This is a HACK!
+ install-data-hook:
+ ( cd $(DESTDIR)$(sysconfdir); chown $(webuser):$(webgroup) $(sysconf_DATA); chmod 600 $(sysconf_DATA) )
+- -( if ! test -e $(RUNDIR); then mkdir $(RUNDIR); fi )
+- ( if ! test -e $(ZM_RUNDIR); then mkdir $(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(ZM_RUNDIR); chmod u+w $(ZM_RUNDIR) )
++ -( if ! test -e $(DESTDIR)$(RUNDIR); then mkdir $(DESTDIR)$(RUNDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_RUNDIR); then mkdir $(DESTDIR)$(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_RUNDIR); chmod u+w $(DESTDIR)$(ZM_RUNDIR) )
+
+ uninstall-hook:
+ @-( cd $(DESTDIR)$(webdir); rm -rf events graphics images sounds temp )
diff --git a/www-misc/zoneminder/files/conf.d b/www-misc/zoneminder/files/conf.d
new file mode 100644
index 000000000000..d2e03363867a
--- /dev/null
+++ b/www-misc/zoneminder/files/conf.d
@@ -0,0 +1,6 @@
+ZM_SCRIPT=/usr/bin/zmpkg.pl
+
+# Commands for starting and stopping the server
+
+CMD_START="${ZM_SCRIPT} start"
+CMD_STOP="${ZM_SCRIPT} stop"
diff --git a/www-misc/zoneminder/files/digest-zoneminder-1.22.0 b/www-misc/zoneminder/files/digest-zoneminder-1.22.0
new file mode 100644
index 000000000000..e3b0380efc2b
--- /dev/null
+++ b/www-misc/zoneminder/files/digest-zoneminder-1.22.0
@@ -0,0 +1 @@
+MD5 f5f9e029f1b7c96bcfe93c49697a60c3 ZoneMinder-1.22.0.tar.gz 1178414
diff --git a/www-misc/zoneminder/files/init.d b/www-misc/zoneminder/files/init.d
new file mode 100644
index 000000000000..d0cbb53ca925
--- /dev/null
+++ b/www-misc/zoneminder/files/init.d
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/files/init.d,v 1.1 2006/02/06 22:02:52 rl03 Exp $
+
+depend() {
+ need mysql
+ use net
+}
+
+start() {
+ ebegin "Starting zoneminder"
+ eval ${CMD_START}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping zoneminder"
+ eval ${CMD_STOP}
+ eend $?
+}
diff --git a/www-misc/zoneminder/files/postinstall-2.txt b/www-misc/zoneminder/files/postinstall-2.txt
new file mode 100644
index 000000000000..b41d8ddb558a
--- /dev/null
+++ b/www-misc/zoneminder/files/postinstall-2.txt
@@ -0,0 +1,20 @@
+1. If this is a new installation, you will need to create a database for ZM to
+ use. Execute the following:
+
+ cd /usr/share/${PN}
+ mysql mysql < db/zm_create.sql
+ mysql mysql
+ > grant select,insert,update,delete on <your database name>.* to '<username>'@localhost identified by '<password>';
+ > quit
+ mysqladmin reload
+
+2. Edit /etc/zm.conf:
+ ZM_PATH_BUILD => /usr/share/${PN}
+ ZM_PATH_WEB => ${MY_INSTALLDIR}
+ ZM_PATH_CGI => ${VHOST_CGIBINDIR}
+
+ Also set your database settings.
+
+3. Login: http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/zm.php
+
+Default username/password are admin/admin.
diff --git a/www-misc/zoneminder/files/postupgrade.txt b/www-misc/zoneminder/files/postupgrade.txt
new file mode 100644
index 000000000000..35a4f27d3f84
--- /dev/null
+++ b/www-misc/zoneminder/files/postupgrade.txt
@@ -0,0 +1,12 @@
+1. If you are upgrading, you will need to run the zmupdate.pl script:
+
+ /usr/bin/zmupdate.pl version=<from version> [--user=<database user> --pass=<database password>]
+
+2. Edit /etc/zm.conf:
+ ZM_PATH_BUILD => /usr/share/${PN}
+ ZM_PATH_WEB => ${MY_INSTALLDIR}
+ ZM_PATH_CGI => ${VHOST_CGIBINDIR}
+
+ Also set your database settings.
+
+3. Login: http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/zm.php