summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-08-16 14:34:54 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-08-16 14:34:54 +0000
commit6648349e7241fae76ad2fe70580ecfda51881f8b (patch)
treebc7c68d9563a6c593e1ecefde4f3dcd7064ae906 /www-servers/lighttpd/lighttpd-1.3.16.ebuild
parentrevision bump and removed older (security problematic) versions (diff)
downloadhistorical-6648349e7241fae76ad2fe70580ecfda51881f8b.tar.gz
historical-6648349e7241fae76ad2fe70580ecfda51881f8b.tar.bz2
historical-6648349e7241fae76ad2fe70580ecfda51881f8b.zip
Removed zope patch for 1.3.16 since it should be fixed (in a different way) in that version. Also updated all ebuilds to use -1 instead of /bin/false when calling enewuser.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'www-servers/lighttpd/lighttpd-1.3.16.ebuild')
-rw-r--r--www-servers/lighttpd/lighttpd-1.3.16.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/www-servers/lighttpd/lighttpd-1.3.16.ebuild b/www-servers/lighttpd/lighttpd-1.3.16.ebuild
index 1151eb206c2a..9b8410f5ea99 100644
--- a/www-servers/lighttpd/lighttpd-1.3.16.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.3.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.3.16.ebuild,v 1.3 2005/08/12 18:05:28 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.3.16.ebuild,v 1.4 2005/08/16 14:34:54 ka0ttic Exp $
inherit eutils
@@ -32,7 +32,7 @@ LOG_DIR="/var/log/lighttpd/"
pkg_setup() {
enewgroup lighttpd
- enewuser lighttpd -1 /bin/false "${LIGHTTPD_DIR}" lighttpd
+ enewuser lighttpd -1 -1 "${LIGHTTPD_DIR}" lighttpd
}
src_unpack() {
@@ -42,7 +42,6 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-1.3.13-no-mysql-means-no-mysql.diff
epatch ${FILESDIR}/${PN}-1.3.13-ldap-binddn.diff
use php && epatch ${FILESDIR}/${PN}-1.3.13-php.diff
- epatch ${FILESDIR}/${P}-zope-deserves-lovins-too.diff
}
src_compile() {
@@ -51,7 +50,7 @@ src_compile() {
einfo "Regenerating automake/autoconf files"
autoreconf -f -i || die "autoreconf failed"
- econf ${myconf} \
+ econf --libdir=/usr/$(get_libdir)/${PN} \
$(use_enable ipv6) \
$(use_with mysql) \
$(use_with ldap) \