summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-11 15:02:35 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-11 15:02:35 +0000
commit6d7a3d98b0cf97ce25bc97579974a88a5f20ee02 (patch)
tree67b2cfc34b5e17103deb259e4a534872241cf0d7 /www-servers/nginx
parentMark 1.0.0 stable on ia64 (diff)
downloadhistorical-6d7a3d98b0cf97ce25bc97579974a88a5f20ee02.tar.gz
historical-6d7a3d98b0cf97ce25bc97579974a88a5f20ee02.tar.bz2
historical-6d7a3d98b0cf97ce25bc97579974a88a5f20ee02.zip
* bump
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.543
-rw-r--r--www-servers/nginx/nginx-0.3.54.ebuild78
3 files changed, 88 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index bd0b571fd7ff..845b4ca42263 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.100 2006/07/08 12:11:34 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.101 2006/07/11 15:02:35 voxus Exp $
+
+*nginx-0.3.54 (11 Jul 2006)
+
+ 11 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.54.ebuild,
+ -nginx-0.3.53-r1.ebuild:
+ Bump.
*nginx-0.3.53-r1 (08 Jul 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.54 b/www-servers/nginx/files/digest-nginx-0.3.54
new file mode 100644
index 000000000000..6024e480c273
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.54
@@ -0,0 +1,3 @@
+MD5 231eb4697627830d10d71943703db59a nginx-0.3.54.tar.gz 407906
+RMD160 cd08c7e47ab8fb56099545c5c8dfac0e3f9e4fb7 nginx-0.3.54.tar.gz 407906
+SHA256 f2983cfc238925bbfcadc507f8795c9c013ec14e6ed90546a777683ab74afec4 nginx-0.3.54.tar.gz 407906
diff --git a/www-servers/nginx/nginx-0.3.54.ebuild b/www-servers/nginx/nginx-0.3.54.ebuild
new file mode 100644
index 000000000000..665021d3ecb2
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.54.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.54.ebuild,v 1.1 2006/07/11 15:02:35 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}