summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-28 13:47:01 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-28 13:47:01 +0000
commit9e6ecd23f0dd5613f6fd817106af603376af6fab (patch)
tree8d35024df5a45df4475a29762a69ffb067cfb8cd /www-servers
parentVersion bump; 2.6.1 stable on x86. Fixed deps. (diff)
downloadhistorical-9e6ecd23f0dd5613f6fd817106af603376af6fab.tar.gz
historical-9e6ecd23f0dd5613f6fd817106af603376af6fab.tar.bz2
historical-9e6ecd23f0dd5613f6fd817106af603376af6fab.zip
Added static support via USE=static for bug 84482.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/ChangeLog5
-rw-r--r--www-servers/pound/Manifest14
-rw-r--r--www-servers/pound/pound-1.8.3.ebuild9
3 files changed, 18 insertions, 10 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index a737cdab13c7..523c7c34c4be 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-servers/pound
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.7 2005/04/30 08:02:31 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.8 2005/06/28 13:47:01 ka0ttic Exp $
+
+ 28 Jun 2005; Aaron Walker <ka0ttic@gentoo.org> pound-1.8.3.ebuild:
+ Added static support via USE=static for bug 84482.
30 Apr 2005; Bryan Østergaard <kloeri@gentoo.org> pound-1.8.3.ebuild:
Stable on alpha, bug 90851.
diff --git a/www-servers/pound/Manifest b/www-servers/pound/Manifest
index bcbef6590815..7997eb5bedb5 100644
--- a/www-servers/pound/Manifest
+++ b/www-servers/pound/Manifest
@@ -1,18 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+MD5 80c79efb58b6ace68114f624e843a564 pound-1.8.3.ebuild 1149
MD5 05792285ec2b1c8a753313e5d1574eb4 pound-1.7.ebuild 1149
-MD5 7bc6c1abd501624d45d2a8fa9a29fc87 ChangeLog 2277
+MD5 fcfb8a9fd918193533aa6251bccf282c ChangeLog 2401
MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
-MD5 281e5ab742cee73151c7ea502755bacd pound-1.8.3.ebuild 1079
-MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
MD5 887a882063050c34c66dcfb8091711bf files/pound.init 583
-MD5 a5bfd8880ab9b367f5333083252548db files/digest-pound-1.7 58
MD5 1b3ef0c3cf70a54e0ea0c16066ea3261 files/digest-pound-1.8.3 60
+MD5 a5bfd8880ab9b367f5333083252548db files/digest-pound-1.7 58
+MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCczuyKf2g/qXtneoRApOIAJsGd95mRuwchLk1U6zscu7TumMbbACglQdo
-kN97CIaMba6dplrpNRj+5PI=
-=mQ+Y
+iD8DBQFCwVUvEZCkKN40op4RAmDUAJ9kaeaOn/YlSmde9kdFTr2KMheFrACePg57
+3q6SXne63ITsJSJOMwutvJM=
+=TZom
-----END PGP SIGNATURE-----
diff --git a/www-servers/pound/pound-1.8.3.ebuild b/www-servers/pound/pound-1.8.3.ebuild
index e1b3036e1469..d26ba81feba0 100644
--- a/www-servers/pound/pound-1.8.3.ebuild
+++ b/www-servers/pound/pound-1.8.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.8.3.ebuild,v 1.3 2005/04/30 08:02:31 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.8.3.ebuild,v 1.4 2005/06/28 13:47:01 ka0ttic Exp $
+
+inherit flag-o-matic
MY_P="${P/p/P}"
DESCRIPTION="A http/https reverse-proxy and load-balancer."
@@ -10,7 +12,7 @@ HOMEPAGE="http://www.apsis.ch/pound/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa"
-IUSE="ssl msdav unsafe"
+IUSE="ssl msdav unsafe static"
DEPEND="virtual/libc
ssl? ( dev-libs/openssl )"
@@ -18,11 +20,14 @@ DEPEND="virtual/libc
S="${WORKDIR}/${MY_P}"
src_compile() {
+ use static && append-ldflags -static
+
econf \
$(use_with ssl) \
$(use_enable msdav) \
$(use_enable unsafe) \
|| die "configure failed"
+
emake || die "compile failed"
}