summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-11-27 05:33:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-11-27 05:33:45 +0000
commit775a85b1ff59b3b70367db78941bed7ae886253c (patch)
tree7547f07e0145981f13eae78ee7976a049e44567e /x11-libs/gl2ps/gl2ps-1.3.6.ebuild
parentBuild in the source tree. (diff)
downloadhistorical-775a85b1ff59b3b70367db78941bed7ae886253c.tar.gz
historical-775a85b1ff59b3b70367db78941bed7ae886253c.tar.bz2
historical-775a85b1ff59b3b70367db78941bed7ae886253c.zip
Version bump
Package-Manager: portage-2.1.10.37/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/gl2ps/gl2ps-1.3.6.ebuild')
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/gl2ps/gl2ps-1.3.6.ebuild b/x11-libs/gl2ps/gl2ps-1.3.6.ebuild
new file mode 100644
index 000000000000..5cd7e92ebae2
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.6.ebuild,v 1.1 2011/11/27 05:33:45 bicatali Exp $
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+DEPEND="
+ media-libs/freeglut
+ png? ( media-libs/libpng )
+ doc? ( dev-tex/tth dev-texlive/texlive-latex )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${P}-CMakeLists.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable png PNG)
+ $(cmake-utils_use_enable zlib ZLIB)
+ $(cmake-utils_use_enable doc DOC)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}