summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-02-04 06:01:02 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-02-04 06:01:02 +0000
commit14cefcc44255ef7013b98bcbd3684aecd3393d69 (patch)
tree018e4ee4f16f230d3cd4cac56a01514b57813050 /x11-libs/pango/pango-1.2.1.ebuild
parentfixed first line (diff)
downloadhistorical-14cefcc44255ef7013b98bcbd3684aecd3393d69.tar.gz
historical-14cefcc44255ef7013b98bcbd3684aecd3393d69.tar.bz2
historical-14cefcc44255ef7013b98bcbd3684aecd3393d69.zip
up-ported the smoothhint patch, new version
Diffstat (limited to 'x11-libs/pango/pango-1.2.1.ebuild')
-rw-r--r--x11-libs/pango/pango-1.2.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/pango/pango-1.2.1.ebuild b/x11-libs/pango/pango-1.2.1.ebuild
new file mode 100644
index 000000000000..6320ba2a839d
--- /dev/null
+++ b/x11-libs/pango/pango-1.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.2.1.ebuild,v 1.1 2003/02/04 06:01:02 spider Exp $
+
+inherit eutils libtool
+
+IUSE="doc"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~alpha"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Text rendering and Layout library"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
+HOMEPAGE="http://www.pango.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=dev-libs/glib-2.1.3
+ >=media-libs/fontconfig-2
+ >=media-libs/freetype-2.1.2-r2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9
+ app-text/sgmltools-lite )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Some enhancements from Redhat
+ epatch ${FILESDIR}/pango-1.0.99.020606-xfonts.patch
+ # patch adapted from RH initial patch by <foser@gentoo.org>
+ epatch ${FILESDIR}/${P}-slighthint-gentoo.patch
+}
+
+src_compile() {
+ elibtoolize
+ local myconf=""
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+ if [ -n "$DEBUGBUILD" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf ${myconf} --without-qt || die
+ make || die "serial make failed"
+}
+
+src_install() {
+ einstall
+ rm ${D}/etc/pango/pango.modules
+
+ dodoc AUTHORS ChangeLog COPYING README INSTALL NEWS TODO*
+}
+
+pkg_postinst() {
+ pango-querymodules >/etc/pango/pango.modules
+}