summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 17:58:23 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 17:58:23 +0000
commit9325feb812a5ad4eafc85962b4a833c3a121f3e2 (patch)
tree797c5e4dc8c8c5b4f9575c828bc3bd3b8be60645 /x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
parentfix ChangeLog header (diff)
downloadhistorical-9325feb812a5ad4eafc85962b4a833c3a121f3e2.tar.gz
historical-9325feb812a5ad4eafc85962b4a833c3a121f3e2.tar.bz2
historical-9325feb812a5ad4eafc85962b4a833c3a121f3e2.zip
Add check for qt-core built with use ssl, to fix bug 236781
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.5 i686
Diffstat (limited to 'x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild')
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild b/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
index 8445a55af0a0..4432c0f7e72f 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild,v 1.1 2008/09/19 00:18:17 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild,v 1.2 2008/09/19 17:58:23 yngwin Exp $
EAPI="1"
inherit qt4-build
@@ -23,6 +23,10 @@ tools/designer/src/plugins/qwebview"
QCONFIG_ADD="webkit"
QCONFIG_DEFINE="QT_WEBKIT"
+# see bug 236781
+QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} ssl"
+
src_compile() {
local myconf
myconf="${myconf} -webkit"