summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-06 20:56:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-06 20:56:41 +0000
commit2a0b83d10e3c1b824ec729533e3207f3b63db37c (patch)
treee05f42a3b96687288c58f73114095a30ce74ce7c /x11-libs
parenthuge # of bug fixes (diff)
downloadhistorical-2a0b83d10e3c1b824ec729533e3207f3b63db37c.tar.gz
historical-2a0b83d10e3c1b824ec729533e3207f3b63db37c.tar.bz2
historical-2a0b83d10e3c1b824ec729533e3207f3b63db37c.zip
huge # of bug fixes
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/Manifest4
-rw-r--r--x11-libs/openmotif/files/Mwm.defaults14
-rw-r--r--x11-libs/openmotif/files/digest-openmotif-2.2.2-r2 (renamed from x11-libs/openmotif/files/digest-openmotif-2.2.2)0
-rw-r--r--x11-libs/openmotif/openmotif-2.2.2-r2.ebuild78
-rw-r--r--x11-libs/openmotif/openmotif-2.2.2.ebuild38
5 files changed, 94 insertions, 40 deletions
diff --git a/x11-libs/openmotif/Manifest b/x11-libs/openmotif/Manifest
index ed011c079480..c66df8af9f8c 100644
--- a/x11-libs/openmotif/Manifest
+++ b/x11-libs/openmotif/Manifest
@@ -1,7 +1,7 @@
MD5 bab90541194a08586c684da6f7ca75e7 openmotif-2.1.30-r1.ebuild 930
MD5 81204d17ce9b31bf63e865f933ff635e openmotif-2.2.2-r1.ebuild 1044
-MD5 0a42bafc6a29cfe4e28697f4fdaf8b06 openmotif-2.2.2-r2.ebuild 1832
-MD5 e20b76b989ca2737a1415bada15c8a0e ChangeLog 2405
+MD5 2d4518493a5a4059271949808f15c3cf openmotif-2.2.2-r2.ebuild 1833
+MD5 35a0c3f77bc618ad6fedcf3e76c5e209 ChangeLog 2788
MD5 009fd49058dd31057e2cbdc0c5cbb6a5 files/digest-openmotif-2.2.2-r1 136
MD5 e0b6cf2385221247e7204f63a199c6c3 files/digest-openmotif-2.2.2-r2 68
MD5 818d2d673fe5ee323f93b5a66fb1baca files/digest-openmotif-2.1.30-r1 79
diff --git a/x11-libs/openmotif/files/Mwm.defaults b/x11-libs/openmotif/files/Mwm.defaults
new file mode 100644
index 000000000000..ea91b6fb8d86
--- /dev/null
+++ b/x11-libs/openmotif/files/Mwm.defaults
@@ -0,0 +1,14 @@
+Mwm*fontList: variable
+Mwm*iconClick: False
+Mwm*iconPlacement: top left
+Mwm*moveOpaque: True
+Mwm*rootButtonClick: True
+Mwm*foreground: #000000
+Mwm*background: #B8B8C0
+Mwm*enableThinThickness: True
+Mwm*enableEtchedInMenu: True
+Mwm*menu*fontList: -adobe-helvetica-medium-r-*--*-120-*-*-*-*-*-*
+Mwm*client*title*fontList: -adobe-helvetica-bold-r-*--*-100-*-*-*-*-*-*
+Mwm*icon*fontList: -adobe-helvetica-bold-r-*--*-80-*-*-*-*-*-*
+Mwm*feedback*fontList: -adobe-helvetica-bold-r-*--*-100-*-*-*-*-*-*
+Mwm*multiClickTime: 300
diff --git a/x11-libs/openmotif/files/digest-openmotif-2.2.2 b/x11-libs/openmotif/files/digest-openmotif-2.2.2-r2
index e91e220e3840..e91e220e3840 100644
--- a/x11-libs/openmotif/files/digest-openmotif-2.2.2
+++ b/x11-libs/openmotif/files/digest-openmotif-2.2.2-r2
diff --git a/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild b/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild
new file mode 100644
index 000000000000..ca3fad516ca1
--- /dev/null
+++ b/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild,v 1.1 2003/06/06 20:56:38 seemant Exp $
+
+inherit libtool
+
+MY_P=${P/m/M}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="OpenMotif is a defacto standard graphical user interface on Unix and Unix-like systems"
+HOMEPAGE="http://www.motifzone.org/"
+SRC_URI="ftp://ftp.sgi.com/other/motifzone/2.2/src/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MOTIF"
+KEYWORDS="x86 ppc ~sparc alpha"
+
+PROVIDE="virtual/motif"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/animate-demo.diff
+ epatch ${FILESDIR}/include-order.diff
+}
+
+src_compile() {
+ elibtoolize
+
+ # get around some LANG problems in make (#15119)
+ unset LANG
+
+ econf \
+ --prefix=/usr/X11R6 \
+ --sysconfdir=/etc/X11 \
+ --with-x \
+ --with-gnu-ld || die
+
+ make || die "make failed"
+}
+
+src_install() {
+
+ make DESTDIR=${D} VARDIR=${D}/var/X11/ install || die "install failed"
+
+ prepman /usr/X11R6
+
+ #
+ # patch manpages to reflect actual location of configuration files
+ #
+ einfo "fixing manpages..."
+ list="/usr/X11R6/man/man1/mwm.1 /usr/X11R6/man/man4/mwmrc.4"
+ for f in $list; do
+ einfo " ...${D}/$f"
+ dosed 's:/usr/X11R6/lib/X11/\(.*system\\&\.mwmrc\):/etc/X11/mwm/\1:g' \
+ "$f"
+ dosed 's:/usr/X11R6/lib/X11/app-defaults:/etc/X11/app-defaults:g' \
+ "$f"
+ done
+ unset f list
+
+
+ # Move the system.mwmrc and create symlink
+ dodir /etc/X11/mwm
+ mv ${D}/usr/X11R6/lib/X11/mwm/system.mwmrc $D}/etc/X11/mwm
+ dosym ../../../../etc/X11/mwm/system.mwmrc /usr/X11R6/lib/X11/mwm
+
+
+ # upstream does not include an app-defaults/Mwm file any longer with
+ # 2.2.2
+ into /etc/X11/app-defaults
+ newins ${FILESDIR}/Mwm.defaults Mwm
+
+ dodoc COPYRIGHT* LICENSE* RE* *BUG*
+}
diff --git a/x11-libs/openmotif/openmotif-2.2.2.ebuild b/x11-libs/openmotif/openmotif-2.2.2.ebuild
deleted file mode 100644
index aafddded8bd2..000000000000
--- a/x11-libs/openmotif/openmotif-2.2.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.2.ebuild,v 1.7 2003/05/01 01:50:53 weeve Exp $
-
-S=${WORKDIR}/openMotif-2.2.2
-BUILD=${WORKDIR}/motif-build
-DESCRIPTION="Open Motif"
-SRC_URI="ftp://ftp.sgi.com/other/motifzone/2.2/src/openMotif-2.2.2.tar.gz"
-HOMEPAGE="http://www.motifzone.org/"
-LICENSE="MOTIF"
-SLOT="0"
-KEYWORDS="x86 ppc ~sparc "
-PROVIDE="virtual/motif"
-
-DEPEND="virtual/glibc virtual/x11"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/animate-demo.diff || die "patch failed"
- patch -p1 < ${FILESDIR}/include-order.diff || die "patch failed"
-}
-
-src_compile() {
-
- econf || die "configuration failed"
-
- make || die "make failed"
-
-}
-
-src_install() {
-
- make DESTDIR=${D} VARDIR=${D}/var/X11/ install \
- || die "install failed"
-
-}