summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-16 22:44:29 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-16 22:44:29 +0000
commit63596c6eed4671d76198a03c5c966a037b542aa5 (patch)
tree38fff2f2e5e1b1ab95773ca648ff794c3b4553ea /x11-libs
parentxtrlock is a minimalist screen locker for X (diff)
downloadhistorical-63596c6eed4671d76198a03c5c966a037b542aa5.tar.gz
historical-63596c6eed4671d76198a03c5c966a037b542aa5.tar.bz2
historical-63596c6eed4671d76198a03c5c966a037b542aa5.zip
finally (?) fixed this Xaw3d problem
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild61
-rw-r--r--x11-libs/Xaw3d/Xaw3d-1.5.ebuild85
-rw-r--r--x11-libs/Xaw3d/files/digest-Xaw3d-1.5-r1 (renamed from x11-libs/Xaw3d/files/digest-Xaw3d-1.5)0
3 files changed, 61 insertions, 85 deletions
diff --git a/x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild b/x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild
new file mode 100644
index 000000000000..41075a330d31
--- /dev/null
+++ b/x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+
+# Ok, hopefully this will resolv the problem with the version of libXaw3d that
+# gets created.
+#
+# The problem its seems, is that when X gets compiled, it determines (with the
+# help of some very dark magic) what version libXaw.so it it should build (6.1 or
+# 7.0). Now, when compiling Xaw3d, it checks which version of Xaw was built, and
+# then builds the same version of Xaw3d.
+#
+# Since this ebuild use the Makefile's "install" function, it "should" not be a
+# problem anymore.
+#
+# Azarah.
+
+
+S=${WORKDIR}/xc/lib/Xaw3d
+DESCRIPTION="the Xaw3d is a drop-in 3D replacement of the Xaw widget set
+ which comes with X. It is used e.g. by gv the ghostcript frontend."
+# All full ftp.x.org mirrors can be added here.
+SRC_URI="ftp://ftp.x.org/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz
+ http://ibiblio.org/pub/X11/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz"
+# None so far as I know.
+#HOMEPAGE="http://"
+
+# There _might_ be something else, but I doubt it.
+DEPEND="virtual/x11"
+
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # For some reason it isn't automatically patched.
+ # That's why I manually override the source_unpack function.
+ patch -p0 <${FILESDIR}/Xaw3d-xfree86.diff || die
+ patch -p0 <${FILESDIR}/Xaw3d-out-of-tree.diff || die
+}
+
+src_compile() {
+
+ # convoluted process for out-of-tree building
+ mkdir ./X11
+ cd ./X11 ; ln -sf ../../Xaw3d . ; cd ..
+
+ xmkmf || die
+ make includes || die
+ make depend || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc README.XAW3D
+}
+
diff --git a/x11-libs/Xaw3d/Xaw3d-1.5.ebuild b/x11-libs/Xaw3d/Xaw3d-1.5.ebuild
deleted file mode 100644
index c3981f7f8e37..000000000000
--- a/x11-libs/Xaw3d/Xaw3d-1.5.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/Xaw3d/Xaw3d-1.5.ebuild,v 1.6 2001/09/17 17:11:42 danarmak Exp $
-
-# !! IMPORTANT NOTE !!
-# The Xaw3d widget set is meant to be built as part of the X Consortium's
-# official R6.x tree. Building it against XFree86 creates a problem,
-# hence Xaw3d-xfree86.diff. Building it out-of-tree (i.e. without the
-# entire X source present) creates another problem because, like X,
-# Xaw3d uses Imakefiles which fit into the X hierarchy. Hence Xaw3d-out-of-tree.diff
-# (The problem it takes care of is a missing widec.h)
-# This implementation of the build process, together with the 2 patches,
-# comes from Slackware with very slight modifications introduced. If you
-# want to see the original, go to ftp.slackware.com and into the source -
-# it has standard shell scripts in text files for compiling.
-# Another (similar) set of instructions can be found at the gv homepage:
-# http://wwwthep.physik.uni-mainz.de/~plass/gv/Xaw3d.html
-#
-# NOTE: I did not write these patches. I did rename them, and have a lurking
-# suspicion I confused them and switched the names arond. Someone who is
-# better versed in compiling X and the structure of its Imakefiles might
-# want to take a look at it. But it does work :-)
-
-S=${WORKDIR}/xc/lib/Xaw3d
-
-DESCRIPTION="the Xaw3d is a drop-in 3D replacement of the Xaw widget set
- which comes with X. It is used e.g. by gv the ghostcript frontend."
-
-# All full ftp.x.org mirrors can be added here.
-SRC_URI="ftp://ftp.x.org/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz
- http://ibiblio.org/pub/X11/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz"
-
-# None so far as I know.
-#HOMEPAGE="http://"
-
-# There _might_ be something else, but I doubt it.
-DEPEND="virtual/x11"
-
-src_unpack() {
-
- unpack ${P}.tar.gz
- cd ${S}
-
- # For some reason it isn't automatically patched.
- # That's why I manually override the source_unpack function.
- patch -p0 <${FILESDIR}/Xaw3d-xfree86.diff
- patch -p0 <${FILESDIR}/Xaw3d-out-of-tree.diff
-
-}
-
-src_compile() {
-
- # convoluted process for out-of-tree building
- mkdir ./X11
- cd ./X11 ; ln -sf ../../Xaw3d . ; cd ..
-
- try xmkmf
- try emake
-
-}
-
-src_install () {
-
- # There is no install target in the Makefile.
- # We have to copy everything by hand.
- # Update: usage of ebuild installation functions added by achim, thanks
- # 2nd update: achim's addition did not install library symlinks
- # correctly. I could not find the documentation of the prepdir helper
- # function so I switched back to manual installation for now.
-
- into /usr/X11R6
- dolib.so libXaw3d.so.7.0
- cd ${D}/usr/X11R6/lib
- ln -s libXaw3d.so.7.0 libXaw3d.so.7
- ln -s libXaw3d.so.7.0 libXaw3d.so
-
- # headers
- cd ${S}
- insinto /usr/X11R6/include/X11/Xaw3d
- doins *.h
-
- dodoc README.XAW3D
-}
-
diff --git a/x11-libs/Xaw3d/files/digest-Xaw3d-1.5 b/x11-libs/Xaw3d/files/digest-Xaw3d-1.5-r1
index 2f89de8c301b..2f89de8c301b 100644
--- a/x11-libs/Xaw3d/files/digest-Xaw3d-1.5
+++ b/x11-libs/Xaw3d/files/digest-Xaw3d-1.5-r1