summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-21 19:51:00 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-21 19:51:00 +0000
commit9ca55760a4ceac8491613832e12511fbb3330f37 (patch)
treedba051495ffc3b3b05ab11d7e084c5209db9da4a /x11-libs
parentnew ebuild that generates the kdelibs apidocs using doxygen. is part of kde 3.1. (diff)
downloadhistorical-9ca55760a4ceac8491613832e12511fbb3330f37.tar.gz
historical-9ca55760a4ceac8491613832e12511fbb3330f37.tar.bz2
historical-9ca55760a4ceac8491613832e12511fbb3330f37.zip
rh patch
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/files/gtk+-2.0.6-exportsymbols.patch12
-rw-r--r--x11-libs/gtk+/gtk+-2.0.9.ebuild14
-rw-r--r--x11-libs/gtk+/gtk+-2.1.2.ebuild14
4 files changed, 41 insertions, 7 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 6ef084ceeebd..6f795f78fae3 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.37 2002/11/21 01:16:28 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.38 2002/11/21 19:51:00 azarah Exp $
+
+ 21 Nov 2002; Martin Schlemmer <azarah@gentoo.org> gtk+-2.1.2.ebuild,
+ gtk+-2.0.9.ebuild :
+
+ Turn of --export-symbols-regex for now, since it removes
+ the wrong symbols. Patch from Redhat.
*gtk+-2.0.9 (20 Nov 2002)
diff --git a/x11-libs/gtk+/files/gtk+-2.0.6-exportsymbols.patch b/x11-libs/gtk+/files/gtk+-2.0.6-exportsymbols.patch
new file mode 100644
index 000000000000..e6106e741928
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.0.6-exportsymbols.patch
@@ -0,0 +1,12 @@
+--- gtk+-2.0.6/configure.in.exportsymbols Thu Aug 8 16:46:41 2002
++++ gtk+-2.0.6/configure.in Thu Aug 8 16:47:12 2002
+@@ -273,7 +273,8 @@
+ if test "$os_win32" != yes; then
+ # libtool option to control which symbols are exported
+ # right now, symbols starting with _ are not exported
+- LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^_]].*"'
++ # Disabled until -export-symbols-regex works (RH patch)
++ LIBTOOL_EXPORT_OPTIONS=
+ else
+ # We currently use .def files on Windows (for gdk-pixbuf, gdk and gtk)
+ LIBTOOL_EXPORT_OPTIONS=
diff --git a/x11-libs/gtk+/gtk+-2.0.9.ebuild b/x11-libs/gtk+/gtk+-2.0.9.ebuild
index 453d62684db5..d694b2c4d28d 100644
--- a/x11-libs/gtk+/gtk+-2.0.9.ebuild
+++ b/x11-libs/gtk+/gtk+-2.0.9.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.9.ebuild,v 1.1 2002/11/21 01:16:28 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.9.ebuild,v 1.2 2002/11/21 19:51:00 azarah Exp $
-inherit libtool flag-o-matic
+inherit eutils libtool flag-o-matic
IUSE="tiff doc jpeg directfb"
-S=${WORKDIR}/${P}
+S="${WORKDIR}/${P}"
DESCRIPTION="Gimp ToolKit + "
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
HOMEPAGE="http://www.gtk.org/"
@@ -28,6 +28,14 @@ DEPEND="${RDEPEND}
doc? ( >=dev-util/gtk-doc-0.9
app-text/sgmltools-lite )"
+src_unpack() {
+ unpack ${A}
+
+ # Turn of --export-symbols-regex for now, since it removes
+ # the wrong symbols
+# cd ${S}; epatch ${FILESDIR}/gtk+-2.0.6-exportsymbols.patch
+}
+
src_compile() {
# see bug 8762
replace-flags "-O3" "-O2"
diff --git a/x11-libs/gtk+/gtk+-2.1.2.ebuild b/x11-libs/gtk+/gtk+-2.1.2.ebuild
index 0ca256a037c2..d1ece34e499f 100644
--- a/x11-libs/gtk+/gtk+-2.1.2.ebuild
+++ b/x11-libs/gtk+/gtk+-2.1.2.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.1.2.ebuild,v 1.2 2002/11/21 01:16:28 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.1.2.ebuild,v 1.3 2002/11/21 19:51:00 azarah Exp $
IUSE="tiff doc jpeg directfb"
-inherit libtool flag-o-matic debug
+inherit eutils libtool flag-o-matic debug
SLOT="2"
KEYWORDS="x86"
-S=${WORKDIR}/${P}
+S="${WORKDIR}/${P}"
DESCRIPTION="Gimp ToolKit + "
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
HOMEPAGE="http://www.gtk.org/"
@@ -29,6 +29,14 @@ DEPEND="${RDEPEND}
doc? ( >=dev-util/gtk-doc-0.9
app-text/sgmltools-lite )"
+src_unpack() {
+ unpack ${A}
+
+ # Turn of --export-symbols-regex for now, since it removes
+ # the wrong symbols
+ cd ${S}; epatch ${FILESDIR}/gtk+-2.0.6-exportsymbols.patch
+}
+
src_compile() {
# see bug 8762
replace-flags "-O3" "-O2"