summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-03-15 12:25:10 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-03-15 12:25:10 +0000
commitb8302ec9c1fa96df609a68584bd0aba63990e24f (patch)
treec9e94d04f3367eff953f625d271db2097725c8ce /x11-libs
parentNew ebuild (~masked) Closes #16551 (diff)
downloadhistorical-b8302ec9c1fa96df609a68584bd0aba63990e24f.tar.gz
historical-b8302ec9c1fa96df609a68584bd0aba63990e24f.tar.bz2
historical-b8302ec9c1fa96df609a68584bd0aba63990e24f.zip
Added some flags for hppa. Added hppa to keywords.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog10
-rw-r--r--x11-libs/qt/qt-2.3.2-r1.ebuild4
-rw-r--r--x11-libs/qt/qt-3.1.0-r3.ebuild12
-rw-r--r--x11-libs/qt/qt-3.1.1-r2.ebuild12
4 files changed, 31 insertions, 7 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 4da8e561630d..c48debaebc42 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for x11-libs/qt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.53 2003/02/12 09:24:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.54 2003/03/15 12:25:10 gmsoft Exp $
04 Feb 2003; Hannes Mehnert <hannes@gentoo.org> qt-3.1.0-r3.ebuild,
qt-3.1.1-r2.ebuild: changed dependency from x11-libs/xft to virtual/xft
@@ -10,11 +10,19 @@
*qt-3.1.0-r3 (02 Feb 2003)
+ 15 mar 2003; Guy Martin <gmsoft@gentoo.org> qt-3.1.0-r3.ebuild :
+ Added some flags for a succefull build on hppa.
+ Added hppa to keywords.
+
07 Feb 2003; Jason Wever <weeve@gentoo.org> qt-3.1.0-r3.ebuild ;
Changed ~sparc keyword to sparc.
*qt-3.1.1-r2 (02 Feb 2003)
+ 15 mar 2003; Guy Martin <gmsoft@gentoo.org> qt-3.1.1-r2.ebuild :
+ Added some flags for a succefull build on hppa.
+ Added ~hppa to keywords.
+
02 Feb 2003; Hannes Mehnert <hannes@gentoo.org> qt-3.1.0-r3.ebuild,
qt-3.1.1-r2.ebuild: added xft dependency
diff --git a/x11-libs/qt/qt-2.3.2-r1.ebuild b/x11-libs/qt/qt-2.3.2-r1.ebuild
index d9b940f74600..75028d426be8 100644
--- a/x11-libs/qt/qt-2.3.2-r1.ebuild
+++ b/x11-libs/qt/qt-2.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-2.3.2-r1.ebuild,v 1.17 2003/02/13 17:01:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-2.3.2-r1.ebuild,v 1.18 2003/03/15 12:25:10 gmsoft Exp $
IUSE="gif opengl nas"
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${PV}.tar.gz"
HOMEPAGE="http://www.trolltech.com/"
SLOT="2"
LICENSE="QPL-1.0"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc hppa"
RDEPEND="virtual/x11
media-libs/libpng
diff --git a/x11-libs/qt/qt-3.1.0-r3.ebuild b/x11-libs/qt/qt-3.1.0-r3.ebuild
index 37e1c2982bc9..b063af592686 100644
--- a/x11-libs/qt/qt-3.1.0-r3.ebuild
+++ b/x11-libs/qt/qt-3.1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0-r3.ebuild,v 1.6 2003/02/13 17:02:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0-r3.ebuild,v 1.7 2003/03/15 12:25:10 gmsoft Exp $
inherit eutils
@@ -11,7 +11,7 @@ S=${WORKDIR}/qt-x11-free-${PV}
DESCRIPTION="QT version ${PV}"
SLOT="3"
LICENSE="QPL-1.0"
-KEYWORDS="x86 ~ppc ~alpha sparc"
+KEYWORDS="x86 ~ppc ~alpha sparc hppa"
SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2"
@@ -61,6 +61,14 @@ src_unpack() {
cp qmake.conf qmake.conf.orig
sed -e "s:= gcc:= ${CC}:" qmake.conf.orig > qmake.conf
fi
+
+ # hppa need some additional flags
+ if [ "${ARCH}" = "hppa" ]; then
+ echo "QMAKE_CFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_CXXFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_LFLAGS += -ffunction-sections -Wl,--stub-group-size=25000" >> qmake.conf
+ fi
+
# on alpha we need to compile everything with -fPIC
if [ ${ARCH} == "alpha" ]; then
cp qmake.conf qmake.conf.orig
diff --git a/x11-libs/qt/qt-3.1.1-r2.ebuild b/x11-libs/qt/qt-3.1.1-r2.ebuild
index 467da0e69970..6539f197dac7 100644
--- a/x11-libs/qt/qt-3.1.1-r2.ebuild
+++ b/x11-libs/qt/qt-3.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.1-r2.ebuild,v 1.3 2003/02/13 17:02:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.1-r2.ebuild,v 1.4 2003/03/15 12:25:10 gmsoft Exp $
inherit eutils
@@ -11,7 +11,7 @@ S=${WORKDIR}/qt-x11-free-${PV}
DESCRIPTION="QT version ${PV}"
SLOT="3"
LICENSE="QPL-1.0"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa"
SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2"
@@ -59,6 +59,14 @@ src_unpack() {
cp qmake.conf qmake.conf.orig
sed -e "s:= gcc:= ${CC}:" qmake.conf.orig > qmake.conf
fi
+
+ # hppa need some additional flags
+ if [ "${ARCH}" = "hppa" ]; then
+ echo "QMAKE_CFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_CXXFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_LFLAGS += -ffunction-sections -Wl,--stub-group-size=25000" >> qmake.conf
+ fi
+
# on alpha we need to compile everything with -fPIC
if [ ${ARCH} == "alpha" ]; then
cp qmake.conf qmake.conf.orig