summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-13 23:11:25 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-13 23:11:25 +0000
commit4aa2e5b151911915ac98249b859ac9993ef40534 (patch)
tree717a03ce15124ca0055af6ed112f5a30aa3a62f7 /x11-misc/wdm/wdm-1.26-r1.ebuild
parentadd test cases, fix system detection for linux, and touch up machine syntax (diff)
downloadhistorical-4aa2e5b151911915ac98249b859ac9993ef40534.tar.gz
historical-4aa2e5b151911915ac98249b859ac9993ef40534.tar.bz2
historical-4aa2e5b151911915ac98249b859ac9993ef40534.zip
ebuild cleanup and fix to #93186
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'x11-misc/wdm/wdm-1.26-r1.ebuild')
-rw-r--r--x11-misc/wdm/wdm-1.26-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/wdm/wdm-1.26-r1.ebuild b/x11-misc/wdm/wdm-1.26-r1.ebuild
new file mode 100644
index 000000000000..cc2f56f8156e
--- /dev/null
+++ b/x11-misc/wdm/wdm-1.26-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/wdm-1.26-r1.ebuild,v 1.1 2005/06/13 23:11:25 smithj Exp $
+
+inherit eutils
+
+IUSE="truetype pam png jpeg gif tiff"
+
+DESCRIPTION="WINGs Display Manager"
+HOMEPAGE="http://voins.program.ru/wdm/"
+SRC_URI="http://voins.program.ru/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~alpha"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-wm/windowmaker-0.65.1
+ virtual/x11
+ truetype? ( virtual/xft )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_compile() {
+ econf \
+ --exec-prefix=/usr \
+ --with-wdmdir=/etc/X11/wdm \
+ $(use_enable pam)\
+ $(use_enable png)\
+ $(use_enable jpeg)\
+ $(use_enable gif)\
+ $(use_enable tiff) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ rm -f ${D}/etc/pam.d/wdm
+ newpamd "${FILESDIR}/wdm-include" wdm
+}