summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-06-21 05:48:51 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-06-21 05:48:51 +0000
commit03aaae89a675be985a56a213575a846fb98bbefc (patch)
tree21de7ae756768b52ea85e39cfeca49bf79d3a2dd /x11-misc/xkeyboard-config
parent(#134604) Don't ever compile sunffb DRI driver, the compilation's broken. (diff)
downloadhistorical-03aaae89a675be985a56a213575a846fb98bbefc.tar.gz
historical-03aaae89a675be985a56a213575a846fb98bbefc.tar.bz2
historical-03aaae89a675be985a56a213575a846fb98bbefc.zip
(#130590) Ensure that the old XKB directory gets out of the way (Patrick Allaert).
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog7
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild14
2 files changed, 18 insertions, 3 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index 838c8db9f87f..5e72fb0e66b0 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xkeyboard-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.11 2006/04/16 20:51:44 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.12 2006/06/21 05:47:21 spyderous Exp $
+
+ 21 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ xkeyboard-config-0.8.ebuild:
+ (#130590) Ensure that the old XKB directory gets out of the way (Patrick
+ Allaert).
*xkeyboard-config-0.8 (16 Apr 2006)
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild
index 5978beca2586..de3c9c680d66 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild,v 1.1 2006/04/16 20:51:44 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild,v 1.2 2006/06/21 05:47:21 spyderous Exp $
-inherit eutils
+inherit eutils multilib
DESCRIPTION="X keyboard configuration database"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
@@ -15,6 +15,16 @@ RDEPEND="x11-apps/xkbcomp
DEPEND="${RDEPEND}
dev-perl/XML-Parser"
+pkg_setup() {
+ # (#130590) The old XKB directory can screw stuff up
+ local DIR="${ROOT}usr/$(get_libdir)/X11/xkb"
+ if [[ -d ${DIR} ]] ; then
+ eerror "Directory ${DIR} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${DIR}"
+ fi
+}
+
src_compile() {
econf \
--with-xkb-base=/usr/share/X11/xkb \