summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-01-18 23:22:29 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-01-18 23:22:29 +0000
commit08f4905bdb7d7b31b387c29b55fcab0566af0bb7 (patch)
treef8e230a8cf5f1b2314473301c23857639ebf13db /x11-misc
parentVersion bump, ebuild by Tiziano Muller, bug #235710. Fixes also bug #229065: ... (diff)
downloadhistorical-08f4905bdb7d7b31b387c29b55fcab0566af0bb7.tar.gz
historical-08f4905bdb7d7b31b387c29b55fcab0566af0bb7.tar.bz2
historical-08f4905bdb7d7b31b387c29b55fcab0566af0bb7.zip
Version bump, ebuild by Tim Harder, see bug #255243.
Package-Manager: portage-2.1.6.6/cvs/Linux 2.6.28-tuxonice x86_64
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/grun/ChangeLog9
-rw-r--r--x11-misc/grun/grun-0.9.3.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/x11-misc/grun/ChangeLog b/x11-misc/grun/ChangeLog
index 99d68436934c..1d7bda5ae241 100644
--- a/x11-misc/grun/ChangeLog
+++ b/x11-misc/grun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/grun
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/ChangeLog,v 1.27 2008/12/01 20:36:43 ssuominen Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/ChangeLog,v 1.28 2009/01/18 23:22:29 nelchael Exp $
+
+*grun-0.9.3 (18 Jan 2009)
+
+ 18 Jan 2009; <nelchael@gentoo.org> +grun-0.9.3.ebuild:
+ Version bump, ebuild by Tim Harder <thorium90@gmail.com>, see bug #255243.
01 Dec 2008; <ssuominen@gentoo.org> grun-0.9.2-r1.ebuild:
Run eautoreconf for bug 248567, and use automake 1.9 because the package
diff --git a/x11-misc/grun/grun-0.9.3.ebuild b/x11-misc/grun/grun-0.9.3.ebuild
new file mode 100644
index 000000000000..650b314b5b4b
--- /dev/null
+++ b/x11-misc/grun/grun-0.9.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/grun-0.9.3.ebuild,v 1.1 2009/01/18 23:22:29 nelchael Exp $
+
+inherit eutils
+
+DESCRIPTION="a GTK+ application launcher with nice features such as a history"
+HOMEPAGE="http://code.google.com/p/grun/"
+SRC_URI="http://grun.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ [[ -z ${TERM} ]] && TERM=xterm
+
+ econf $(use_enable nls) --disable-gtktest --enable-testfile \
+ --enable-associations --with-default-xterm=${TERM}
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ einstall || die "einstall failed."
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "It is recommended to bind grun to a keychain. Fluxbox users can"
+ elog "do this by appending e.g. the following line to ~/.fluxbox/keys:"
+ elog
+ elog "Mod4 r :ExecCommand grun"
+ elog
+ elog "Then reconfigure Fluxbox (using the menu) and hit <WinKey>-<r>"
+ elog
+ elog "The default system-wide definition file for associating file"
+ elog "extensions with applications is /usr/share/grun/gassoc, the"
+ elog "default system-wide definition file for recognized console"
+ elog "applications is /usr/share/grun/consfile. They can be overridden"
+ elog "on a per user basis by ~/.gassoc and ~/.consfile respectively."
+ elog
+ elog "To change the default terminal application grun uses, adjust the"
+ elog "TERM environment variable accordingly and remerge grun, e.g."
+ elog
+ elog "TERM=Eterm emerge grun"
+}