summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-02 15:50:36 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-02 15:50:36 +0000
commit973963e019409ed53e5ad5bea1f9d701a0e1102a (patch)
treecfe3cc49ad4062ad001e917ba43da13a81f61f5f /x11-plugins/noscript
parentold (diff)
downloadhistorical-973963e019409ed53e5ad5bea1f9d701a0e1102a.tar.gz
historical-973963e019409ed53e5ad5bea1f9d701a0e1102a.tar.bz2
historical-973963e019409ed53e5ad5bea1f9d701a0e1102a.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'x11-plugins/noscript')
-rw-r--r--x11-plugins/noscript/ChangeLog7
-rw-r--r--x11-plugins/noscript/noscript-1.4.9.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-plugins/noscript/ChangeLog b/x11-plugins/noscript/ChangeLog
index 924996d70889..3284bb793b88 100644
--- a/x11-plugins/noscript/ChangeLog
+++ b/x11-plugins/noscript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/noscript
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.88 2008/02/21 17:12:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.89 2008/03/02 15:50:36 armin76 Exp $
+
+*noscript-1.4.9 (02 Mar 2008)
+
+ 02 Mar 2008; Raúl Porcel <armin76@gentoo.org> +noscript-1.4.9.ebuild:
+ Version bump
*noscript-1.4 (21 Feb 2008)
diff --git a/x11-plugins/noscript/noscript-1.4.9.ebuild b/x11-plugins/noscript/noscript-1.4.9.ebuild
new file mode 100644
index 000000000000..4603fc695dc8
--- /dev/null
+++ b/x11-plugins/noscript/noscript-1.4.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/noscript-1.4.9.ebuild,v 1.1 2008/03/02 15:50:36 armin76 Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Firefox plugin to disable javascript"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-1.5.0.7
+ >=www-client/mozilla-firefox-1.5.0.7
+)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+}