summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-21 20:39:14 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-21 20:39:14 +0000
commitff3b60a7a3be4939fe6b7ca3ad1142c7251a08ef (patch)
treef588780a38b58e60cc34a26f26f0cea1b81bef77 /x11-plugins/pidgintex
parentAdd FreeBSD 8.0 profiles for i686 and x86_64 (diff)
downloadhistorical-ff3b60a7a3be4939fe6b7ca3ad1142c7251a08ef.tar.gz
historical-ff3b60a7a3be4939fe6b7ca3ad1142c7251a08ef.tar.bz2
historical-ff3b60a7a3be4939fe6b7ca3ad1142c7251a08ef.zip
Initial import. Ebuild by me and Constantin Bergemann, bug #219138. Nice alternative for pidgin-latex.
Package-Manager: portage-2.1.7.15/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/pidgintex')
-rw-r--r--x11-plugins/pidgintex/ChangeLog11
-rw-r--r--x11-plugins/pidgintex/Manifest4
-rw-r--r--x11-plugins/pidgintex/metadata.xml15
-rw-r--r--x11-plugins/pidgintex/pidgintex-1.1.1.ebuild43
4 files changed, 73 insertions, 0 deletions
diff --git a/x11-plugins/pidgintex/ChangeLog b/x11-plugins/pidgintex/ChangeLog
new file mode 100644
index 000000000000..6a200dbabf7d
--- /dev/null
+++ b/x11-plugins/pidgintex/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/pidgintex
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgintex/ChangeLog,v 1.1 2009/12/21 20:39:14 pva Exp $
+
+*pidgintex-1.1.1 (21 Dec 2009)
+
+ 21 Dec 2009; Peter Volkov <pva@gentoo.org> +pidgintex-1.1.1.ebuild,
+ +metadata.xml:
+ Initial import. Ebuild by me and Constantin Bergemann, bug #219138. Nice
+ alternative for pidgin-latex.
+
diff --git a/x11-plugins/pidgintex/Manifest b/x11-plugins/pidgintex/Manifest
new file mode 100644
index 000000000000..8121c9cb02b0
--- /dev/null
+++ b/x11-plugins/pidgintex/Manifest
@@ -0,0 +1,4 @@
+DIST pidginTeX-1.1.1.tar.gz 23322 RMD160 b7ab407d229c4b33749bbd5dd491a6221323457d SHA1 7823c26552c8b9878bdbc64675645d6d34a03fc5 SHA256 1b47e89d12d5f5a8de4f3f89ea37da393223d525632c92e71cef8a54399ac1aa
+EBUILD pidgintex-1.1.1.ebuild 1138 RMD160 6a028cc3afe90e1d7626a22f35228f693e8a9214 SHA1 6345d7af161d8629e5c77f8fc88aef903a9e1440 SHA256 66b5b8074e98150b0acea008b980cc9dd12848786ec02bf6ec4c4db6a5eab517
+MISC ChangeLog 439 RMD160 d177997fb90ea7d5bdd5784e69522b1a9d705ad3 SHA1 4e3af78eeffe8688d30b67fcd68a8264faa28f09 SHA256 ea60f39cc44313759634f7d60e1d824cdb234a7568a325156ee71c8d9054d7a7
+MISC metadata.xml 568 RMD160 c87f6f706482066e45ef07b11f3f34314e722f60 SHA1 5e7c9adaa38e9646161955054d9227ba1ac1f012 SHA256 2d4d561da08366d124c8015c81fc71fb5b78278e7b621bb226a588e9854f69a2
diff --git a/x11-plugins/pidgintex/metadata.xml b/x11-plugins/pidgintex/metadata.xml
new file mode 100644
index 000000000000..1b7319740533
--- /dev/null
+++ b/x11-plugins/pidgintex/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+</maintainer>
+<longdescription>
+pidginTeX is a fast plugin for the instant messaging client Pidgin and uses
+mimeTeX or mathTeX to render LaTeX expressions in messages and chat. It is
+intended for math but mathTeX is fully compatible with LaTeX and any package can
+be used and mimeTeX also supports many other features.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild b/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild
new file mode 100644
index 000000000000..ce8a8419c35e
--- /dev/null
+++ b/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild,v 1.1 2009/12/21 20:39:14 pva Exp $
+
+EAPI="2"
+inherit toolchain-funcs multilib
+
+MY_P=pidginTeX-${PV}
+
+DESCRIPTION="Pidgin plugin to render LaTeX expressions in messages."
+HOMEPAGE="http://code.google.com/p/pidgintex"
+SRC_URI="http://pidgintex.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-im/pidgin[gtk]
+ app-text/mathtex"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e "s:\(^CC.*=\).*:\1 $(tc-getCC):" \
+ -e "s:\(^STRIP.*=\).*:\1 true:" \
+ -e "s:\(^CFLAGS[[:space:]]*\)=:\1+=:" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/purple-2:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+ # set default renderer to mathtex
+ sed -e "/purple_prefs_add_string.*PREFS_RENDERER/{s:mimetex:mathtex:;}" \
+ -i pidginTeX.c || die
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install() {
+ make PREFIX="${D}/usr" install || die "make install failed"
+ dodoc CHANGELOG README TODO || die
+}