summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-03-29 14:07:30 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-03-29 14:07:30 +0000
commit47cb1690c600b7ae8e2caf3776599d32e5e08372 (patch)
tree44bc28e357a8448051af9adf884e1fe65a9b32aa /x11-plugins/wmgtemp/wmgtemp-1.0.ebuild
parentstable x86, security bug 308049 (diff)
downloadhistorical-47cb1690c600b7ae8e2caf3776599d32e5e08372.tar.gz
historical-47cb1690c600b7ae8e2caf3776599d32e5e08372.tar.bz2
historical-47cb1690c600b7ae8e2caf3776599d32e5e08372.zip
Version bump. See bug #291426.
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'x11-plugins/wmgtemp/wmgtemp-1.0.ebuild')
-rw-r--r--x11-plugins/wmgtemp/wmgtemp-1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild b/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild
new file mode 100644
index 000000000000..ad3c4630b46a
--- /dev/null
+++ b/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild,v 1.1 2010/03/29 14:07:30 s4t4n Exp $
+
+inherit eutils
+
+
+DESCRIPTION="CPU and SYS temperature dockapp"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/${P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ =sys-apps/lm_sensors-3*
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:-Wall -g:\$(CFLAGS):" src/Makefile \
+ || die "sed failed."
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dodoc BUGS CREDITS README TODO
+ dobin src/wmgtemp
+ doman wmgtemp.1
+}