summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2009-01-16 16:21:11 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2009-01-16 16:21:11 +0000
commitc6d932e3f23d9edb17f0774d0ad0999f8943467d (patch)
treef1e10951e011e1f0b7841301e9109661b9448ee3 /x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
parentStable for HPPA (bug #252991). (diff)
downloadhistorical-c6d932e3f23d9edb17f0774d0ad0999f8943467d.tar.gz
historical-c6d932e3f23d9edb17f0774d0ad0999f8943467d.tar.bz2
historical-c6d932e3f23d9edb17f0774d0ad0999f8943467d.zip
Fixed compilation with --as-needed. Closes bug #248642.
Prevent automatic stripping of binaries. Some ebuild QA fixing. Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.24-tuxonice-r9 i686
Diffstat (limited to 'x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild')
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
index bf04a0dea76b..55a676b8c5a1 100644
--- a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild,v 1.2 2006/01/15 17:47:42 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild,v 1.3 2009/01/16 16:21:10 s4t4n Exp $
inherit eutils
@@ -21,18 +21,18 @@ KEYWORDS="x86 ppc"
src_unpack()
{
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-makefile.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile.patch"
}
src_install()
{
dodir /usr/bin/
- einstall DESTDIR=${D}/usr/bin/ CFLAGS="${CFLAGS} -Wall" || die "Installation failed"
+ einstall DESTDIR="${D}/usr/bin/" CFLAGS="${CFLAGS} -Wall" || die "Installation failed"
dodoc README sample.wmlpqrc
newman wmlpq.1x wmlpq.1
insinto /usr/share/applications
- doins ${FILESDIR}/${PN}.desktop
+ doins "${FILESDIR}/${PN}.desktop"
}