summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2006-07-18 08:55:32 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2006-07-18 08:55:32 +0000
commit2598ad345ca8156dc67fbec6b55628681e6db3b5 (patch)
tree6c99ec17738204aa94840ff73c5a05e8ffae72ab /x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
parentEnable symlink useflag by default. (diff)
downloadhistorical-2598ad345ca8156dc67fbec6b55628681e6db3b5.tar.gz
historical-2598ad345ca8156dc67fbec6b55628681e6db3b5.tar.bz2
historical-2598ad345ca8156dc67fbec6b55628681e6db3b5.zip
Added some magic sed to fix bug #140857.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild')
-rw-r--r--x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild b/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
index e194b009d1dd..84e5d3f7ed39 100644
--- a/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
+++ b/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild,v 1.6 2004/12/12 18:10:39 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild,v 1.7 2006/07/18 08:55:32 s4t4n Exp $
IUSE=""
@@ -12,10 +12,22 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ppc ~sparc"
-DEPEND=">=x11-libs/gtk+-2.4.1
+RDEPEND=">=x11-libs/gtk+-2.4.1
>=app-crypt/mhash-0.9.1
>=app-crypt/mcrypt-2.6.4"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Solves compile error about undefined exit - Bug 140857
+ sed -i -e '/#include <stdio.h>/ { p ; s/stdio/stdlib/ }' wmgeneral/wmgeneral-gtk.c
+}
+
src_install()
{
einstall