summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-07-16 13:30:18 +0000
committerDon Seiler <rizzo@gentoo.org>2004-07-16 13:30:18 +0000
commit9a71966aed13576bc98d5df428c35d4af6524dd7 (patch)
treec66bd0144e87760d4cc25db442b4343bf263af05 /x11-plugins
parentadd gcj useflag, building with gcj is optional (diff)
downloadhistorical-9a71966aed13576bc98d5df428c35d4af6524dd7.tar.gz
historical-9a71966aed13576bc98d5df428c35d4af6524dd7.tar.bz2
historical-9a71966aed13576bc98d5df428c35d4af6524dd7.zip
Patched to work with gaim-0.80 until 2.28 comes out
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gaim-encryption/ChangeLog8
-rw-r--r--x11-plugins/gaim-encryption/Manifest5
-rw-r--r--x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.27-r11
-rw-r--r--x11-plugins/gaim-encryption/files/gaim-encryption_prpl-num.diff143
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.27-r1.ebuild47
5 files changed, 202 insertions, 2 deletions
diff --git a/x11-plugins/gaim-encryption/ChangeLog b/x11-plugins/gaim-encryption/ChangeLog
index 3cbade8cd675..f450ddc99c33 100644
--- a/x11-plugins/gaim-encryption/ChangeLog
+++ b/x11-plugins/gaim-encryption/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gaim-encryption
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.1 2004/07/08 15:32:53 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.2 2004/07/16 13:30:17 rizzo Exp $
+
+*gaim-encryption-2.27-r1 (16 Jul 2004)
+
+ 16 Jul 2004; Don Seiler <rizzo@gentoo.org>
+ +files/gaim-encryption_prpl-num.diff, +gaim-encryption-2.27-r1.ebuild:
+ Patched to work with gaim-0.80 until 2.28 comes out
07 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
gaim-encryption-2.27.ebuild:
diff --git a/x11-plugins/gaim-encryption/Manifest b/x11-plugins/gaim-encryption/Manifest
index 42448b5210d3..1d2774c981dc 100644
--- a/x11-plugins/gaim-encryption/Manifest
+++ b/x11-plugins/gaim-encryption/Manifest
@@ -1,6 +1,9 @@
+MD5 2f6ceb46444013647ed96b59235ac3e7 gaim-encryption-2.27-r1.ebuild 1220
MD5 674727e4288dc4482fae9dd6cd80410c gaim-encryption-2.25.ebuild 1493
+MD5 cf1fe1ffe5675919c59e04ecf0d93e52 ChangeLog 4853
MD5 09706c6e8fae8e18d38209949d588a46 gaim-encryption-2.27.ebuild 1123
MD5 ab7db4bf9ff48c8de9da14fd12f6c15c metadata.xml 344
-MD5 88daa60181f03edaa94ae5bb26573d59 ChangeLog 4640
MD5 f6d7c4865e839026143ac5f87868ce6b files/digest-gaim-encryption-2.25 72
MD5 0f841aa75334a0c388d872bee0608be6 files/digest-gaim-encryption-2.27 72
+MD5 0f841aa75334a0c388d872bee0608be6 files/digest-gaim-encryption-2.27-r1 72
+MD5 7f4e72ec7a830b0b0889833a498b9f63 files/gaim-encryption_prpl-num.diff 7542
diff --git a/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.27-r1 b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.27-r1
new file mode 100644
index 000000000000..245340900650
--- /dev/null
+++ b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.27-r1
@@ -0,0 +1 @@
+MD5 b5d24bbada652d9673f35c5f3c6b03c7 gaim-encryption-2.27.tar.gz 363114
diff --git a/x11-plugins/gaim-encryption/files/gaim-encryption_prpl-num.diff b/x11-plugins/gaim-encryption/files/gaim-encryption_prpl-num.diff
new file mode 100644
index 000000000000..1ef6ddc5f18b
--- /dev/null
+++ b/x11-plugins/gaim-encryption/files/gaim-encryption_prpl-num.diff
@@ -0,0 +1,143 @@
+===================================================================
+RCS file: /cvsroot/gaim-encryption/encrypt/encrypt.c,v
+retrieving revision 1.112
+retrieving revision 1.113
+diff -u -r1.112 -r1.113
+--- gaim-encryption/encrypt/encrypt.c 2004/06/26 01:54:36 1.112
++++ gaim-encryption/encrypt/encrypt.c 2004/07/08 03:07:01 1.113
+@@ -140,8 +140,8 @@
+ GaimConversation *conv;
+
+ int header_size, footer_size;
+- const gchar* header = g_hash_table_lookup(header_table, (gpointer)gaim_account_get_protocol(acct));
+- const gchar* footer = g_hash_table_lookup(footer_table, (gpointer)gaim_account_get_protocol(acct));
++ const gchar* header = g_hash_table_lookup(header_table, gaim_account_get_protocol_id(acct));
++ const gchar* footer = g_hash_table_lookup(footer_table, gaim_account_get_protocol_id(acct));
+
+ if (!header) header = header_default;
+ if (!footer) footer = "";
+@@ -201,8 +201,8 @@
+ unsigned char* tmpmsg;
+
+ int header_size, footer_size;
+- const gchar* header = g_hash_table_lookup(header_table, (gpointer)gaim_account_get_protocol(gc->account));
+- const gchar* footer = g_hash_table_lookup(footer_table, (gpointer)gaim_account_get_protocol(gc->account));
++ const gchar* header = g_hash_table_lookup(header_table, gaim_account_get_protocol_id(gc->account));
++ const gchar* footer = g_hash_table_lookup(footer_table, gaim_account_get_protocol_id(gc->account));
+
+ if (!header) header = header_default;
+ if (!footer) footer = "";
+@@ -468,9 +468,9 @@
+ /* since ICQ will now escape HTML */
+
+ int header_size, footer_size;
+- const gchar* header = g_hash_table_lookup(header_table, (gpointer)gaim_account_get_protocol(acct));
+- const gchar* footer = g_hash_table_lookup(footer_table, (gpointer)gaim_account_get_protocol(acct));
+- const gchar* notify = g_hash_table_lookup(notify_table, (gpointer)gaim_account_get_protocol(acct));
++ const gchar* header = g_hash_table_lookup(header_table, gaim_account_get_protocol_id(acct));
++ const gchar* footer = g_hash_table_lookup(footer_table, gaim_account_get_protocol_id(acct));
++ const gchar* notify = g_hash_table_lookup(notify_table, gaim_account_get_protocol_id(acct));
+
+ if (!header) header = header_default;
+ if (!footer) footer = "";
+@@ -686,9 +686,11 @@
+ /* Get account-specific message size limit*/
+
+ static int GE_get_msg_size_limit(GaimAccount *acct) {
+- if (gaim_account_get_protocol(acct) == GAIM_PROTO_YAHOO) {
++ const char* protocol_id = gaim_account_get_protocol_id(acct);
++
++ if (strcmp(protocol_id, "prpl-yahoo") == 0) {
+ return 945;
+- } else if (gaim_account_get_protocol(acct) == GAIM_PROTO_MSN) {
++ } else if (strcmp(protocol_id, "prpl-msn") == 0) {
+ return 1500; /* This may be too small... somewhere in the 1500-1600 (+ html on front/back) */
+ } else {
+ /* Well, ok, this isn't too exciting. Someday we can actually check */
+@@ -713,9 +715,9 @@
+ int baggage_size;
+ char baggage[BUF_LONG];
+
+- const gchar* header = g_hash_table_lookup(header_table, (gpointer)gaim_account_get_protocol(acct));
+- const gchar* footer = g_hash_table_lookup(footer_table, (gpointer)gaim_account_get_protocol(acct));
+- const gchar* notify = g_hash_table_lookup(notify_table, (gpointer)gaim_account_get_protocol(acct));
++ const gchar* header = g_hash_table_lookup(header_table, gaim_account_get_protocol_id(acct));
++ const gchar* footer = g_hash_table_lookup(footer_table, gaim_account_get_protocol_id(acct));
++ const gchar* notify = g_hash_table_lookup(notify_table, gaim_account_get_protocol_id(acct));
+
+ if (!header) header = header_default;
+ if (!footer) footer = "";
+@@ -867,8 +869,8 @@
+ conv = gaim_conversation_new(GAIM_CONV_IM, acct, name);
+ }
+
+- header = g_hash_table_lookup(header_table, (gpointer)gaim_account_get_protocol(conv->account));
+- footer = g_hash_table_lookup(footer_table, (gpointer)gaim_account_get_protocol(conv->account));
++ header = g_hash_table_lookup(header_table, gaim_account_get_protocol_id(conv->account));
++ footer = g_hash_table_lookup(footer_table, gaim_account_get_protocol_id(conv->account));
+
+ if (!header) header = header_default;
+ if (!footer) footer = "";
+@@ -994,30 +996,29 @@
+ }
+
+ static void GE_headers_init() {
+- header_table = g_hash_table_new_full(g_direct_hash, g_direct_equal, NULL, g_free);
+- footer_table = g_hash_table_new_full(g_direct_hash, g_direct_equal, NULL, g_free);
+- notify_table = g_hash_table_new_full(g_direct_hash, g_direct_equal, NULL, g_free);
++ header_table = g_hash_table_new_full(g_str_hash, g_str_equal, g_free, g_free);
++ footer_table = g_hash_table_new_full(g_str_hash, g_str_equal, g_free, g_free);
++ notify_table = g_hash_table_new_full(g_str_hash, g_str_equal, g_free, g_free);
+
+- g_hash_table_insert(header_table, (gpointer)GAIM_PROTO_TOC,
++ g_hash_table_insert(header_table, g_strdup("prpl-toc"),
+ g_strdup("*** Encrypted with the Gaim-Encryption plugin <A HREF=\""));
+- g_hash_table_insert(footer_table, (gpointer)GAIM_PROTO_TOC,
++ g_hash_table_insert(footer_table, g_strdup("prpl-toc"),
+ g_strdup("\"></A>"));
+- g_hash_table_insert(notify_table, (gpointer)GAIM_PROTO_TOC,
++ g_hash_table_insert(notify_table, g_strdup("prpl-toc"),
+ g_strdup("<A HREF=\"Gaim-Encryption Capable\"></A>"));
+
+-
+- g_hash_table_insert(header_table, (gpointer)GAIM_PROTO_OSCAR,
++ g_hash_table_insert(header_table, g_strdup("prpl-oscar"),
+ g_strdup("*** Encrypted with the Gaim-Encryption plugin <A HREF=\""));
+- g_hash_table_insert(footer_table, (gpointer)GAIM_PROTO_OSCAR,
++ g_hash_table_insert(footer_table, g_strdup("prpl-oscar"),
+ g_strdup("\"></A>"));
+- g_hash_table_insert(notify_table, (gpointer)GAIM_PROTO_OSCAR,
++ g_hash_table_insert(notify_table, g_strdup("prpl-oscar"),
+ g_strdup("<A HREF=\"Gaim-Encryption Capable\"></A>"));
+
+- g_hash_table_insert(header_table, (gpointer)GAIM_PROTO_JABBER,
++ g_hash_table_insert(header_table, g_strdup("prpl-jabber"),
+ g_strdup("*** Encrypted with the Gaim-Encryption plugin <A HREF='"));
+- g_hash_table_insert(footer_table, (gpointer)GAIM_PROTO_JABBER,
++ g_hash_table_insert(footer_table, g_strdup("prpl-jabber"),
+ g_strdup("'></A>"));
+- g_hash_table_insert(notify_table, (gpointer)GAIM_PROTO_JABBER,
++ g_hash_table_insert(notify_table, g_strdup("prpl-jabber"),
+ g_strdup("<A HREF='Gaim-Encryption Capable'> </A>"));
+
+ header_default = g_strdup("*** Encrypted :");
+===================================================================
+RCS file: /cvsroot/gaim-encryption/encrypt/state.c,v
+retrieving revision 1.12
+retrieving revision 1.13
+diff -u -r1.12 -r1.13
+--- gaim-encryption/encrypt/state.c 2004/06/26 01:54:36 1.12
++++ gaim-encryption/encrypt/state.c 2004/07/08 03:07:01 1.13
+@@ -143,9 +143,10 @@
+
+ /* The only special case here is Oscar/TOC: If the other user's name is all */
+ /* digits, then they're ICQ, so we pretend that we already notified them */
++
++ const char* protocol_id = gaim_account_get_protocol_id(account);
+
+- if ( (gaim_account_get_protocol(account) == GAIM_PROTO_TOC) ||
+- (gaim_account_get_protocol(account) == GAIM_PROTO_OSCAR) ) {
++ if (strcmp(protocol_id, "prpl-toc") == 0 || strcmp(protocol_id, "prpl-oscar") == 0) {
+
+ while(*name != 0) {
+ if (!isdigit(*name++)) {
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.27-r1.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.27-r1.ebuild
new file mode 100644
index 000000000000..7964e91d605d
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.27-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.27-r1.ebuild,v 1.1 2004/07/16 13:30:17 rizzo Exp $
+
+inherit flag-o-matic eutils
+use debug && inherit debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~hppa ~mips"
+IUSE="debug"
+
+DEPEND=">=net-im/gaim-0.79
+ dev-libs/nss"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gaim-encryption_prpl-num.diff
+}
+
+src_compile() {
+ local myconf
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+
+ econf ${myconf} || die "Configuration failed"
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || emake -j1 || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc CHANGELOG COPYING INSTALL NOTES README TODO VERSION WISHLIST
+}
+