summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-01-12 10:42:13 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-01-12 10:42:13 +0000
commit2a9e23c82e953132ad4543731249bb1aedd466a9 (patch)
treed073c655f59153bfbe2d6110f4d7d198a049f2ad /x11-wm/fvwm
parentrevision bump, fixing #37079 (diff)
downloadhistorical-2a9e23c82e953132ad4543731249bb1aedd466a9.tar.gz
historical-2a9e23c82e953132ad4543731249bb1aedd466a9.tar.bz2
historical-2a9e23c82e953132ad4543731249bb1aedd466a9.zip
revision bump, fixing #37079
Diffstat (limited to 'x11-wm/fvwm')
-rw-r--r--x11-wm/fvwm/Manifest4
-rw-r--r--x11-wm/fvwm/files/digest-fvwm-2.5.8-r32
-rw-r--r--x11-wm/fvwm/files/fvwm-2.5.8-taskbar-margins.diff55
-rw-r--r--x11-wm/fvwm/files/fvwm-2.5.8-undermouse.diff73
-rw-r--r--x11-wm/fvwm/files/fvwm-iconman.diff55
-rw-r--r--x11-wm/fvwm/fvwm-2.5.8-r3.ebuild312
6 files changed, 499 insertions, 2 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index 381e95d002e1..bb2c93da43bc 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -1,7 +1,7 @@
MD5 e79bd2fa2e46e650aabaa16754e25583 fvwm-2.5.7-r5.ebuild 8757
MD5 b893f78193652b275ce5d276ac38af29 fvwm-2.4.17.ebuild 3961
-MD5 317153014c5752ba4623e9877de77f69 fvwm-2.5.8-r3.ebuild 10055
-MD5 417bd6d3c665bd0742dfacca52c9db44 ChangeLog 9873
+MD5 7358e02a3de54ef00c04a9bf78214f9c fvwm-2.5.8-r3.ebuild 10055
+MD5 4f33249e78f1d91e7e6ad862031ee5ee ChangeLog 10179
MD5 4833e4d0685ef48988c0c5c4f9c6b377 metadata.xml 527
MD5 e277a2831ac0104d5af9b1aef8ee3403 fvwm-2.5.8-r2.ebuild 9684
MD5 e2ceb5d855c5406a09d82442196efad8 files/README.transluceny.gz 5788
diff --git a/x11-wm/fvwm/files/digest-fvwm-2.5.8-r3 b/x11-wm/fvwm/files/digest-fvwm-2.5.8-r3
new file mode 100644
index 000000000000..3ad7e1a9fea0
--- /dev/null
+++ b/x11-wm/fvwm/files/digest-fvwm-2.5.8-r3
@@ -0,0 +1,2 @@
+MD5 c702d873d124a475f95c45432b8bd7d7 fvwm-2.5.8.tar.bz2 1778920
+MD5 a714fc47fe53c079905aee4037653579 FvwmTabs-2.6.tar.gz 24345
diff --git a/x11-wm/fvwm/files/fvwm-2.5.8-taskbar-margins.diff b/x11-wm/fvwm/files/fvwm-2.5.8-taskbar-margins.diff
new file mode 100644
index 000000000000..449ebc446a68
--- /dev/null
+++ b/x11-wm/fvwm/files/fvwm-2.5.8-taskbar-margins.diff
@@ -0,0 +1,55 @@
+--- fvwm-2.5.8/modules/FvwmTaskBar/Start.c 2003-09-03 14:52:36.000000000 +0100
++++ fvwm/modules/FvwmTaskBar/Start.c 2004-01-12 09:55:10.000000000 +0000
+@@ -42,6 +42,8 @@
+ int WindowButtonsLeftMargin = 4; /* default value is 4 */
+ int WindowButtonsRightMargin = 2; /* default value is 2 */
+ int StartButtonRightMargin = 0; /* default value is 0 */
++int has_wb_left_margin = 0;
++int has_wb_right_margin = 0;
+ Bool StartButtonOpensAboveTaskBar = FALSE;
+ char *StartName = NULL,
+ *StartCommand = NULL,
+@@ -294,12 +296,14 @@
+ if(atoi(rest)>=0)
+ {
+ WindowButtonsLeftMargin = atoi(rest);
++ has_wb_left_margin = 1;
+ }
+ break;
+ case 7: /* WindowButtonsRightMargin */
+ if(atoi(rest)>=0)
+ {
+ WindowButtonsRightMargin = atoi(rest);
++ has_wb_right_margin = 1;
+ }
+ break;
+ case 8: /* StartButtonRightMargin */
+@@ -311,7 +315,6 @@
+ default:
+ /* unknown option */
+ return False;
+- break;
+ } /* switch */
+
+ return True;
+@@ -455,10 +458,16 @@
+ }
+ else
+ {
+- StartAndLaunchButtonsWidth = 0;
+- StartButtonRightMargin = 0;
+- WindowButtonsLeftMargin = 0;
+- WindowButtonsRightMargin = 0;
++ StartAndLaunchButtonsWidth = 0;
++ StartButtonRightMargin = 0;
++ if (has_wb_left_margin == 0)
++ {
++ WindowButtonsLeftMargin = 0;
++ }
++ if (has_wb_right_margin == 0)
++ {
++ WindowButtonsRightMargin = 0;
++ }
+ }
+ }
+
diff --git a/x11-wm/fvwm/files/fvwm-2.5.8-undermouse.diff b/x11-wm/fvwm/files/fvwm-2.5.8-undermouse.diff
new file mode 100644
index 000000000000..be18ea4abda1
--- /dev/null
+++ b/x11-wm/fvwm/files/fvwm-2.5.8-undermouse.diff
@@ -0,0 +1,73 @@
+diff -Naur fvwm-2.5.8/fvwm/fvwm.h fvwm/fvwm/fvwm.h
+--- fvwm-2.5.8/fvwm/fvwm.h 2003-09-24 11:15:20.000000000 +0200
++++ fvwm/fvwm/fvwm.h 2003-11-25 00:53:26.000000000 +0100
+@@ -467,8 +467,9 @@
+ #define PLACE_TILECASCADE 0x5
+ #define PLACE_CASCADE_B 0x6
+ #define PLACE_MINOVERLAP 0x7
+-#define PLACE_MASK 0x7
+- unsigned placement_mode : 3;
++#define PLACE_UNDERMOUSE 0x8
++#define PLACE_MASK 0x8
++ unsigned placement_mode : 4;
+ unsigned ewmh_placement_mode : 2; /* see ewmh.h */
+ #define WS_CR_MOTION_METHOD_AUTO CR_MOTION_METHOD_AUTO
+ #define WS_CR_MOTION_METHOD_USE_GRAV CR_MOTION_METHOD_USE_GRAV
+diff -Naur fvwm-2.5.8/fvwm/placement.c fvwm/fvwm/placement.c
+--- fvwm-2.5.8/fvwm/placement.c 2003-07-08 00:22:20.000000000 +0200
++++ fvwm/fvwm/placement.c 2003-11-25 00:53:26.000000000 +0100
+@@ -1156,7 +1156,35 @@
+ fw, sflags, &screen_g, &xl, &yt, pdeltax,
+ pdeltay, 0);
+ flags.is_smartly_placed = True;
+- break;
++
++ case PLACE_UNDERMOUSE:
++ {
++ int mx;
++ int my;
++ FQueryPointer(dpy, Scr.Root, &JunkRoot, &JunkChild,
++ &mx, &my, &JunkX, &JunkY, &JunkMask);
++ xl = mx - (fw->frame_g.width / 2);
++ yt = my - (fw->frame_g.height / 2);
++ if (xl + fw->frame_g.width > screen_g.x + screen_g.width)
++ {
++ xl = screen_g.x + screen_g.width - fw->frame_g.width;
++ }
++ if (yt + fw->frame_g.height > screen_g.y + screen_g.height)
++ {
++ yt = screen_g.y + screen_g.height - fw->frame_g.height;
++ }
++ if (xl < screen_g.x)
++ {
++ xl = screen_g.x;
++ }
++ if (yt < screen_g.y)
++ {
++ yt = screen_g.y;
++ }
++ attr_g->x = xl;
++ attr_g->y = yt;
++ }
++ break;
+ default:
+ /* can't happen */
+ break;
+diff -Naur fvwm-2.5.8/fvwm/style.c fvwm/fvwm/style.c
+--- fvwm-2.5.8/fvwm/style.c 2003-08-23 06:27:43.000000000 +0200
++++ fvwm/fvwm/style.c 2003-11-25 00:53:26.000000000 +0100
+@@ -3738,7 +3738,13 @@
+ break;
+
+ case 'u':
+- if (StrEquals(token, "UsePPosition"))
++ if (StrEquals(token, "UnderMousePlacement"))
++ {
++ ps->flags.placement_mode = PLACE_UNDERMOUSE;
++ ps->flag_mask.placement_mode = PLACE_MASK;
++ ps->change_mask.placement_mode = PLACE_MASK;
++ }
++ else if (StrEquals(token, "UsePPosition"))
+ {
+ ps->flags.use_no_pposition = !on;
+ ps->flag_mask.use_no_pposition = 1;
diff --git a/x11-wm/fvwm/files/fvwm-iconman.diff b/x11-wm/fvwm/files/fvwm-iconman.diff
new file mode 100644
index 000000000000..150176222c25
--- /dev/null
+++ b/x11-wm/fvwm/files/fvwm-iconman.diff
@@ -0,0 +1,55 @@
+diff -pru fvwm/modules/FvwmIconMan/FvwmIconMan.h fvwm.new/modules/FvwmIconMan/FvwmIconMan.h
+--- fvwm/modules/FvwmIconMan/FvwmIconMan.h 2003-04-26 19:37:06.000000000 +0200
++++ fvwm.new/modules/FvwmIconMan/FvwmIconMan.h 2003-05-20 11:46:26.000000000 +0200
+@@ -313,7 +313,7 @@ typedef struct win_manager {
+ WeightedSort *weighted_sorts;
+ int weighted_sorts_len, weighted_sorts_size;
+ char *AnimCommand;
+- Uchar showonlyiconic;
++ int showonlyiconic;
+ Uchar showtransient;
+ rectangle managed_g; /* dimensions of managed screen portion */
+
+Tylko w fvwm.new/modules/FvwmIconMan: FvwmIconMan.h~
+diff -pru fvwm/modules/FvwmIconMan/readconfig.c fvwm.new/modules/FvwmIconMan/readconfig.c
+--- fvwm/modules/FvwmIconMan/readconfig.c 2003-04-26 19:37:18.000000000 +0200
++++ fvwm.new/modules/FvwmIconMan/readconfig.c 2003-05-20 11:48:41.000000000 +0200
+@@ -1572,11 +1572,14 @@ void read_in_resources()
+ ConsoleMessage("Need argument to showonlyicons\n");
+ continue;
+ }
+- if (!strcasecmp(p, "true")) {
++ if (!strcasecmp (p, "false")) {
++ i = 0;
++ }
++ else if (!strcasecmp (p, "true")) {
+ i = 1;
+ }
+- else if (!strcasecmp(p, "false")) {
+- i = 0;
++ else if (!strcasecmp (p, "never")) {
++ i = 2;
+ }
+ else {
+ ConsoleMessage("Bad line: %s\n", current_line);
+Tylko w fvwm.new/modules/FvwmIconMan: readconfig.c~
+diff -pru fvwm/modules/FvwmIconMan/xmanager.c fvwm.new/modules/FvwmIconMan/xmanager.c
+--- fvwm/modules/FvwmIconMan/xmanager.c 2003-04-26 19:37:23.000000000 +0200
++++ fvwm.new/modules/FvwmIconMan/xmanager.c 2003-05-20 11:49:39.000000000 +0200
+@@ -1415,9 +1415,12 @@ void check_in_window(WinData *win)
+
+ if (win->manager && win->complete) {
+ is_state_selected =
+- ((!win->manager->showonlyiconic || win->iconified) &&
+- (win->manager->showtransient || !IS_TRANSIENT(win)));
+- in_viewport = win_in_viewport(win);
++ (((!win->iconified&&(win->manager->showonlyiconic==2))||
++ (win->manager->showonlyiconic==0)||
++ ((win->iconified&&(win->manager->showonlyiconic==1))
++ ))&&
++ (win->manager->showtransient || !IS_TRANSIENT(win)));
++ in_viewport = win_in_viewport(win);
+ if (win->manager->usewinlist && DO_SKIP_WINDOW_LIST(win))
+ in_viewport = 0;
+ if (win->button == NULL && in_viewport && is_state_selected) {
+Tylko w fvwm.new/modules/FvwmIconMan: xmanager.c~
diff --git a/x11-wm/fvwm/fvwm-2.5.8-r3.ebuild b/x11-wm/fvwm/fvwm-2.5.8-r3.ebuild
new file mode 100644
index 000000000000..d1b1d27921de
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.5.8-r3.ebuild
@@ -0,0 +1,312 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8-r3.ebuild,v 1.1 2004/01/12 10:42:04 taviso Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="readline truetype ncurses gtk stroke gnome rplay xinerama perl nls png bidi imlib tcltk debug gtk2"
+
+DESCRIPTION="An extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2
+ perl? ( mirror://gentoo/FvwmTabs-2.6.tar.gz )"
+HOMEPAGE="http://www.fvwm.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+LICENSE="GPL-2 FVWM"
+
+RDEPEND="readline? ( >=sys-libs/readline-4.1
+ ncurses? ( >=sys-libs/ncurses-5.3-r1 )
+ !ncurses? ( >=sys-libs/libtermcap-compat-1.2.3 ) )
+ gtk? ( =x11-libs/gtk+-1.2*
+ imlib? ( >=media-libs/gdk-pixbuf-0.21.0
+ >=media-libs/imlib-1.9.14-r1 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 ) )
+ rplay? ( >=media-sound/rplay-3.3.2 )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ png? ( >=media-libs/libpng-1.0.12-r2 )
+ stroke? ( >=dev-libs/libstroke-0.4 )
+ perl? ( tcltk? ( >=dev-lang/tk-8.3.4
+ >=dev-perl/perl-tk-800.024-r2
+ >=dev-perl/X11-Protocol-0.52 ) )
+ truetype? ( virtual/xft
+ >=media-libs/fontconfig-2.1-r1
+ >=dev-libs/expat-1.95.6-r1 )
+ !noxpm? ( >=media-libs/netpbm-9.12-r4 )
+ >=dev-lang/perl-5.6.1-r10
+ >=sys-libs/zlib-1.1.4-r1
+ virtual/x11"
+# XXX: gtk2 perl bindings require dev-perl/gtk2-perl, worth a dependency?
+# XXX: gtk perl bindings require dev-perl/gtk-perl, worth a dependency?
+# XXX: netpbm is used by FvwmScript-ScreenDump...im assuming anyone with
+# `use noxpm` will not want them.
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ # this patch enables fast translucent menus in fvwm..yummy! this is a
+ # minor tweak of a patch posted to fvwm-user mailing list by Olivier
+ # Chapuis in <20030827135125.GA6370@snoopy.folie>.
+ cd ${S}; epatch ${FILESDIR}/fvwm-translucent-menus.diff.gz
+
+ # according to a post to fvwm-workers mailing list, Mikhael Goikhman
+ # planned on disabling these debug statements before the release, but
+ # never got around to it.
+ cd ${S}; epatch ${FILESDIR}/disable-debug-statements.diff
+
+ # FvwmTabs uses /tmp/.fvwmtabs.state for storing state files by default,
+ # this probably isnt a good idea security wise, allowing someone to do
+ # damage with symlinks. It will also break if multiple users try using
+ # the same location simultaneously...probably should use File::Temp, but
+ # moving it into ~/.fvwmtabs.state will do for now.
+ if use perl; then
+ cd ${WORKDIR}; epatch ${FILESDIR}/fvwmtabs-insecure-tmp-handling.diff
+
+ # I'll supply a default icon for FvwmTabs, this removes the need for
+ # installing an iconset, this one comes from the fvwm_icons package.
+ ebegin " Setting default icon for FvwmTabs"
+ sed -i 's#/usr/share/icons/mini/mini-happy.xpm#/usr/share/fvwm/mini-happy.xpm#g' \
+ FvwmTabs FvwmTabs.1 fvwmtabrc
+ eend $?
+ fi
+
+ # this patch from cvs, regarding a message sent to the fvwm-workers
+ # mailing list in <20031111234845.A12314@deepblue.milkyway.com.au>,
+ # perllib applications were getting destroyed before the ON_EXIT
+ # handler could be invoked.
+ cd ${S}; epatch ${FILESDIR}/fvwm-2.5.8-perllib-disconnect.diff
+
+ # files with \n in them make fvwm-menu-directory misbehave.
+ cd ${S}/bin; epatch ${FILESDIR}/fvwm-2.5.8-fvwm-menu-directory-security.diff
+
+ # add a nice new placement policy, UnderMousePlacement.
+ cd ${S}; epatch ${FILESDIR}/fvwm-2.5.8-undermouse.diff
+
+ # this patch adds an 'ShowOnlyIcons Never' option to FvwmIconMan.
+ cd ${S}; epatch ${FILESDIR}/fvwm-iconman.diff
+
+ # if you disable the start button in FvwmTaskBar, your margins
+ # may get ignored.
+ cd ${S}; epatch ${FILESDIR}/fvwm-2.5.8-taskbar-margins.diff
+
+ # build fails on alpha with certain options without this.
+ use alpha && append-flags -fPIC
+}
+
+src_compile() {
+ local myconf="--libexecdir=/usr/lib --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm --enable-package-subdirs"
+
+ # ImagePath should include /usr/share/icons/fvwm (x11-themes/fvwm_icons)
+ #
+ # Another iconset for fvwm, wm-icons, includes configurations and user
+ # configuration utilities to make them easy to use with fvwm, no need
+ # to put them in the default ImagePath.
+
+ # use readline in FvwmConsole.
+ if ! use readline; then
+ myconf="${myconf} --without-readline-library"
+ else
+ myconf="${myconf} --with-readline-library"
+
+ # choose ncurses or termcap.
+ if use ncurses; then
+ myconf="${myconf} --without-termcap-library"
+ else
+ myconf="${myconf} --without-ncurses-library"
+ fi
+ fi
+
+ # since fvwm-2.5.8 GTK support can be diabled with --disable-gtk, previously
+ # we had to hide the includes/libs during configure. this is still the case
+ # for GDK image suport _with_ gtk, unfortunately.
+ # FvwmGtk can be built as a gnome application, or a Gtk+ application.
+ if ! use gtk; then
+ myconf="${myconf} --disable-gtk --without-gnome"
+ else
+ if ! use imlib; then
+ einfo "ATTN: You can safely ignore any imlib related configure errors."
+ myconf="${myconf} --with-imlib-prefix=${T}"
+ fi
+ if ! use gnome; then
+ myconf="${myconf} --without-gnome"
+ else
+ myconf="${myconf} --with-gnome"
+ fi
+ fi
+
+ # rplay is a cool, but little used way of playing sounds over a network
+ # Fvwm support is pretty good.
+ if ! use rplay; then
+ myconf="${myconf} --without-rplay-library"
+ fi
+
+ # Install perl bindings.
+ if use perl; then
+ myconf="${myconf} --enable-perllib"
+ else
+ myconf="${myconf} --disable-perllib"
+ fi
+
+ # xinerama support for those who have multi-headed machines.
+ if use xinerama; then
+ myconf="${myconf} --enable-xinerama"
+ else
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ # bidirectional writing support, eg hebrew
+ if use bidi; then
+ myconf="${myconf} --enable-bidi"
+ else
+ myconf="${myconf} --disable-bidi"
+ fi
+
+ # png image support (very nice in fvwm)
+ if ! use png; then
+ myconf="${myconf} --without-png-library"
+ fi
+
+ # native language support
+ if use nls; then
+ myconf="${myconf} --enable-nls"
+ else
+ myconf="${myconf} --disable-nls"
+ fi
+
+ # support for mouse gestures using libstroke (very very cool)
+ if ! use stroke; then
+ myconf="${myconf} --without-stroke-library"
+ fi
+
+ # more verbosity for module developers/hackers/etc.
+ if use debug; then
+ myconf="${myconf} --enable-debug-msgs --enable-command-log"
+ append-flags -DCR_DETECT_MOTION_METHOD_DEBUG
+ fi
+
+ # Xft Anti Aliased text support (yummy eye candy)
+ if use truetype; then
+ myconf="${myconf} --enable-xft"
+ else
+ myconf="${myconf} --disable-xft"
+ fi
+
+ # disable xsm protocol (session management) support?
+ if use nosm; then
+ myconf="${myconf} --disable-sm"
+ else
+ myconf="${myconf} --enable-sm"
+ fi
+
+ # disable xpm support? (maybe you only use png in your themes, or just solid colour?)
+ if use noxpm; then
+ myconf="${myconf} --without-xpm-library"
+ fi
+
+ # set the local maintainer for fvwm-bug.
+ export FVWM_BUGADDR="taviso@gentoo.org"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ if use perl; then
+
+ local toolkits="gtk2 gtk tcltk"
+
+ if use tcltk; then
+ # Install the very cool FvwmTabs module
+ # http://users.tpg.com.au/users/scottie7/FvwmTabs
+ einfo "Installing FvwmTabs module..."
+
+ exeinto /usr/lib/fvwm/${PV}/
+ doexe ${WORKDIR}/FvwmTabs
+ dodoc ${WORKDIR}/fvwmtabrc ${WORKDIR}/README.fvwmtabs
+ doman ${WORKDIR}/FvwmTabs.1
+
+ # install default drag and drop icon.
+ insinto /usr/share/fvwm
+ newins ${FILESDIR}/mini.happy.xpm mini-happy.xpm
+ else
+ # Remove the Tk bindings (requires perl-tk)
+ rm -f ${D}/usr/share/fvwm/perllib/FVWM/Module/Tk.pm
+ toolkits=${toolkits/tcltk/}
+ fi
+ if ! use gtk; then
+ # Remove gtk bindings (requires gtk-perl/gtk2-perl)
+ rm -f ${D}/usr/share/fvwm/perllib/FVWM/Module/Gtk.pm \
+ ${D}/usr/share/fvwm/perllib/FVWM/Module/Gtk2.pm
+ toolkits=${toolkits/gtk2/}
+ toolkits=${toolkits/gtk/}
+ else
+ if ! use gtk2; then
+ # Just remove the gtk2 bindings (requires gtk2-perl)
+ rm -f ${D}/usr/share/fvwm/perllib/FVWM/Module/Gtk2.pm
+ toolkits=${toolkits/gtk2/}
+ fi
+ fi
+ toolkits=${toolkits// /}
+ if ! test "${toolkits}"; then
+ # No perl toolkit bindings wanted, remove the unneeded files
+ # and empty directories.
+ rm -f ${D}/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm
+ find ${D}/usr/share/fvwm/perllib -depth -type d -exec rmdir {} \; 2>/dev/null
+ fi
+ else
+ # Remove useless script if perllib isnt required.
+ rm -rf ${D}/usr/bin/fvwm-perllib ${D}/usr/share/man/man1/fvwm-perllib.1
+ fi
+
+ # neat utility for testing fvwm behaviour on applications setting various
+ # hints, creates a simple black window with configurable hints set.
+ if use debug; then
+ dobin ${S}/tests/hints/hints_test
+ newdoc ${S}/tests/hints/README README.hints
+ fi
+
+ # fvwm-convert-2.6 is just a stub, contains no code - remove it for now.
+ # fvwm-convert-2.2 has a man page, but the script is no longer distributed.
+ rm -f ${D}/usr/bin/fvwm-convert-2.6 ${D}/usr/share/man/man1/fvwm-convert-2.6.1
+ rm -f ${D}/usr/share/man/man1/fvwm-convert-2.2.1
+
+ # ive included `exec` to save a few bytes of memory.
+ echo "#!/bin/bash" > fvwm2
+ echo "exec /usr/bin/fvwm2" >> fvwm2
+
+ exeinto /etc/X11/Sessions
+ doexe fvwm2
+
+ dodoc AUTHORS ChangeLog COPYING README NEWS docs/ANNOUNCE docs/BUGS \
+ docs/COMMANDS docs/DEVELOPERS docs/FAQ docs/error_codes docs/TODO \
+ docs/fvwm.lsm
+
+ dodoc utils/fvwm_make_directory_menu.sh utils/fvwm_make_browse_menu.sh \
+ utils/quantize_pixmaps utils/xselection.c
+
+ dodoc ${FILESDIR}/README.transluceny.gz
+
+ # fix a couple of symlinks.
+ prepallman
+}
+
+pkg_postinst() {
+ if use perl; then
+ if use tcltk; then
+ einfo "By setting the perl and tcltk USE flags, you have elected to"
+ einfo "install the FvwmTabs module, a configurable tabbing system"
+ einfo "for FVWM. You can read more about FvwmTabs here:"
+ einfo
+ einfo " http://users.tpg.com.au/users/scottie7/fvwmtabs.html"
+ einfo
+ fi
+ fi
+}