summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Hale <tseng@gentoo.org>2003-12-22 21:25:00 +0000
committerBrandon Hale <tseng@gentoo.org>2003-12-22 21:25:00 +0000
commit701e9f3ba3ad4c229ca32095dfdf900a12e8e021 (patch)
tree65a649fc471a689f6140a3021a7a56935b998581 /x11-wm/openbox
parentVersion bump, thanks to SuperLag on freenode for his lightening fast report. (diff)
downloadhistorical-701e9f3ba3ad4c229ca32095dfdf900a12e8e021.tar.gz
historical-701e9f3ba3ad4c229ca32095dfdf900a12e8e021.tar.bz2
historical-701e9f3ba3ad4c229ca32095dfdf900a12e8e021.zip
Version bump, thanks to SuperLag on freenode for his lightening fast report.
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/Manifest4
-rw-r--r--x11-wm/openbox/files/digest-openbox-3.12
-rw-r--r--x11-wm/openbox/openbox-3.1.ebuild55
3 files changed, 59 insertions, 2 deletions
diff --git a/x11-wm/openbox/Manifest b/x11-wm/openbox/Manifest
index 71fffca33239..9fc37407d840 100644
--- a/x11-wm/openbox/Manifest
+++ b/x11-wm/openbox/Manifest
@@ -1,4 +1,4 @@
-MD5 92cf9e5feda56fcccd00587136223e71 ChangeLog 13665
+MD5 7a121c65f96142f58bc60a63c6747c7b ChangeLog 13840
MD5 416452bedba085c06bd2502510370e1a metadata.xml 162
MD5 5dfe3a3dad2d7e59ec7e5fc229b3997f openbox-1.2.4.ebuild 629
MD5 cd8e991ef4a7829c1a715bf68403ecdf openbox-2.1.3-r4.ebuild 874
@@ -6,7 +6,7 @@ MD5 d00d1c66664d638aa414324a9de97a24 openbox-2.3.0.ebuild 1237
MD5 bbddfe37157511609a9ef1a0674b1a73 openbox-2.3.1.ebuild 1257
MD5 fc2def52b7a44b9c694a4f5e63cddcf5 openbox-3.0.ebuild 1316
MD5 382a5d992266dc5c700d9be416f6ae4f openbox-3.0-r1.ebuild 1419
-MD5 fc2def52b7a44b9c694a4f5e63cddcf5 openbox-3.1.ebuild 1316
+MD5 b9be52ce5ce554e872f2031571879844 openbox-3.1.ebuild 1418
MD5 f0b52d0f48a8b10c418a6d6558c4198c files/digest-openbox-1.2.4 65
MD5 14ea1589afa8d9807619faebdd1468b5 files/digest-openbox-2.1.3-r4 65
MD5 e8173797964d97d9293eee8faa1a95aa files/digest-openbox-2.3.0 65
diff --git a/x11-wm/openbox/files/digest-openbox-3.1 b/x11-wm/openbox/files/digest-openbox-3.1
new file mode 100644
index 000000000000..03ac811de4db
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-3.1
@@ -0,0 +1,2 @@
+MD5 3152631bb8c892b919129e2a58978aad openbox-3.1.tar.gz 550425
+MD5 3d69bb394dae0994461172fccedc602a ob-themes-usability.tar.bz2 19204
diff --git a/x11-wm/openbox/openbox-3.1.ebuild b/x11-wm/openbox/openbox-3.1.ebuild
new file mode 100644
index 000000000000..6b8511fbe0e0
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.1.ebuild,v 1.1 2003/12/22 21:24:47 tseng Exp $
+
+S=${WORKDIR}/${P/_/-}
+DESCRIPTION="Openbox is a standards compliant, fast, light-weight, extensible window manager."
+
+SRC_URI="http://icculus.org/openbox/releases/${P/_/-}.tar.gz
+ mirror://gentoo/ob-themes-usability.tar.bz2"
+
+HOMEPAGE="http://icculus.org/openbox/"
+IUSE="nls"
+SLOT="3"
+
+DEPEND="virtual/xft
+ virtual/x11
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2
+ >=dev-libs/libxml2-2.0"
+RDEPEND=${DEPEND}
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_compile() {
+
+ econf \
+ `use_enable nls` || die
+ emake || die
+}
+
+src_install () {
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox" > ${D}/etc/X11/Sessions/openbox
+ fperms a+x /etc/X11/Sessions/openbox
+
+ make DESTDIR=${D} install || die
+ dodoc README AUTHORS ChangeLog TODO
+
+ # Extra styles from http://home.clara.co.uk/dpb/openbox.htm
+ # These are included due to the poor usability of the default themes
+ # for users with limited vision. These are based on Jimmac's
+ # Gorilla and Industrial themes for Metacity.
+
+ dodir /usr/share/themes
+ cp -a ${WORKDIR}/ob-themes-usability/* ${D}/usr/share/themes
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "The binary is now moved to /usr/bin/openbox."
+ ewarn "Likewise for the session files."
+ ewarn
+}