summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-25 09:59:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-25 09:59:20 +0000
commitaaaac3b5096155349a6e52b901b44fa40db903c4 (patch)
tree943f2d0cc80a3c1edf13b634daefd44751cefb9b /xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
parentAdd ~arm-linux and ~x86-linux keywords. (diff)
downloadhistorical-aaaac3b5096155349a6e52b901b44fa40db903c4.tar.gz
historical-aaaac3b5096155349a6e52b901b44fa40db903c4.tar.bz2
historical-aaaac3b5096155349a6e52b901b44fa40db903c4.zip
Version bump.
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64 Manifest-Sign-Key: 0x4868F14D
Diffstat (limited to 'xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild')
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
new file mode 100644
index 000000000000..9a5671faddce
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild,v 1.1 2013/02/25 09:59:16 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to control MPRIS2 compatible players like Pragha (from the same authors)"
+HOMEPAGE="https://github.com/matiasdelellis/xfce4-soundmenu-plugin"
+SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm"
+
+RDEPEND=">=dev-libs/glib-2.28
+ >=dev-libs/keybinder-0.2.2:0
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ glyr? ( >=media-libs/glyr-1.0.0 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}