summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 00:04:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 00:04:57 +0000
commit9c63e019c7a1966780476d0a38a2f59af136d0ab (patch)
tree36f25a93fd9ca2538b29a553a4e44cea12035353 /xfce-extra
parenteapi=3 (diff)
downloadhistorical-9c63e019c7a1966780476d0a38a2f59af136d0ab.tar.gz
historical-9c63e019c7a1966780476d0a38a2f59af136d0ab.tar.bz2
historical-9c63e019c7a1966780476d0a38a2f59af136d0ab.zip
eapi3, array
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild28
-rw-r--r--xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-0.4.0-r1.ebuild12
-rw-r--r--xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.3.ebuild13
-rw-r--r--xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-0.3.6.ebuild14
-rw-r--r--xfce-extra/xfce4-volumed/xfce4-volumed-0.1.8.ebuild10
5 files changed, 42 insertions, 35 deletions
diff --git a/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild b/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
index 362ffc6a186c..7b8b7b667fcb 100644
--- a/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
+++ b/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild,v 1.5 2010/08/24 03:06:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild,v 1.6 2011/01/30 00:02:55 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="Panel plugin displaying date, time and small calendar"
@@ -15,26 +15,24 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~
IUSE="debug"
RDEPEND=">=x11-libs/gtk+-2.6:2
- >=xfce-base/xfce4-panel-4.3.99.2
>=xfce-base/libxfce4util-4.3.99.2
- >=xfce-base/libxfcegui4-4.3.99.2"
+ >=xfce-base/libxfcegui4-4.3.99.2
+ >=xfce-base/xfce4-panel-4.3.99.2"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/intltool"
+ dev-util/intltool
+ dev-util/pkgconfig"
pkg_setup() {
- # static, http://bugzilla.xfce.org/show_bug.cgi?id=6659
- XFCONF="--disable-dependency-tracking
+ XFCONF=(
+ --disable-dependency-tracking
--disable-static
- $(xfconf_use_debug)"
+ $(xfconf_use_debug)
+ )
+
DOCS="AUTHORS ChangeLog NEWS THANKS"
}
src_prepare() {
- # Encoding, http://bugzilla.xfce.org/show_bug.cgi?id=6660
- sed -i \
- -e '/Encoding/d' \
- panel-plugin/datetime.desktop.in.in || die
-
+ sed -i -e '/Encoding/d' panel-plugin/datetime.desktop.in.in || die
xfconf_src_prepare
}
diff --git a/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-0.4.0-r1.ebuild b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-0.4.0-r1.ebuild
index f7beec485419..91030c579feb 100644
--- a/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-0.4.0-r1.ebuild
+++ b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-0.4.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-0.4.0-r1.ebuild,v 1.10 2010/08/09 11:04:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-0.4.0-r1.ebuild,v 1.11 2011/01/30 00:04:20 ssuominen Exp $
-EAPI=2
+EAPI=3
EAUTORECONF=yes
EINTLTOOLIZE=yes
inherit xfconf
@@ -28,8 +28,10 @@ pkg_setup() {
"${FILESDIR}"/${P}-link_to_libxfcegui4.patch
"${FILESDIR}"/${P}-fix-tooltips-gtk2.16.patch
)
- XFCONF="--disable-dependency-tracking
- $(xfconf_use_debug)"
+ XFCONF=(
+ --disable-dependency-tracking
+ $(xfconf_use_debug)
+ )
DOCS="AUTHORS ChangeLog README"
}
diff --git a/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.3.ebuild b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.3.ebuild
index 786ed6af3391..75b9228e5a02 100644
--- a/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.3.ebuild
+++ b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.3.ebuild,v 1.3 2010/11/05 13:56:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.3.ebuild,v 1.4 2011/01/30 00:03:27 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="Panel plugin to control V4L radio device"
@@ -21,7 +21,10 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.40"
pkg_setup() {
- XFCONF="--disable-dependency-tracking
- $(xfconf_use_debug)"
+ XFCONF=(
+ --disable-dependency-tracking
+ $(xfconf_use_debug)
+ )
+
DOCS="AUTHORS NEWS README"
}
diff --git a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-0.3.6.ebuild b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-0.3.6.ebuild
index 1ca332897121..6c0b97fa7cf7 100644
--- a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-0.3.6.ebuild
+++ b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-0.3.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-0.3.6.ebuild,v 1.5 2010/08/07 17:22:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-0.3.6.ebuild,v 1.6 2011/01/30 00:04:57 ssuominen Exp $
-EAPI=2
+EAPI=3
EAUTORECONF=yes
inherit xfconf
@@ -20,7 +20,7 @@ RDEPEND=">=xfce-base/exo-0.3.1.3
>=xfce-base/libxfce4util-4.4
>=xfce-base/libxfcegui4-4.4
>=dev-libs/libpcre-5
- dbus? ( >=dev-libs/dbus-glib-0.60 )"
+ dbus? ( >=dev-libs/dbus-glib-0.88 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
@@ -30,8 +30,10 @@ pkg_setup() {
"${FILESDIR}"/${P}-exo.patch
"${FILESDIR}"/${P}-link_to_libxfcegui4.patch
)
- XFCONF="--disable-dependency-tracking
+ XFCONF=(
+ --disable-dependency-tracking
$(use_enable dbus)
- $(xfconf_use_debug)"
+ $(xfconf_use_debug)
+ )
DOCS="AUTHORS ChangeLog README THANKS TODO"
}
diff --git a/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.8.ebuild b/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.8.ebuild
index a90c9a9414f8..7f23d66ca7d2 100644
--- a/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.8.ebuild
+++ b/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.8.ebuild,v 1.5 2011/01/29 20:22:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.8.ebuild,v 1.6 2011/01/29 23:59:53 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="Daemon to control volume up/down and mute keys"
@@ -25,8 +25,10 @@ DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
pkg_setup() {
- XFCONF="--disable-dependency-tracking
+ XFCONF=(
+ --disable-dependency-tracking
$(use_enable debug)
- $(use_with libnotify)"
+ $(use_with libnotify)
+ )
DOCS="AUTHORS ChangeLog README THANKS"
}