summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/arts/arts-1.0.7.ebuild42
-rw-r--r--kde-base/arts/files/digest-arts-1.0.71
-rw-r--r--kde-base/kde/files/digest-kde-3.1_beta10
-rw-r--r--kde-base/kde/kde-3.1_beta1.ebuild12
-rw-r--r--kde-base/kdeaddons/files/digest-kdeaddons-3.1_beta11
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.1_beta1.ebuild19
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.1_beta11
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.1_beta1.ebuild17
-rw-r--r--kde-base/kdeartwork/files/digest-kdeartwork-3.1_beta11
-rw-r--r--kde-base/kdeartwork/kdeartwork-3.1_beta1.ebuild16
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.1_beta11
-rw-r--r--kde-base/kdebase/files/startkde-3.1_beta1-gentoo.diff48
-rw-r--r--kde-base/kdebase/kdebase-3.1_beta1.ebuild94
-rw-r--r--kde-base/kdebindings/files/digest-kdebindings-3.1_beta11
-rw-r--r--kde-base/kdebindings/kdebindings-3.1_beta1.ebuild39
-rw-r--r--kde-base/kdeedu/files/digest-kdeedu-3.1_beta11
-rw-r--r--kde-base/kdeedu/files/kdeedu-3.1_beta1-errno.diff19
-rw-r--r--kde-base/kdeedu/kdeedu-3.1_beta1.ebuild11
-rw-r--r--kde-base/kdegames/files/digest-kdegames-3.1_beta11
-rw-r--r--kde-base/kdegames/kdegames-3.1_beta1.ebuild8
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-3.1_beta11
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.1_beta1.ebuild27
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1_beta11
-rw-r--r--kde-base/kdelibs/kdelibs-3.1_beta1.ebuild90
-rw-r--r--kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_beta11
-rw-r--r--kde-base/kdemultimedia/files/kdemultimedia-3.1_beta1-gentoo-timidity.diff21
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.1_beta1.ebuild65
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-3.1_beta11
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.1_beta1.ebuild29
-rw-r--r--kde-base/kdepim/files/digest-kdepim-3.1_beta11
-rw-r--r--kde-base/kdepim/kdepim-3.1_beta1.ebuild19
-rw-r--r--kde-base/kdesdk/files/digest-kdesdk-3.1_beta11
-rw-r--r--kde-base/kdesdk/kdesdk-3.1_beta1.ebuild7
-rw-r--r--kde-base/kdetoys/files/digest-kdetoys-3.1_beta11
-rw-r--r--kde-base/kdetoys/kdetoys-3.1_beta1.ebuild8
-rw-r--r--kde-base/kdeutils/files/digest-kdeutils-3.1_beta11
-rw-r--r--kde-base/kdeutils/kdeutils-3.1_beta1.ebuild7
37 files changed, 614 insertions, 0 deletions
diff --git a/kde-base/arts/arts-1.0.7.ebuild b/kde-base/arts/arts-1.0.7.ebuild
new file mode 100644
index 000000000000..75feae3dcf63
--- /dev/null
+++ b/kde-base/arts/arts-1.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.0.7.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-base flag-o-matic
+
+SRC_URI="mirror://kde/unstable/kde-3.1-beta1/src/${P}.tar.bz2"
+KEYWORDS="x86"
+HOMEPAGE="http://multimedia.kde.org"
+DESCRIPTION="KDE Sound Server"
+set-kdedir 3.1_beta1
+need-qt 3.0.3
+
+if [ "${COMPILER}" == "gcc3" ]; then
+ # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+ # these.. Even starting a compile shuts down the arts server
+ filter-flags "-fomit-frame-pointer -fstrength-reduce"
+fi
+
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+use alsa && myconf="$myconf --enable-alsa" || myconf="$myconf --disable-alsa"
+
+src_unpack() {
+
+ base_src_unpack
+
+ kde_sandbox_patch ${S}/soundserver
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ # fix root exploit
+ # fixed on kde cvs, not needed anymore
+ # chmod ug-s ${D}${KDEDIR}/bin/artswrapper
+
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+}
diff --git a/kde-base/arts/files/digest-arts-1.0.7 b/kde-base/arts/files/digest-arts-1.0.7
new file mode 100644
index 000000000000..44dfc051b489
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-1.0.7
@@ -0,0 +1 @@
+MD5 23eb9ef045632fceb382120d7f9a58d5 arts-1.0.7.tar.bz2 934692
diff --git a/kde-base/kde/files/digest-kde-3.1_beta1 b/kde-base/kde/files/digest-kde-3.1_beta1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/kde-base/kde/files/digest-kde-3.1_beta1
diff --git a/kde-base/kde/kde-3.1_beta1.ebuild b/kde-base/kde/kde-3.1_beta1.ebuild
new file mode 100644
index 000000000000..814667b98853
--- /dev/null
+++ b/kde-base/kde/kde-3.1_beta1.ebuild
@@ -0,0 +1,12 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+
+DESCRIPTION="KDE $PV - merge this to pull in all non-developer kde-base/* packages"
+HOMEPAGE="http://www.kde.org/"
+# removed: kdebindings, kdesdk, kdoc since these are developer-only packages
+RDEPEND=`echo ~kde-base/kde{libs,base,addons,admin,artwork,edu,games,graphics,multimedia,network,pim,toys,utils}-${PV}`
+
+SLOT="3.0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
diff --git a/kde-base/kdeaddons/files/digest-kdeaddons-3.1_beta1 b/kde-base/kdeaddons/files/digest-kdeaddons-3.1_beta1
new file mode 100644
index 000000000000..5ac567371b67
--- /dev/null
+++ b/kde-base/kdeaddons/files/digest-kdeaddons-3.1_beta1
@@ -0,0 +1 @@
+MD5 6052de68257086dc3394fec93b5fd202 kdeaddons-3.0.7.tar.bz2 1021245
diff --git a/kde-base/kdeaddons/kdeaddons-3.1_beta1.ebuild b/kde-base/kdeaddons/kdeaddons-3.1_beta1.ebuild
new file mode 100644
index 000000000000..f04f7e7a4437
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.1_beta1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV: addons - applets, plugins..."
+KEYWORDS="x86"
+
+newdepend "~kde-base/kdebase-${PV}
+ ~kde-base/kdenetwork-${PV}
+ ~kde-base/kdemultimedia-${PV}
+ ~kde-base/kdegames-${PV}
+ sdl? ( >=media-libs/libsdl-1.2 )
+ svga? ( media-libs/svgalib )
+ xmms? ( media-sound/xmms )"
+
+use sdl && myconf="$myconf --with-sdl --with-sdl-prefix=/usr" || myconf="$myconf --without-sdl --disable-sdltest"
+
+use xmms || export ac_cv_have_xmms=no
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.1_beta1 b/kde-base/kdeadmin/files/digest-kdeadmin-3.1_beta1
new file mode 100644
index 000000000000..0f2b4aa4e16e
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.1_beta1
@@ -0,0 +1 @@
+MD5 963d9394fea2444c5f9f03027bd64a22 kdeadmin-3.0.7.tar.bz2 1373982
diff --git a/kde-base/kdeadmin/kdeadmin-3.1_beta1.ebuild b/kde-base/kdeadmin/kdeadmin-3.1_beta1.ebuild
new file mode 100644
index 000000000000..6a4c337eeb87
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.1_beta1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - administration tools"
+
+KEYWORDS="x86"
+
+newdepend ">=app-arch/rpm-4.0.4-r1
+ dev-libs/popt
+ pam? ( >=sys-libs/pam-0.72 )"
+
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --without-pam --with-shadow"
+myconf="$myconf --without-rpm"
+
+# TODO: add nis support
diff --git a/kde-base/kdeartwork/files/digest-kdeartwork-3.1_beta1 b/kde-base/kdeartwork/files/digest-kdeartwork-3.1_beta1
new file mode 100644
index 000000000000..44c9f2532791
--- /dev/null
+++ b/kde-base/kdeartwork/files/digest-kdeartwork-3.1_beta1
@@ -0,0 +1 @@
+MD5 19493a9039a273f712d12238f5161732 kdeartwork-3.0.7.tar.bz2 12425325
diff --git a/kde-base/kdeartwork/kdeartwork-3.1_beta1.ebuild b/kde-base/kdeartwork/kdeartwork-3.1_beta1.ebuild
new file mode 100644
index 000000000000..a98d4575a17f
--- /dev/null
+++ b/kde-base/kdeartwork/kdeartwork-3.1_beta1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+newdepend "opengl? ( virtual/opengl ) >=kde-base/kdebase-${PV}"
+
+DESCRIPTION="KDE $PV - artwork"
+
+KEYWORDS="x86"
+
+myconf="$myconf --with-dpms"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+
+PATCHES="$FILESDIR/xsaver-conflicting-typedefs.diff"
+
diff --git a/kde-base/kdebase/files/digest-kdebase-3.1_beta1 b/kde-base/kdebase/files/digest-kdebase-3.1_beta1
new file mode 100644
index 000000000000..ca4e54e87f3b
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.1_beta1
@@ -0,0 +1 @@
+MD5 1031ebc18fbc0dcaa92bb202b402eeab kdebase-3.0.7.tar.bz2 13263004
diff --git a/kde-base/kdebase/files/startkde-3.1_beta1-gentoo.diff b/kde-base/kdebase/files/startkde-3.1_beta1-gentoo.diff
new file mode 100644
index 000000000000..8437a8c67ca4
--- /dev/null
+++ b/kde-base/kdebase/files/startkde-3.1_beta1-gentoo.diff
@@ -0,0 +1,48 @@
+--- startkde.orig Mon Aug 5 18:29:33 2002
++++ startkde Thu Aug 22 17:04:50 2002
+@@ -1,8 +1,28 @@
+-#!/bin/sh
++#!/bin/sh --login
+ #
+-# DEFAULT KDE STARTUP SCRIPT ( KDE-3.1 )
++# GENTOO CUSTOMIZED KDE STARTUP SCRIPT ( KDE-3.1 )
+ #
+
++# Gentoo part:
++export PATH="_KDEDIR_/bin:${PATH}"
++export KDEDIR="_KDEDIR_"
++export KDEDIRS="_KDEDIR_:/usr" # do NOT add env.d's KDEDIRS
++
++cd ~
++[ -d .kde ] && mv .kde .kde.backup
++if [ ! -e .kde3.1 ]; then
++ if [ -e .kde3 ]; then
++ cp -r .kde3 .kde3.1
++ else
++ mkdir .kde3.1
++ fi
++fi
++ln -sf .kde3.1 .kde
++
++#export KDEHOME="${HOME}/.kde3.1"
++
++# Gentoo part ends
++
+ # Boot sequence:
+ #
+ # kdeinit is used to fork off processes which improves memory usage
+@@ -25,12 +45,12 @@
+ # especially necessary on slow machines, where starting KDE takes one or two
+ # minutes until anything appears on the screen.
+ #
+-# Set the background to plain grey.
++# Set the background to cyan (Gentoo version change).
+ # The standard X background is nasty, causing moire effects and exploding
+ # people's heads. We use colours from the standard KDE palette for those with
+ # palettised displays.
+
+-test "$XDM_MANAGED" || bkg="-solid #C0C0C0"
++test "$XDM_MANAGED" || bkg="-solid #5477A0"
+ xsetroot -cursor_name left_ptr $bkg
+
+ # The user's personal KDE directory is usually ~/.kde, but this setting
diff --git a/kde-base/kdebase/kdebase-3.1_beta1.ebuild b/kde-base/kdebase/kdebase-3.1_beta1.ebuild
new file mode 100644
index 000000000000..5e8c53e11f15
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.1_beta1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="x86"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ encode? ( >=media-sound/lame-3.89b )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ opengl? ( virtual/opengl )
+ samba? ( net-fs/samba )
+ >=media-libs/freetype-2"
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+myconf="$myconf --with-dpms --with-cdparanoia"
+
+use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+use encode && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+src_compile() {
+
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e 's:SessionTypes=:SessionTypes=kde-${PV},:' \
+ -e "s:Session=${PREFIX}/share/config/kdm/Xsession:Session=/etc/X11/xdm/Xsession:" kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ mkdir -p ${D}/usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+}
diff --git a/kde-base/kdebindings/files/digest-kdebindings-3.1_beta1 b/kde-base/kdebindings/files/digest-kdebindings-3.1_beta1
new file mode 100644
index 000000000000..65b676bfcbd7
--- /dev/null
+++ b/kde-base/kdebindings/files/digest-kdebindings-3.1_beta1
@@ -0,0 +1 @@
+MD5 42ceeacebf5db2fc7ee5bf70937e2c10 kdebindings-3.0.7.tar.bz2 6119986
diff --git a/kde-base/kdebindings/kdebindings-3.1_beta1.ebuild b/kde-base/kdebindings/kdebindings-3.1_beta1.ebuild
new file mode 100644
index 000000000000..beeeddb0b61d
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.1_beta1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+# TODO: add gnustep, objc bindings
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - kde library bindings for languages other than c++"
+
+KEYWORDS="x86"
+
+newdepend "~kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ ~kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+#src_unpack()
+#{
+# base_src_unpack
+#
+# if [ -z "`use mozilla`" ]; then
+# # disable mozilla bindings/xpart
+# cd ${S}
+# cp configure configure.orig
+# sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+# chmod +x configure
+# fi
+#}
+
diff --git a/kde-base/kdeedu/files/digest-kdeedu-3.1_beta1 b/kde-base/kdeedu/files/digest-kdeedu-3.1_beta1
new file mode 100644
index 000000000000..7aa208ae94be
--- /dev/null
+++ b/kde-base/kdeedu/files/digest-kdeedu-3.1_beta1
@@ -0,0 +1 @@
+MD5 c367e582e6959797a0c106ab13bb8fae kdeedu-3.0.7.tar.bz2 17848915
diff --git a/kde-base/kdeedu/files/kdeedu-3.1_beta1-errno.diff b/kde-base/kdeedu/files/kdeedu-3.1_beta1-errno.diff
new file mode 100644
index 000000000000..a86bb2b42ad9
--- /dev/null
+++ b/kde-base/kdeedu/files/kdeedu-3.1_beta1-errno.diff
@@ -0,0 +1,19 @@
+--- kmplot/kmplot/View.cpp Mon Jul 15 23:34:49 2002
++++ kmplot/kmplot/View.cpp Sun Jul 21 12:33:25 2002
+@@ -1,6 +1,6 @@
+ #include "View.h"
+ #include "View.moc"
+-
++#include <errno.h>
+
+ View::View( QWidget* parent, const char* name ) : QWidget( parent, name )
+ {
+@@ -151,7 +151,7 @@
+ mflg = 2;
+ for ( x = dmin; x < dmax; x += dx )
+ {
+- int errno = 0;
++ errno = 0;
+ switch ( p_mode )
+ {
+ case 0:
diff --git a/kde-base/kdeedu/kdeedu-3.1_beta1.ebuild b/kde-base/kdeedu/kdeedu-3.1_beta1.ebuild
new file mode 100644
index 000000000000..e7c8bd22e759
--- /dev/null
+++ b/kde-base/kdeedu/kdeedu-3.1_beta1.ebuild
@@ -0,0 +1,11 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/kdeedu-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - educational apps"
+
+KEYWORDS="x86"
+
+PATCHES="$FILESDIR/$P-errno.diff"
+
diff --git a/kde-base/kdegames/files/digest-kdegames-3.1_beta1 b/kde-base/kdegames/files/digest-kdegames-3.1_beta1
new file mode 100644
index 000000000000..5d7662bba8cc
--- /dev/null
+++ b/kde-base/kdegames/files/digest-kdegames-3.1_beta1
@@ -0,0 +1 @@
+MD5 4e31d0da7eaa203aeeefd986f6b2f27a kdegames-3.0.7.tar.bz2 8026271
diff --git a/kde-base/kdegames/kdegames-3.1_beta1.ebuild b/kde-base/kdegames/kdegames-3.1_beta1.ebuild
new file mode 100644
index 000000000000..2686f580b510
--- /dev/null
+++ b/kde-base/kdegames/kdegames-3.1_beta1.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegames/kdegames-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - games"
+
+KEYWORDS="x86"
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-3.1_beta1 b/kde-base/kdegraphics/files/digest-kdegraphics-3.1_beta1
new file mode 100644
index 000000000000..50694f6dad71
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-3.1_beta1
@@ -0,0 +1 @@
+MD5 233c150449cab3a6c262e4b2e2b4f37b kdegraphics-3.0.7.tar.bz2 3537954
diff --git a/kde-base/kdegraphics/kdegraphics-3.1_beta1.ebuild b/kde-base/kdegraphics/kdegraphics-3.1_beta1.ebuild
new file mode 100644
index 000000000000..911a024374d6
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.1_beta1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - graphics-related apps"
+
+KEYWORDS="x86"
+
+newdepend "gphoto2? ( >=media-gfx/gphoto2-2.0_beta1 >=media-libs/libgpio-20010607 )
+ sys-devel/perl
+ media-gfx/sane-backends
+ tetex? ( >=app-text/tetex-1.0.7 )
+ media-libs/imlib
+ app-text/ghostscript
+ virtual/glut virtual/opengl
+ !media-gfx/kpovmodeler" # kpovmodeler's old separate ebuild
+
+use gphoto2 && myconf="$myconf --with-kamera --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2 \
+ --with-gpio --with-gpio-includes=/usr/include \
+ --with-gpio-libraries=/usr/lib" || myconf="$myconf --without-kamera"
+
+use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+myconf="$myconf --with-imlib --with-imlib-config=/usr/bin"
+
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1_beta1 b/kde-base/kdelibs/files/digest-kdelibs-3.1_beta1
new file mode 100644
index 000000000000..a7a9e02c7219
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1_beta1
@@ -0,0 +1 @@
+MD5 904aae52e5544c7663e35521a93b6965 kdelibs-3.0.7.tar.bz2 9188248
diff --git a/kde-base/kdelibs/kdelibs-3.1_beta1.ebuild b/kde-base/kdelibs/kdelibs-3.1_beta1.ebuild
new file mode 100644
index 000000000000..014a93f5572b
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1_beta1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
+
+DESCRIPTION="KDE $PV - base libraries needed by all kde programs"
+KEYWORDS="x86"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ ~kde-base/arts-1.0.7
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+#myconf="$myconf --enable-final"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ [ "$ARCH" != "ppc" ] && \
+ [ "$ARCH" != "sparc" ] && [ "$ARCH" != "sparc64" ] && \
+ myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+KDEDIRS=${PREFIX}" > ${D}/etc/env.d/49kdelibs-${PV} # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/56kdedir-${PV} # number goes up with version upgrade
+
+}
+
+
diff --git a/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_beta1 b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_beta1
new file mode 100644
index 000000000000..35b42b15fbd2
--- /dev/null
+++ b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_beta1
@@ -0,0 +1 @@
+MD5 aab046d93c9d21205da85d6085d747fa kdemultimedia-3.0.7.tar.bz2 5735434
diff --git a/kde-base/kdemultimedia/files/kdemultimedia-3.1_beta1-gentoo-timidity.diff b/kde-base/kdemultimedia/files/kdemultimedia-3.1_beta1-gentoo-timidity.diff
new file mode 100644
index 000000000000..f392a244212e
--- /dev/null
+++ b/kde-base/kdemultimedia/files/kdemultimedia-3.1_beta1-gentoo-timidity.diff
@@ -0,0 +1,21 @@
+diff -ru kdemultimedia-2.2.1.orig/kmidi/TIMIDITY/motif_p.c kdemultimedia-2.2.1/kmidi/TIMIDITY/motif_p.c
+--- kmidi/TIMIDITY/motif_p.c Mon Feb 28 19:07:37 2000
++++ kmidi/TIMIDITY/motif_p.c Fri Oct 19 04:00:10 2001
+@@ -22,6 +22,7 @@
+ pipe communication between motif interface and sound generator
+
+ */
++#include <sys/errno.h>
+ #ifdef IA_MOTIF
+
+ #include <stdio.h>
+--- kmidi/TIMIDITY/tk_c.c 2002-04-04 21:15:35.000000000 -0600
++++ kmidi/TIMIDITY/tk_c.c 2002-04-04 21:17:06.000000000 -0600
+@@ -12,6 +12,7 @@
+ *================================================================*/
+ #ifdef TCLTK
+
++#include <sys/errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.1_beta1.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.1_beta1.ebuild
new file mode 100644
index 000000000000..077ec82310af
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.1_beta1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="KDE $PV - multimedia apps"
+KEYWORDS="x86"
+
+newdepend ">=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-video/xanim-2.80.1
+ nas? ( >=media-libs/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ slang? ( >=sys-libs/slang-1.4.4 )
+ app-cdr/cdrtools
+ >=app-cdr/cdrdao-1.1.5
+ >=media-sound/mpg123-0.59r
+ tcltk? ( >=dev-lang/tk-8.0.5-r2 )
+ >=dev-libs/glib-1.3.3
+ >=media-libs/xine-lib-0.9.9
+ oggvorbis? ( media-libs/libvorbis )"
+ #gtk? ( =x11-libs/gtk+-1.2* )
+# alsa? ( >=media-libs/alsa-lib-0.5.9 )"
+
+replace-flags "-O3" "-O2"
+
+myaudio="--enable-audio=oss"
+myinterface="--enable-interface=xaw,ncurses"
+myconf="$myconf --enable-xaw --enable-ncurses"
+myconf="$myconf --with-xine-prefix=/usr"
+
+# alsa 0.9 not supported
+#use alsa && myconf="$myconf --with-alsa --with-arts-alsa" && myaudio="$myaudio,alsa" ||
+myconf="$myconf --without-alsa --disable-alsa"
+use nas && myaudio="$myaudio,nas --with-nas-library=/usr/X11R6/lib/libaudio.so --with-nas-includes=/usr/X11R6/include" || myconf="$myconf --disable-nas"
+use esd && myaudio="$myaudio,esd" || myconf="$myconf --disable-esd"
+use motif && myinterface="$myinterface,motif" && myconf="$myconf --enable-motif"
+# kmidi/TIMIDITY miscompiles with gtk
+#use gtk && myinterface="$myinterface,gtk" && myconf="$myconf --enable-gtk"
+use slang && myinterface="$myinterface,slang" && myconf="$myconf --enable-slang"
+use tcltk && myinterface="$myinterface,tcltk" && myconf="$myconf --enable-tcltk"
+use oggvorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
+
+myconf="$myconf $myaudio $myinterface"
+
+src_unpack() {
+
+ base_src_unpack
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo-timidity.diff || die
+
+}
+
+pkg_postinst() {
+
+ if [ -n "`use alsa`" ]; then
+ einfo "WARNING: alsa support has been removed becuase of a bug in kdemm sources.
+For further information see bug #2324 on bugs.gentoo.org and bug #39574 on bugs.kde.org.
+Meanwhile, you can use the alsa oss emulation."
+ fi
+ return 0
+
+}
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.1_beta1 b/kde-base/kdenetwork/files/digest-kdenetwork-3.1_beta1
new file mode 100644
index 000000000000..200ce8f6f339
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-3.1_beta1
@@ -0,0 +1 @@
+MD5 6d2e620bd3f8120bc48760dd1eb606f1 kdenetwork-3.0.7.tar.bz2 4542126
diff --git a/kde-base/kdenetwork/kdenetwork-3.1_beta1.ebuild b/kde-base/kdenetwork/kdenetwork-3.1_beta1.ebuild
new file mode 100644
index 000000000000..d7a1bf8d325d
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.1_beta1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - network apps: kmail..."
+KEYWORDS="x86"
+
+src_install() {
+
+ kde_src_install
+
+ chmod +s ${D}/${KDEDIR}/bin/reslisa
+
+ # empty config file needed for lisa to work with default settings
+ touch ${D}/etc/lisarc
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${D}/etc/init.d/reslisa
+ chmod +x ${D}/etc/init.d/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+
+}
+
diff --git a/kde-base/kdepim/files/digest-kdepim-3.1_beta1 b/kde-base/kdepim/files/digest-kdepim-3.1_beta1
new file mode 100644
index 000000000000..8d5405394b36
--- /dev/null
+++ b/kde-base/kdepim/files/digest-kdepim-3.1_beta1
@@ -0,0 +1 @@
+MD5 b421b6a8c3063e0ea8a139f8dd5a23b4 kdepim-3.0.7.tar.bz2 3069887
diff --git a/kde-base/kdepim/kdepim-3.1_beta1.ebuild b/kde-base/kdepim/kdepim-3.1_beta1.ebuild
new file mode 100644
index 000000000000..cc3c66a5ea38
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.1_beta1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - PIM (Personal Information Management) apps: korganizer..."
+KEYWORDS="x86"
+DEPEND="$DEPEND sys-devel/perl"
+
+newdepend "pda? ( >=dev-libs/pilot-link-0.11.1-r1 )
+ ~kde-base/kdebase-$PV"
+
+use pda && myconf="$myconf --with-extra-includes=/usr/include/libpisock"
+
+src_install() {
+ kde_src_install
+ docinto html
+ dodoc *.html
+}
diff --git a/kde-base/kdesdk/files/digest-kdesdk-3.1_beta1 b/kde-base/kdesdk/files/digest-kdesdk-3.1_beta1
new file mode 100644
index 000000000000..0095adf9abea
--- /dev/null
+++ b/kde-base/kdesdk/files/digest-kdesdk-3.1_beta1
@@ -0,0 +1 @@
+MD5 28400c5125aa370c1977f4778da75a3f kdesdk-3.0.7.tar.bz2 1990341
diff --git a/kde-base/kdesdk/kdesdk-3.1_beta1.ebuild b/kde-base/kdesdk/kdesdk-3.1_beta1.ebuild
new file mode 100644
index 000000000000..7f823444b7de
--- /dev/null
+++ b/kde-base/kdesdk/kdesdk-3.1_beta1.ebuild
@@ -0,0 +1,7 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - SDK: kbabel, ..."
+KEYWORDS="x86"
diff --git a/kde-base/kdetoys/files/digest-kdetoys-3.1_beta1 b/kde-base/kdetoys/files/digest-kdetoys-3.1_beta1
new file mode 100644
index 000000000000..66780007483a
--- /dev/null
+++ b/kde-base/kdetoys/files/digest-kdetoys-3.1_beta1
@@ -0,0 +1 @@
+MD5 7a61b95500afce90b5f12bd8eaa6ee54 kdetoys-3.0.7.tar.bz2 1382537
diff --git a/kde-base/kdetoys/kdetoys-3.1_beta1.ebuild b/kde-base/kdetoys/kdetoys-3.1_beta1.ebuild
new file mode 100644
index 000000000000..846d0a650009
--- /dev/null
+++ b/kde-base/kdetoys/kdetoys-3.1_beta1.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdetoys/kdetoys-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - toys"
+KEYWORDS="x86"
+
diff --git a/kde-base/kdeutils/files/digest-kdeutils-3.1_beta1 b/kde-base/kdeutils/files/digest-kdeutils-3.1_beta1
new file mode 100644
index 000000000000..a29304d7914f
--- /dev/null
+++ b/kde-base/kdeutils/files/digest-kdeutils-3.1_beta1
@@ -0,0 +1 @@
+MD5 0979ef2e7773524c4941daa84a065d26 kdeutils-3.0.7.tar.bz2 1301516
diff --git a/kde-base/kdeutils/kdeutils-3.1_beta1.ebuild b/kde-base/kdeutils/kdeutils-3.1_beta1.ebuild
new file mode 100644
index 000000000000..cad14cba34f3
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.1_beta1.ebuild
@@ -0,0 +1,7 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.1_beta1.ebuild,v 1.1 2002/08/22 21:13:57 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - utilities"
+KEYWORDS="x86"