summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/leechcraft-bittorrent/ChangeLog10
-rw-r--r--net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.4.99.ebuild18
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/ChangeLog10
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.99.ebuild50
4 files changed, 84 insertions, 4 deletions
diff --git a/net-p2p/leechcraft-bittorrent/ChangeLog b/net-p2p/leechcraft-bittorrent/ChangeLog
index 0be1519dd543..113b4561bb1f 100644
--- a/net-p2p/leechcraft-bittorrent/ChangeLog
+++ b/net-p2p/leechcraft-bittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/leechcraft-bittorrent
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-bittorrent/ChangeLog,v 1.5 2011/12/31 12:18:31 maksbotan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-bittorrent/ChangeLog,v 1.6 2012/02/02 17:49:53 maksbotan Exp $
+
+*leechcraft-bittorrent-0.4.99 (02 Feb 2012)
+
+ 02 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-bittorrent-0.4.99.ebuild:
+ Bump net-p2p/leechcraft-bittorrent to 0.4.99, thanks to 0xd34df00d
*leechcraft-bittorrent-0.4.97 (31 Dec 2011)
diff --git a/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.4.99.ebuild b/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.4.99.ebuild
new file mode 100644
index 000000000000..244524f487d9
--- /dev/null
+++ b/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.4.99.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.4.99.ebuild,v 1.1 2012/02/02 17:49:53 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ net-libs/rb_libtorrent"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-task-show"
diff --git a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
index cfbdb04eab7f..c6eeb9208184 100644
--- a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
+++ b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/leechcraft-eiskaltdcpp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.5 2011/12/31 12:18:55 maksbotan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.6 2012/02/02 17:50:23 maksbotan Exp $
+
+*leechcraft-eiskaltdcpp-0.4.99 (02 Feb 2012)
+
+ 02 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-eiskaltdcpp-0.4.99.ebuild:
+ Bump net-p2p/leechcraft-eiskaltdcpp to 0.4.99, thanks to 0xd34df00d
*leechcraft-eiskaltdcpp-0.4.97 (31 Dec 2011)
diff --git a/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.99.ebuild b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.99.ebuild
new file mode 100644
index 000000000000..429e18835384
--- /dev/null
+++ b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.99.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.99.ebuild,v 1.1 2012/02/02 17:50:23 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="EiskaltDC++ ported to LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +emoticons examples javascript lua pcre spell sqlite upnp"
+
+RDEPEND="~net-misc/leechcraft-core-${PV}
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/openssl-0.9.8
+ virtual/libiconv
+ sys-devel/gettext
+ lua? ( >=dev-lang/lua-5.1 )
+ upnp? ( net-libs/miniupnpc )
+ javascript? (
+ x11-libs/qt-script
+ x11-libs/qtscriptgenerator
+ )
+ spell? ( app-text/aspell )
+ sqlite? ( x11-libs/qt-sql:4[sqlite] )
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ virtual/leechcraft-task-show
+ !!net-p2p/eiskaltdcpp"
+DEPEND="~net-misc/leechcraft-core-${PV}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use lua LUA_SCRIPT)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use javascript USE_JS)"
+ "$(cmake-utils_use spell USE_ASPELL)"
+ "$(cmake-utils_use sqlite USE_QT_SQLITE)"
+ "$(cmake-utils_use upnp USE_MINIUPNP)"
+ -DLOCAL_MINIUPNP="0"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
+ "$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use pcre PERL_REGEX)"
+ )
+
+ cmake-utils_src_configure
+}