summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-firewall/shorewall-common/ChangeLog6
-rw-r--r--net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild19
-rw-r--r--net-firewall/shorewall-lite/ChangeLog6
-rw-r--r--net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild15
-rw-r--r--net-firewall/shorewall-perl/ChangeLog6
-rw-r--r--net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild22
-rw-r--r--net-firewall/shorewall-shell/ChangeLog6
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild21
-rw-r--r--net-firewall/shorewall/ChangeLog8
-rw-r--r--net-firewall/shorewall/shorewall-4.0-r1.ebuild28
10 files changed, 91 insertions, 46 deletions
diff --git a/net-firewall/shorewall-common/ChangeLog b/net-firewall/shorewall-common/ChangeLog
index e034babf5ca9..d49c842718df 100644
--- a/net-firewall/shorewall-common/ChangeLog
+++ b/net-firewall/shorewall-common/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/shorewall-common
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.10 2008/02/24 18:46:36 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.11 2008/02/25 18:06:26 pva Exp $
+
+ 25 Feb 2008; <pva@gentoo.org> shorewall-common-4.0.9.ebuild:
+ Don't depend on shorewall-shell by default, bug #211321, thank you Stefan
+ Wimmer for report and Vieri for the fix.
*shorewall-common-4.0.9 (24 Feb 2008)
diff --git a/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild b/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild
index dcfcef3b4e9f..6ed485b6b717 100644
--- a/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild
+++ b/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild,v 1.1 2008/02/24 18:46:36 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.0.9.ebuild,v 1.2 2008/02/25 18:06:26 pva Exp $
inherit eutils
-# Choose between experimental, stable and beta:
-#MY_P_TREE="development/4.0" # experimental and beta
-MY_P_TREE="4.0" # stable
-#MY_P_BETA="-RC1" # only beta and RC
-MY_P_BETA="" # stable or experimental
+# Select version (stable, RC, Beta, upstream patched):
+MY_P_TREE="4.0" # stable/devel (eg. "4.0" or "development/4.0")
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_P_PATCH="" # upstream patch (eg. ".2")
MY_P="${P/-common/}${MY_P_BETA}"
MY_PN="${PN/-common/}"
@@ -17,7 +16,7 @@ MY_P_DOCS="${MY_P/${MY_PN}/${MY_PN}-docs-html}"
DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
HOMEPAGE="http://www.shorewall.net/"
-SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/${P}${MY_P_PATCH}${MY_P_BETA}.tar.bz2
doc? ( http://www1.shorewall.net/pub/${MY_PN}/${MY_P_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
LICENSE="GPL-2"
@@ -27,7 +26,6 @@ IUSE="doc"
DEPEND=">=net-firewall/iptables-1.2.4
sys-apps/iproute2
- ~net-firewall/shorewall-shell-${PV}
!<net-firewall/shorewall-4.0"
pkg_setup() {
@@ -43,7 +41,7 @@ src_compile() {
src_install() {
keepdir /var/lib/shorewall
- cd "${WORKDIR}/${P}${MY_P_BETA}"
+ cd "${WORKDIR}/${P}${MY_P_PATCH}${MY_P_BETA}"
PREFIX="${D}" ./install.sh || die "install.sh failed"
newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
@@ -54,7 +52,7 @@ src_install() {
dohtml -r *
## dosym Documentation_Index.html "/usr/share/doc/${PF}/html/index.htm"
# install samples
- cp -pR "${S}${MY_P_BETA}/Samples" "${D}/usr/share/doc/${PF}"
+ cp -pR "${S}${MY_P_PATCH}${MY_P_BETA}/Samples" "${D}/usr/share/doc/${PF}"
fi
}
@@ -97,5 +95,4 @@ pkg_postinst() {
elog
elog "${PN} requires a compiler."
elog "You can choose to emerge shorewall-shell and/or shorewall-perl."
- elog "As of ${PV} shorewall-shell is mandatory."
}
diff --git a/net-firewall/shorewall-lite/ChangeLog b/net-firewall/shorewall-lite/ChangeLog
index f01cdfada289..a1ce44aa4718 100644
--- a/net-firewall/shorewall-lite/ChangeLog
+++ b/net-firewall/shorewall-lite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/shorewall-lite
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.30 2008/02/25 14:56:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.31 2008/02/25 18:08:46 pva Exp $
+
+ 25 Feb 2008; <pva@gentoo.org> shorewall-lite-4.0.9.ebuild:
+ Don't depend on shorewall-shell by default, bug #211321, thank you Stefan
+ Wimmer for report and Vieri for the fix.
25 Feb 2008; Jeroen Roovers <jer@gentoo.org> shorewall-lite-3.4.7.ebuild:
Stable for HPPA (bug #210902).
diff --git a/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild b/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild
index 762b6da26475..2e4a1ce70c65 100644
--- a/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild
+++ b/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild,v 1.1 2008/02/24 18:52:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/shorewall-lite-4.0.9.ebuild,v 1.2 2008/02/25 18:08:46 pva Exp $
-# Choose between experimental, stable and beta:
-#MY_P_TREE="development/4.0" # experimental and beta
-MY_P_TREE="4.0" # stable
-#MY_P_BETA="-Beta7" # only beta
-MY_P_BETA="" # stable or experimental
+# Select version (stable, RC, Beta, upstream patched):
+MY_P_TREE="4.0" # stable/devel (eg. "4.0" or "development/4.0")
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_P_PATCH="" # upstream patch (eg. ".2")
MY_P_DOCS="${P/${PN}/shorewall-docs-html}"
@@ -14,7 +13,7 @@ MY_P="shorewall-${PV}"
DESCRIPTION="An iptables-based firewall whose config is handled by a normal Shorewall."
HOMEPAGE="http://www.shorewall.net/"
-SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_PATCH}${MY_P_BETA}.tar.bz2
doc? ( http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${MY_P_DOCS}${MY_P_BETA}.tar.bz2 )"
LICENSE="GPL-2"
@@ -32,7 +31,7 @@ src_compile() {
src_install() {
keepdir /var/lib/shorewall-lite
- cd "${WORKDIR}/${P}${MY_P_BETA}"
+ cd "${WORKDIR}/${P}${MY_P_PATCH}${MY_P_BETA}"
PREFIX="${D}" ./install.sh || die "install.sh failed"
newinitd "${FILESDIR}/shorewall-lite" shorewall-lite
diff --git a/net-firewall/shorewall-perl/ChangeLog b/net-firewall/shorewall-perl/ChangeLog
index 002f79141be0..551cde07ccbc 100644
--- a/net-firewall/shorewall-perl/ChangeLog
+++ b/net-firewall/shorewall-perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/shorewall-perl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.11 2008/02/24 18:49:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.12 2008/02/25 18:10:27 pva Exp $
+
+ 25 Feb 2008; <pva@gentoo.org> shorewall-perl-4.0.9.ebuild:
+ Don't depend on shorewall-shell by default, bug #211321, thank you Stefan
+ Wimmer for report and Vieri for the fix.
*shorewall-perl-4.0.9 (24 Feb 2008)
diff --git a/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild b/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild
index 614aeb7d223d..055f044a8b32 100644
--- a/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild
+++ b/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild,v 1.1 2008/02/24 18:49:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/shorewall-perl-4.0.9.ebuild,v 1.2 2008/02/25 18:10:27 pva Exp $
-# Choose between experimental, stable and beta:
-#MY_P_TREE="development/4.0" # experimental and beta
-MY_P_TREE="4.0" # stable
-#MY_P_BETA="-Beta7" # only beta
-MY_P_BETA="" # stable or experimental
+# Select version (stable, RC, Beta, upstream patched):
+MY_P_TREE="4.0" # stable/devel (eg. "4.0" or "development/4.0")
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_P_PATCH="" # upstream patch (eg. ".2")
MY_P="shorewall-${PV}"
DESCRIPTION="Shoreline Firewall Perl-based compiler that allows faster compilation and execution."
HOMEPAGE="http://www.shorewall.net/"
-SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_PATCH}${MY_P_BETA}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
IUSE=""
DEPEND="net-firewall/iptables
@@ -31,7 +31,7 @@ src_compile() {
}
src_install() {
- cd "${WORKDIR}/${P}${MY_P_BETA}"
+ cd "${WORKDIR}/${P}${MY_P_PATCH}${MY_P_BETA}"
PREFIX="${D}" ./install.sh || die "install.sh failed"
dodoc releasenotes.txt
@@ -41,9 +41,9 @@ pkg_postinst() {
einfo
einfo "Documentation is available at http://www.shorewall.net"
einfo
- einfo "In order to use the Perl compiler you need to add"
- einfo "SHOREWALL_COMPILER=perl"
- einfo "to shorewall.conf"
+ elog "In order to use the Perl compiler you need to add"
+ elog "SHOREWALL_COMPILER=perl"
+ elog "to shorewall.conf unless you did not install the Shell compiler."
einfo
einfo "Please read the included release notes for more information."
einfo
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index 9360025f4efa..7ecedb7f7d24 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/shorewall-shell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.9 2008/02/24 18:45:36 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.10 2008/02/25 18:11:55 pva Exp $
+
+ 25 Feb 2008; <pva@gentoo.org> shorewall-shell-4.0.9.ebuild:
+ Don't depend on shorewall-shell by default, bug #211321, thank you Stefan
+ Wimmer for report and Vieri for the fix.
*shorewall-shell-4.0.9 (24 Feb 2008)
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild
index 052a73eb3e44..6742056d13de 100644
--- a/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild,v 1.1 2008/02/24 18:45:36 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild,v 1.2 2008/02/25 18:11:55 pva Exp $
-# Choose between experimental, stable and beta:
-#MY_P_TREE="development/4.0" # experimental and beta
-MY_P_TREE="4.0" # stable
-#MY_P_BETA="-Beta7" # only beta
-MY_P_BETA="" # stable or experimental
+# Select version (stable, RC, Beta, upstream patched):
+MY_P_TREE="4.0" # stable/devel (eg. "4.0" or "development/4.0")
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_P_PATCH="" # upstream patch (eg. ".2")
MY_P="shorewall-${PV}"
DESCRIPTION="Shoreline Firewall shell-based compiler."
HOMEPAGE="http://www.shorewall.net/"
-SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_PATCH}${MY_P_BETA}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -30,7 +29,7 @@ src_compile() {
}
src_install() {
- cd "${WORKDIR}/${P}${MY_P_BETA}"
+ cd "${WORKDIR}/${P}${MY_P_PATCH}${MY_P_BETA}"
PREFIX="${D}" ./install.sh || die "install.sh failed"
dodoc releasenotes.txt
@@ -40,9 +39,9 @@ pkg_postinst() {
einfo
einfo "Documentation is available at http://www.shorewall.net"
einfo
- einfo "In order to use the shell compiler you need to add"
- einfo "SHOREWALL_COMPILER=shell"
- einfo "to shorewall.conf"
+ elog "In order to use the shell compiler you need to add"
+ elog "SHOREWALL_COMPILER=shell"
+ elog "to shorewall.conf unless you do not have the Perl compiler."
einfo
einfo "Please read the included release notes for more information."
einfo
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index 8b4d125a54c0..995c174f9a04 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.156 2008/02/25 14:56:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.157 2008/02/25 18:03:25 pva Exp $
+
+*shorewall-4.0-r1 (25 Feb 2008)
+
+ 25 Feb 2008; <pva@gentoo.org> +shorewall-4.0-r1.ebuild:
+ Don't depend on shorewall-shell by default, bug #211321, thank you Stefan
+ Wimmer for report and Vieri for the fix.
25 Feb 2008; Jeroen Roovers <jer@gentoo.org> shorewall-3.4.7.ebuild:
Stable for HPPA (bug #210902).
diff --git a/net-firewall/shorewall/shorewall-4.0-r1.ebuild b/net-firewall/shorewall/shorewall-4.0-r1.ebuild
new file mode 100644
index 000000000000..1d88866f82a8
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.0-r1.ebuild,v 1.1 2008/02/25 18:03:25 pva Exp $
+
+inherit eutils
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=net-firewall/shorewall-common-${PV}"
+
+pkg_setup() {
+ ewarn "Shorewall as such has been removed and split into three packages:"
+ ewarn "shorewall-common, shorewall-shell and shorewall-perl."
+ ewarn "From now on you should emerge shorewall-shell and/or shorewall-perl."
+ ewarn ""
+ ewarn "If you are upgrading from <${P} and you wish to continue using the"
+ ewarn "shell compiler then you should emerge shorewall-shell. If you decide"
+ ewarn "to move to the perl compiler then you can also emerge shorewall-perl"
+ ewarn "and specify the compiler type in shorewall.conf."
+ ewarn "If this is a new installation then you can emerge shorewall-shell"
+ ewarn "and/or shorewall-perl."
+}