summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/pg/ChangeLog5
-rw-r--r--dev-ruby/pg/pg-0.8.0.ebuild53
-rw-r--r--dev-ruby/right_http_connection/ChangeLog6
-rw-r--r--dev-ruby/right_http_connection/right_http_connection-1.2.4.ebuild23
4 files changed, 9 insertions, 78 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index 34e5b4bfb764..5e72dcf34515 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.16 2010/05/23 10:03:10 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.17 2010/07/29 10:00:56 flameeyes Exp $
+
+ 29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org> -pg-0.8.0.ebuild:
+ Cleanup old version.
23 May 2010; Alex Legler <a3li@gentoo.org> pg-0.9.0-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/pg/pg-0.8.0.ebuild b/dev-ruby/pg/pg-0.8.0.ebuild
deleted file mode 100644
index 9250e70282bd..000000000000
--- a/dev-ruby/pg/pg-0.8.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.8.0.ebuild,v 1.8 2010/02/13 20:43:30 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19"
-
-# Tests will always fail because they need access to the pgsql server
-RUBY_FAKEGEM_TEST_TASK="spec"
-RESTRICT="test"
-
-RUBY_FAKEGEM_DOCDIR="doc/rdoc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
-HOMEPAGE="http://bitbucket.org/ged/ruby-pg/"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND="dev-db/postgresql-base"
-DEPEND="${RDEPEND}"
-
-all_ruby_prepare() {
- sed -i \
- -e '/ext_helper/s:^:#:' \
- -e '/setup_extension/s:^:#:' \
- -e '/task :spec =>/s:^:#:' \
- Rakefile || die "Rakefile fix failed"
-}
-
-each_ruby_compile() {
- pushd "${S}"/ext
- ${RUBY} extconf.rb || die "extconf.rb failed"
- emake || die "emake failed"
- popd
-}
-
-each_ruby_install() {
- ruby_fakegem_newins ext/pg.so lib/pg.so
- each_fakegem_install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc sample/*.rb || die "sample installation failed"
-}
diff --git a/dev-ruby/right_http_connection/ChangeLog b/dev-ruby/right_http_connection/ChangeLog
index e7b4685f1fb1..269f6a7b7048 100644
--- a/dev-ruby/right_http_connection/ChangeLog
+++ b/dev-ruby/right_http_connection/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/right_http_connection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.4 2010/05/28 17:42:50 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.5 2010/07/29 10:05:53 flameeyes Exp $
+
+ 29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -right_http_connection-1.2.4.ebuild:
+ Cleanup old version.
28 May 2010; Joseph Jezak <josejx@gentoo.org>
right_http_connection-1.2.4-r1.ebuild:
diff --git a/dev-ruby/right_http_connection/right_http_connection-1.2.4.ebuild b/dev-ruby/right_http_connection/right_http_connection-1.2.4.ebuild
deleted file mode 100644
index 5cf200af9d1d..000000000000
--- a/dev-ruby/right_http_connection/right_http_connection-1.2.4.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/right_http_connection-1.2.4.ebuild,v 1.1 2010/01/12 14:07:07 flameeyes Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="RightScale's robust HTTP/S connection module"
-HOMEPAGE="http://rightscale.rubyforge.org/"
-
-LICENSE="as-is" # truly
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""