summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/ORBit/ORBit-0.5.13.ebuild56
-rw-r--r--gnome-base/ORBit/files/digest-ORBit-0.5.131
-rw-r--r--gnome-base/bonobo/bonobo-1.0.19.ebuild55
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.191
-rw-r--r--gnome-base/oaf/files/digest-oaf-0.6.81
-rw-r--r--gnome-base/oaf/oaf-0.6.8.ebuild57
6 files changed, 171 insertions, 0 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.13.ebuild b/gnome-base/ORBit/ORBit-0.5.13.ebuild
new file mode 100644
index 000000000000..8b7f04f4268a
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.13.ebuild,v 1.1 2002/02/13 16:52:53 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ >=dev-libs/glib-1.2.8"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.8"
+
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+
+ cd ${D}/usr/lib
+ patch -p0 < ${FILESDIR}/libIDLConf.sh-gentoo.diff
+}
+
+
+
diff --git a/gnome-base/ORBit/files/digest-ORBit-0.5.13 b/gnome-base/ORBit/files/digest-ORBit-0.5.13
new file mode 100644
index 000000000000..8f78e352be24
--- /dev/null
+++ b/gnome-base/ORBit/files/digest-ORBit-0.5.13
@@ -0,0 +1 @@
+MD5 89b16a12e565798945b49e9f41d1db5d ORBit-0.5.13.tar.gz 1183657
diff --git a/gnome-base/bonobo/bonobo-1.0.19.ebuild b/gnome-base/bonobo/bonobo-1.0.19.ebuild
new file mode 100644
index 000000000000..1eac960a2706
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.19.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.19.ebuild,v 1.1 2002/02/13 16:56:54 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ chmod 644 ${D}/usr/lib/pkgconfig/libefs.pc
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.19 b/gnome-base/bonobo/files/digest-bonobo-1.0.19
new file mode 100644
index 000000000000..2df9d2634efb
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.19
@@ -0,0 +1 @@
+MD5 97a13cb5c86a5d75c3507a4ad2813090 bonobo-1.0.19.tar.gz 1556542
diff --git a/gnome-base/oaf/files/digest-oaf-0.6.8 b/gnome-base/oaf/files/digest-oaf-0.6.8
new file mode 100644
index 000000000000..b4ee3fa36030
--- /dev/null
+++ b/gnome-base/oaf/files/digest-oaf-0.6.8
@@ -0,0 +1 @@
+MD5 d1a7cd8cd87b78fe049c225d4f0a7f1e oaf-0.6.8.tar.gz 550965
diff --git a/gnome-base/oaf/oaf-0.6.8.ebuild b/gnome-base/oaf/oaf-0.6.8.ebuild
new file mode 100644
index 000000000000..bec57a967feb
--- /dev/null
+++ b/gnome-base/oaf/oaf-0.6.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.8.ebuild,v 1.1 2002/02/13 16:54:16 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Object Activation Framework for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/popt-1.5
+ >=gnome-base/ORBit-0.5.10-r1
+ >=dev-libs/libxml-1.8.15"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp -a configure configure.orig
+ sed -e "s:perl5\.00404:perl5.6.1:" configure.orig > configure
+ rm configure.orig
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}