summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/ethereal/ethereal-0.8.14.ebuild34
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.8.141
-rw-r--r--net-dialup/qtwvdialer/files/digest-qtwvdialer-0.3.11
-rw-r--r--net-dialup/qtwvdialer/qtwvdialer-0.3.1.ebuild34
-rw-r--r--net-print/gtklp/files/digest-gtklp-0.6d1
-rw-r--r--net-print/gtklp/gtklp-0.6d.ebuild31
-rw-r--r--net-www/amaya/amaya-4.1.ebuild36
-rw-r--r--net-www/amaya/files/digest-amaya-4.11
-rw-r--r--sys-apps/file/file-3.33.ebuild29
-rw-r--r--sys-apps/file/files/digest-file-3.331
-rw-r--r--sys-apps/modutils/files/digest-modutils-2.3.211
-rw-r--r--sys-apps/modutils/modutils-2.3.21.ebuild32
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.10q1
-rw-r--r--sys-apps/util-linux/util-linux-2.10q.ebuild40
-rw-r--r--sys-devel/bin86/bin86-0.15.4.ebuild33
-rw-r--r--sys-devel/bin86/files/digest-bin86-0.15.41
-rw-r--r--sys-devel/binutils/binutils-2.10.1.ebuild64
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.10.11
18 files changed, 342 insertions, 0 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.8.14.ebuild b/net-analyzer/ethereal/ethereal-0.8.14.ebuild
new file mode 100644
index 000000000000..10efe811cb08
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.8.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.8.14.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="ethereal"
+SRC_URI="http://ethereal.zing.org/distribution/${A}
+ ftp://ethereal.zing.org/pub/ethereal/${A}"
+HOMEPAGE="http://ethereal.zing.org/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=dev-libs/glib-1.2.8
+ >=x11-libs/gtk+-1.2.8
+ >=net-libs/libpcap-0.5.2
+ >=x11-base/xfree-4.0.1"
+
+src_compile() {
+ cd ${S}
+ LDFLAGS="-L/usr/lib -lz" try ./configure --host=${CHOST} --prefix=/usr/X11R6 --sysconfdir=/etc/ethereal
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/ethereal install
+ prepman /usr/X11R6
+ dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
+
+}
+
+
+
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.8.14 b/net-analyzer/ethereal/files/digest-ethereal-0.8.14
new file mode 100644
index 000000000000..fc4ccd0bd027
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.8.14
@@ -0,0 +1 @@
+MD5 470dd018c417a4bd31f1fafdc57cfe06 ethereal-0.8.14.tar.gz
diff --git a/net-dialup/qtwvdialer/files/digest-qtwvdialer-0.3.1 b/net-dialup/qtwvdialer/files/digest-qtwvdialer-0.3.1
new file mode 100644
index 000000000000..84e84680773f
--- /dev/null
+++ b/net-dialup/qtwvdialer/files/digest-qtwvdialer-0.3.1
@@ -0,0 +1 @@
+MD5 0f74cd54b8d702ae16777122b9a622ab qtwvdialer-0.3.1.tgz
diff --git a/net-dialup/qtwvdialer/qtwvdialer-0.3.1.ebuild b/net-dialup/qtwvdialer/qtwvdialer-0.3.1.ebuild
new file mode 100644
index 000000000000..05a9e4a25cd3
--- /dev/null
+++ b/net-dialup/qtwvdialer/qtwvdialer-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/qtwvdialer/qtwvdialer-0.3.1.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+S=${WORKDIR}/QtWvDialer-${PV}
+DESCRIPTION="QT Frontend for wvdial"
+SRC_URI="http://private.addcom.de/toussaint/${P}.tgz"
+HOMEPAGE="http://private.addcom.de/toussaint/qtwvdialer.html"
+
+DEPEND=">=kde-base/qt-x11-2.2.1
+ >=dev-util/tmake-1.6"
+
+src_compile() {
+
+ cd ${S}
+ export TMAKEPATH="/usr/lib/tmake/linux-g++"
+ cp configure configure.orig
+ sed -e "s:TMAKEPATH/\.\./\.\./bin/tmake:TMAKEPATH/../../../bin/tmake:" \
+ configure.orig > configure
+ try ./configure
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ insinto /usr/X11R6
+ dobin bin/qtwvdialer
+ dodoc AUTHORS CHANGELOG COPYING README
+
+}
+
diff --git a/net-print/gtklp/files/digest-gtklp-0.6d b/net-print/gtklp/files/digest-gtklp-0.6d
new file mode 100644
index 000000000000..c4c66636591c
--- /dev/null
+++ b/net-print/gtklp/files/digest-gtklp-0.6d
@@ -0,0 +1 @@
+MD5 f48d140ccb9a0b856ffe916fbad8bd8d gtklp-0.6d.src.tgz
diff --git a/net-print/gtklp/gtklp-0.6d.ebuild b/net-print/gtklp/gtklp-0.6d.ebuild
new file mode 100644
index 000000000000..d00f1f919b90
--- /dev/null
+++ b/net-print/gtklp/gtklp-0.6d.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.6d.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+S=${WORKDIR}/src
+DESCRIPTION="A GUI fort cupsd"
+SRC_URI="http://www.stud.uni-hannover.de/~sirtobi/gtklp/files/${P}.src.tgz"
+HOMEPAGE="http://www.stud.uni-hannover.de/~sirtobi/gtklp"
+
+DEPEND=">=x11-libs/gtk+-1.2.8
+ >=net-print/cups-1.1.4"
+
+src_compile() {
+
+ cd ${S}
+ try make CCFLAGS=\"$CFLAGS\"
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr/X11R6
+ dobin gtklp
+ dodoc gtklprc.path.sample
+ docinto html
+ dodoc doc/*.html doc/*.jpg doc/*.gif
+
+}
+
diff --git a/net-www/amaya/amaya-4.1.ebuild b/net-www/amaya/amaya-4.1.ebuild
new file mode 100644
index 000000000000..b37799ba68cb
--- /dev/null
+++ b/net-www/amaya/amaya-4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/net-www/amaya/amaya-4.1.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+#P=
+A=${PN}-src-${PV}.tgz
+S=${WORKDIR}/Amaya/LINUX-ELF
+DESCRIPTION="The W3C Web-Browser"
+SRC_URI="ftp://ftp.w3.org/pub/amaya/${PN}-src-${PV}.tgz"
+HOMEPAGE="http://www.w3.org/Amaya/"
+
+
+src_compile() {
+
+ mkdir ${S}
+ cd ${S}
+ try ../configure --prefix=/usr/X11R6 --host=${CHOST} \
+ --without-included-jpeg
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ dodir /usr/X11R6
+ try make prefix=${D}/usr/X11R6 install
+ rm ${D}/usr/X11R6/bin/amaya
+ rm ${D}/usr/X11R6/bin/print
+ dosym /usr/X11R6/Amaya/applis/bin/amaya /usr/X11R6/bin/amaya
+ dosym /usr/X11R6/Amaya/applis/bin/print /usr/X11R6/bin/print
+ dodoc README*
+
+}
+
diff --git a/net-www/amaya/files/digest-amaya-4.1 b/net-www/amaya/files/digest-amaya-4.1
new file mode 100644
index 000000000000..729e4bf11029
--- /dev/null
+++ b/net-www/amaya/files/digest-amaya-4.1
@@ -0,0 +1 @@
+MD5 ccfa14d1796e6ee152e5b6a1777b5525 amaya-src-4.1.tgz
diff --git a/sys-apps/file/file-3.33.ebuild b/sys-apps/file/file-3.33.ebuild
new file mode 100644
index 000000000000..8906286fd7eb
--- /dev/null
+++ b/sys-apps/file/file-3.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patters"
+#unfortunately, this ftp site doesn't support passive ftp
+#maybe we can find an alternative for those behind firewalls, or mirror
+#on cvs.gentoo.org
+SRC_URI="ftp://ftp.astron.com/pub/file/${A}"
+
+src_compile() {
+ try ./configure --prefix=/usr --datadir=/etc --host=${CHOST}
+ try make
+}
+
+src_install() {
+ into /usr
+ dobin file
+ doman file.1 magic.4
+ insinto /etc
+ doins magic magic.mime
+ dodoc LEGAL.NOTICE MAINT README
+}
+
+
+
diff --git a/sys-apps/file/files/digest-file-3.33 b/sys-apps/file/files/digest-file-3.33
new file mode 100644
index 000000000000..9a0e1f33e262
--- /dev/null
+++ b/sys-apps/file/files/digest-file-3.33
@@ -0,0 +1 @@
+MD5 3b8e32ed3a79774bd92f0052fa07ca04 file-3.33.tar.gz
diff --git a/sys-apps/modutils/files/digest-modutils-2.3.21 b/sys-apps/modutils/files/digest-modutils-2.3.21
new file mode 100644
index 000000000000..bb9862096c1e
--- /dev/null
+++ b/sys-apps/modutils/files/digest-modutils-2.3.21
@@ -0,0 +1 @@
+MD5 0ceccc4f1263114f9834fb56c653338f modutils-2.3.21.tar.bz2
diff --git a/sys-apps/modutils/modutils-2.3.21.ebuild b/sys-apps/modutils/modutils-2.3.21.ebuild
new file mode 100644
index 000000000000..49c39bd6768a
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.3.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.3.21.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.3/${A}
+ ftp://ftp.ocs.com.au/pub/modutils/v2.3/${A}"
+
+src_compile() {
+ try ./configure --prefix=/ --host=${CHOST}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ dodir /sbin
+ dodir /usr/man/man1
+ dodir /usr/man/man8
+ dodir /usr/man/man5
+ dodir /usr/man/man2
+ try make prefix=${D} mandir=${D}/usr/man install
+ prepman
+ strip ${D}/sbin/*
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+
+
+
+
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.10q b/sys-apps/util-linux/files/digest-util-linux-2.10q
new file mode 100644
index 000000000000..bdcd5068c5a5
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.10q
@@ -0,0 +1 @@
+MD5 d17838e34cbe2673ed6b8747b10964ce util-linux-2.10q.tar.bz2
diff --git a/sys-apps/util-linux/util-linux-2.10q.ebuild b/sys-apps/util-linux/util-linux-2.10q.ebuild
new file mode 100644
index 000000000000..41183a168f1d
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.10q.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.10q.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/util-linux/${P}.tar.bz2"
+
+src_compile() {
+ try ./configure
+ try make
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ patch -p1 < ${FILESDIR}/util-linux-2.10o*
+ cp MCONFIG MCONFIG.orig
+ sed -e "s/-pipe -O2 -m486 -fomit-frame-pointer/${CFLAGS}/" \
+ -e "s/HAVE_PAM=no/HAVE_PAM=yes/" \
+ -e "s/HAVE_SLN=no/HAVE_SLN=yes/" \
+ -e "s/HAVE_TSORT=no/HAVE_TSORT=yes/" \
+ -e "s/# HAVE_SLANG/HAVE_SLANG/" \
+ -e "s/# SLANGFLAGS/SLANGSFLAGS/" \
+ MCONFIG.orig > MCONFIG
+
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ cd ${S}
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}
+
+
diff --git a/sys-devel/bin86/bin86-0.15.4.ebuild b/sys-devel/bin86/bin86-0.15.4.ebuild
new file mode 100644
index 000000000000..71fcb761daf1
--- /dev/null
+++ b/sys-devel/bin86/bin86-0.15.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.15.4.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/bin86
+DESCRIPTION="Assembler and loader used to create kernel bootsector"
+SRC_URI="http://www.cix.co.uk/~mayday/${A}"
+HOMEPAGE="http://www.cix.co.uk/~mayday/"
+
+src_compile() {
+ try make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s/CFLAGS=-O2/CFLAGS=${CFLAGS}/" Makefile.orig > Makefile
+}
+
+src_install() {
+ into /usr
+ dobin as/as86 as/as86_encap ld/ld86 ld/objdump86 ld/catimage ld/objchop
+ dosym objdump86 /usr/bin/nm86
+ dosym objdump86 /usr/bin/size86
+ doman man/*.1
+ dosym as86_encap.1.gz /usr/man/man1/as86_encap.1.gz
+ dodoc README README-0.4 ChangeLog as/COPYING as/TODO
+}
+
+
diff --git a/sys-devel/bin86/files/digest-bin86-0.15.4 b/sys-devel/bin86/files/digest-bin86-0.15.4
new file mode 100644
index 000000000000..26a7c3731184
--- /dev/null
+++ b/sys-devel/bin86/files/digest-bin86-0.15.4
@@ -0,0 +1 @@
+MD5 8ac305eeb5cb0cb6ce90e7e30f7c11f0 bin86-0.15.4.tar.gz
diff --git a/sys-devel/binutils/binutils-2.10.1.ebuild b/sys-devel/binutils/binutils-2.10.1.ebuild
new file mode 100644
index 000000000000..d0c42cb4aa27
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.10.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.1.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="ftp://ftp.gnu.org/gnu/binutils/${A}"
+
+src_compile() {
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install() {
+ #I'm sure this can be simplified with a "try make PREFIX=${D}/usr install"
+ #one of these days...
+ into /usr
+ doman binutils/*.1 gas/doc/as.1 gprof/gprof.1
+ insinto /usr/lib
+ doins bfd/libbfd.la bfd/libbfd.a opcodes/libopcodes.a opcodes/libopcodes.la libiberty/libiberty.a
+ insinto /usr/include
+ doins bfd/bfd.h include/ansidecl.h include/bfdlink.h
+ cp binutils/nm-new binutils/nm
+ cp binutils/strip-new binutils/strip
+ cp gas/as-new gas/as
+ cp gas/gasp-new gas/gasp
+ cp ld/ld-new ld/ld
+ cd binutils
+ dobin addr2line ar cxxfilt nm objcopy objdump ranlib readelf size strings strip
+ cd ..
+ dobin ld/ld gprof/gprof gas/as gas/gasp
+ dodir /usr/${CHOST}/bin
+ for i in nm strip ar ranlib as ld
+ do
+ dosym /usr/bin/${i} /usr/${CHOST}/bin/${i}
+ done
+ insinto /usr/${CHOST}/lib/ldscripts
+ doins ld/ldscripts/*
+ dodoc COPYING* README* ChangeLog* mpw-README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/MAINTAINERS binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/MAINTAINERS gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/MAINTAINERS gprof/NOTES gprof/TEST gprof/TODO
+ docinto include
+ dodoc include/ChangeLog* include/COPYING include/MAINTAINERS
+ docinto intl
+ dodoc intl/ChangeLog
+ docinto ld
+ dodoc ld/ChangeLog* ld/MAINTAINERS ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog* opcodes/MAINTAINERS
+
+}
+
+
+
diff --git a/sys-devel/binutils/files/digest-binutils-2.10.1 b/sys-devel/binutils/files/digest-binutils-2.10.1
new file mode 100644
index 000000000000..ec81f98fe173
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.10.1
@@ -0,0 +1 @@
+MD5 3e8be56825395a075a71e0b7e8da206a binutils-2.10.1.tar.gz