summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/putty/ChangeLog5
-rw-r--r--net-misc/putty/Manifest4
-rw-r--r--net-misc/putty/putty-0.57.ebuild41
3 files changed, 24 insertions, 26 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 81b8ae007fdc..5f0c1e2b16d7 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.24 2005/08/21 13:29:39 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.25 2005/08/21 18:21:24 taviso Exp $
+
+ 21 Aug 2005; Tavis Ormandy <taviso@gentoo.org> putty-0.57.ebuild:
+ fix #103268
21 Aug 2005; Tavis Ormandy <taviso@gentoo.org> putty-0.57.ebuild:
fix #44836
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index c37abf420985..a84a04900900 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,5 +1,5 @@
-MD5 754f83f3cf48b87d08a29c429a2165c2 putty-0.57.ebuild 1695
-MD5 f5b160bf233f924c3030a87a4ac24fa3 ChangeLog 3465
+MD5 4a383beb375f4954b2af0c9d53acfc22 putty-0.57.ebuild 1820
+MD5 100121157f8df739c1824c18117fe7d7 ChangeLog 3548
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
MD5 3a07269379d199e6363fbe0250c5899a files/digest-putty-0.57 63
MD5 4f674a5fd23877ac6d76c6d9baa33041 files/putty-ut_time.patch 824
diff --git a/net-misc/putty/putty-0.57.ebuild b/net-misc/putty/putty-0.57.ebuild
index ae834a45ab7f..816a7a03054f 100644
--- a/net-misc/putty/putty-0.57.ebuild
+++ b/net-misc/putty/putty-0.57.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.57.ebuild,v 1.6 2005/08/21 13:29:39 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.57.ebuild,v 1.7 2005/08/21 18:21:24 taviso Exp $
inherit eutils
@@ -20,23 +20,27 @@ DEPEND="${RDEPEND} dev-lang/perl"
src_unpack() {
unpack ${A}
-
ebegin "Generating Makefiles"
- cd ${S}; perl ${S}/mkfiles.pl || die
+ cd ${S}; perl ${S}/mkfiles.pl || die
eend $?
ebegin "Setting CFLAGS"
- sed -i "s!-O2!${CFLAGS}!g" ${S}/unix/Makefile.gtk
-
- # prevent gtk-config from being used without gtk
- if ! use gtk; then
- sed -i "s/gtk-config/true/g" ${S}/unix/Makefile.gtk
- fi
+ # bug #103268
+ sed -i "s/-Werror//" ${S}/unix/Makefile.gtk
+ sed -i "s!-O2!${CFLAGS}!g" ${S}/unix/Makefile.gtk
+ # bug #44836
+ # prevent gtk-config from being used without gtk
+ if ! use gtk; then
+ sed -i "s/gtk-config/true/g" ${S}/unix/Makefile.gtk
+ fi
eend $?
}
src_compile() {
- cd ${S}/unix;
+ cd ${S}/unix
+
+ # compile all targets if gtk is required, otherwise
+ # just non-X utilities.
if use gtk; then
emake -f Makefile.gtk
else
@@ -46,34 +50,25 @@ src_compile() {
src_install() {
cd ${S}/doc
-
- if use gtk; then
- doman pterm.1 putty.1 puttytel.1
- fi
-
+ use gtk && doman pterm.1 putty.1 puttytel.1
doman puttygen.1 plink.1
cd ${S}/unix
-
- if use gtk; then
- dobin pterm putty puttytel
- fi
-
+ use gtk && dobin pterm putty puttytel
dobin puttygen plink pscp psftp
cd ${S}
-
dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER website.url
use doc && dodoc doc/*
prepallman
# install desktop file provided by Gustav Schaffter in #49577
- if use gtk; then
+ use gtk && {
dodir /usr/share/applications
insinto /usr/share/applications
doins ${FILESDIR}/putty.desktop
- fi
+ }
if test ! -c /dev/ptmx; then
ewarn