summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/ethereal/ethereal-0.8.11-r1.ebuild29
-rw-r--r--net-analyzer/ethereal/files/digest1
-rw-r--r--net-analyzer/nessus/files/digest5
-rw-r--r--net-analyzer/nessus/nessus-1.0.4-r1.ebuild99
-rw-r--r--net-analyzer/ngrep/files/digest1
-rw-r--r--net-analyzer/ngrep/ngrep-1.38-r1.ebuild33
-rw-r--r--net-analyzer/ntop/files/digest2
-rw-r--r--net-analyzer/ntop/ntop-1.3.1-r1.ebuild38
-rw-r--r--net-analyzer/tcpdump/files/digest1
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.5-r1.ebuild31
10 files changed, 240 insertions, 0 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.8.11-r1.ebuild b/net-analyzer/ethereal/ethereal-0.8.11-r1.ebuild
new file mode 100644
index 000000000000..6f830ec6f366
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.8.11-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.8.11-r1.ebuild,v 1.1 2000/08/08 16:06:07 achim Exp $
+
+P=ethereal-0.8.11
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="net-analyzer"
+DESCRIPTION="ethereal"
+SRC_URI="http://ethereal.zing.org/distribution/${A}
+ ftp://ethereal.zing.org/pub/ethereal/${A}"
+HOMEPAGE="http://ethereal.zing.org/"
+src_compile() {
+ cd ${S}
+ LDFLAGS="-L/usr/lib -lz" ./configure --host=${CHOST} --prefix=/usr/X11R6 --sysconfdir=/etc/ethereal
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/ethereal install
+ prepman /usr/X11R6
+ dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
+
+}
+
+
+
diff --git a/net-analyzer/ethereal/files/digest b/net-analyzer/ethereal/files/digest
new file mode 100644
index 000000000000..986de376e316
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest
@@ -0,0 +1 @@
+MD5 41bd942be38da26faeb1dbf512705583 ethereal-0.8.11.tar.gz
diff --git a/net-analyzer/nessus/files/digest b/net-analyzer/nessus/files/digest
new file mode 100644
index 000000000000..80fa82965a3c
--- /dev/null
+++ b/net-analyzer/nessus/files/digest
@@ -0,0 +1,5 @@
+MD5 1fe60e282532c6018ed402a275903c15 nessus-libraries-1.0.4.tar.gz
+MD5 b6d66f613b3c45526195df9e0087dd63 nessus-core-1.0.4.tar.gz
+MD5 dc6a2758761428f3bf66d0a06806d66a nessus-plugins-1.0.4.tar.gz
+MD5 3a91b6d6a42b8b73124990a13bbd0da2 libnasl-1.0.4.tar.gz
+MD5 a5588935d8d656de4ac3b95e8d3484ea libnasl-patch-1
diff --git a/net-analyzer/nessus/nessus-1.0.4-r1.ebuild b/net-analyzer/nessus/nessus-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..9b71874eedd7
--- /dev/null
+++ b/net-analyzer/nessus/nessus-1.0.4-r1.ebuild
@@ -0,0 +1,99 @@
+#Copyright 2000 Achim Gottinger
+#Distributed under the GPL
+
+# It's better to split it in four different packages
+
+P=nessus-1.0.4
+A="nessus-libraries-1.0.4.tar.gz nessus-core-1.0.4.tar.gz
+ nessus-plugins-1.0.4.tar.gz libnasl-1.0.4.tar.gz libnasl-patch-1"
+S=${WORKDIR}
+CATEGORY="net-analyzer"
+DESCRIPTION="Nessus"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-1.0.4/src/nessus-libraries-1.0.4.tar.gz
+ ftp://ftp.nessus.org/pub/nessus/nessus-1.0.4/src/nessus-core-1.0.4.tar.gz
+ ftp://ftp.nessus.org/pub/nessus/nessus-1.0.4/src/nessus-plugins-1.0.4.tar.gz
+ ftp://ftp.nessus.org/pub/nessus/nessus-1.0.4/src/libnasl-1.0.4.tar.gz
+ ftp://ftp.nessus.org/pub/nessus/nessus-1.0.4/src/libnasl-patch-1"
+
+HOMEPAGE="http://www.nessus.org/"
+
+src_unpack () {
+ unpack nessus-libraries-1.0.4.tar.gz
+ unpack nessus-core-1.0.4.tar.gz
+ unpack nessus-plugins-1.0.4.tar.gz
+ unpack libnasl-1.0.4.tar.gz
+ cd ${S}/libnasl/nasl
+ patch -p0 < ${DISTDIR}/libnasl-patch-1
+}
+src_compile() {
+
+ export PATH=${D}/usr/bin:$PATH
+ export LD_LIBRARY_PATH=${D}/usr/lib:$LD_LIBRARY_PATH
+ echo "Compiling libraries..."
+ cd ${S}/nessus-libraries
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ make
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+ cd ${D}/usr/bin
+ cp nessus-config nessus-config.orig
+ sed -e "s:^PREFIX=:PREFIX=${D}:" \
+ -e "s:-I/usr:-I${D}/usr: " nessus-config.orig > nessus-config
+
+ echo "Compiling libnasl..."
+ cd ${S}/libnasl
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ make
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+ cd ${D}/usr/bin
+ cp nasl-config nasl-config.orig
+ sed -e "s:^PREFIX=:PREFIX=${D}:" nasl-config.orig > nasl-config
+
+ echo "Compiling core..."
+ cd ${S}/nessus-core
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ make
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+
+
+ echo "Compiling plugins..."
+ cd ${S}/nessus-plugins
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ make
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+
+}
+
+src_install() {
+ cd ${S}/nessus-libraries
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+
+ cd ${S}/libnasl
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+
+ cd ${S}/nessus-core
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+ cp ${ROOT}/config/nessusd.conf ${D}/etc/nessus/
+
+ cd ${S}/nessus-plugins
+ make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
+
+ cd ${S}/nessus-libraries
+ docinto nessus-libraries
+ dodoc README*
+
+ cd ${S}/libnasl
+ docinto libnasl
+ dodoc COPYING TODO
+
+ cd ${S}/nessus-core
+ docinto nessus-core
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+
+ cd ${S}/nessus-plugins
+ docinto nessus-plugins
+ dodoc docs/*.txt plugins/accounts/accounts.txt
+}
+
+
+
diff --git a/net-analyzer/ngrep/files/digest b/net-analyzer/ngrep/files/digest
new file mode 100644
index 000000000000..42f6648d7645
--- /dev/null
+++ b/net-analyzer/ngrep/files/digest
@@ -0,0 +1 @@
+MD5 adff63845df54eb40ef48f16664e4344 ngrep-1.38.tar.gz
diff --git a/net-analyzer/ngrep/ngrep-1.38-r1.ebuild b/net-analyzer/ngrep/ngrep-1.38-r1.ebuild
new file mode 100644
index 000000000000..92c3f681dfb2
--- /dev/null
+++ b/net-analyzer/ngrep/ngrep-1.38-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ngrep/ngrep-1.38-r1.ebuild,v 1.1 2000/08/08 16:06:07 achim Exp $
+
+P=ngrep-1.38
+A=${P}.tar.gz
+S=${WORKDIR}/ngrep
+CATEGORY="net-analyzer"
+DESCRIPTION="A grep for network layers"
+SRC_URI="http://ngrep.datasurge.net/"${A}
+HOMEPAGE="http://ngrep.datasurge.net"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dobin ngrep
+ doman ngrep.8
+ dodoc BUGS CHANGES COPYRIGHT CREDITS README TODO USAGE
+}
+
+
+
diff --git a/net-analyzer/ntop/files/digest b/net-analyzer/ntop/files/digest
new file mode 100644
index 000000000000..f5c79862ae09
--- /dev/null
+++ b/net-analyzer/ntop/files/digest
@@ -0,0 +1,2 @@
+MD5 8afc33c65a176339916841e3a5177468 ntop-1.3.1.tar.gz
+MD5 8fcb6a8ba511ec8b54b95f267ef52cf0 openssl-0.9.5a.tar.gz
diff --git a/net-analyzer/ntop/ntop-1.3.1-r1.ebuild b/net-analyzer/ntop/ntop-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..5ac2fec59dea
--- /dev/null
+++ b/net-analyzer/ntop/ntop-1.3.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-1.3.1-r1.ebuild,v 1.1 2000/08/08 16:06:07 achim Exp $
+
+P=ntop-1.3.1
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+CATEGORY="net-analyzer"
+DESCRIPTION="Unix Tool that shows networkusage like top"
+SRC_URI="ftp://ftp.it.ntop.org/pub/local/ntop/snapshots/${A}"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+
+
+src_compile() {
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
+ CFLAGS="$CFLAGS -I/usr/include/openssl" ./configure --prefix=/usr --sysconfdir=/usr/share --host=${CHOST}
+ make
+
+}
+
+src_install () {
+
+ cd ${S}
+ make prefix=${D}/usr sysconfdir=/${D}/usr/share install
+ mv ${D}/usr/bin/plugins ${D}/usr/share/ntop
+ prepman
+ dodoc AUTHORS ChangeLog CONTENTS COPYING FAQ FILES HACKING
+ dodoc KNOWN_BUGS MANIFESTO NEWS ntop.txt PORTING README*
+ dodoc SUPPORT* THANKS THREADS-FAQ TODO
+ docinto html
+ dodoc ntop.html
+}
+
+
+
diff --git a/net-analyzer/tcpdump/files/digest b/net-analyzer/tcpdump/files/digest
new file mode 100644
index 000000000000..7e15b06b082a
--- /dev/null
+++ b/net-analyzer/tcpdump/files/digest
@@ -0,0 +1 @@
+MD5 d4bf4d3a546168bae75b55552942f398 tcpdump-3.5.tar.gz
diff --git a/net-analyzer/tcpdump/tcpdump-3.5-r1.ebuild b/net-analyzer/tcpdump/tcpdump-3.5-r1.ebuild
new file mode 100644
index 000000000000..d0609caa6689
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-3.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.5-r1.ebuild,v 1.1 2000/08/08 16:06:07 achim Exp $
+
+P=tcpdump-3.5
+A=${P}.tar.gz
+S=${WORKDIR}/tcpdump_3_5rel2
+CATEGORY="net-analyzer"
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+SRC_URI="http://www.tcpdump.org/release/${A}
+ http://www.jp.tcpdump.org/release/${A}"
+HOMEPAGE="http://www.tcpdump.org/"
+
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dobin tcpdump
+ doman tcpdump.1
+ dodoc README FILES VERSION CHANGES
+}
+
+
+