summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/libgnomeprint/ChangeLog7
-rw-r--r--gnome-extra/libgnomeprint/files/digest-libgnomeprint-1.113.01
-rw-r--r--gnome-extra/libgnomeprint/libgnomeprint-1.113.0.ebuild68
-rw-r--r--gnome-extra/libgnomeprintui/ChangeLog7
-rw-r--r--gnome-extra/libgnomeprintui/files/digest-libgnomeprintui-1.113.01
-rw-r--r--gnome-extra/libgnomeprintui/libgnomeprintui-1.113.0.ebuild50
-rw-r--r--gnome-extra/libgtkhtml/ChangeLog7
-rw-r--r--gnome-extra/libgtkhtml/files/digest-libgtkhtml-1.99.71
-rw-r--r--gnome-extra/libgtkhtml/libgtkhtml-1.99.7.ebuild51
9 files changed, 193 insertions, 0 deletions
diff --git a/gnome-extra/libgnomeprint/ChangeLog b/gnome-extra/libgnomeprint/ChangeLog
new file mode 100644
index 000000000000..e5ceea3ad25b
--- /dev/null
+++ b/gnome-extra/libgnomeprint/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for gnome-extra/libgnomeprint
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomeprint/ChangeLog,v 1.1 2002/05/22 22:35:57 spider Exp $
+
+*libgnomeprint-1.113.0 (22 May 2002)
+ 22 May 2002; Spider <spider@gentoo.org> libgnomeprint-1.113.0.ebuild:
+ addition from the gnome2 tree
diff --git a/gnome-extra/libgnomeprint/files/digest-libgnomeprint-1.113.0 b/gnome-extra/libgnomeprint/files/digest-libgnomeprint-1.113.0
new file mode 100644
index 000000000000..c1936e3c4a9a
--- /dev/null
+++ b/gnome-extra/libgnomeprint/files/digest-libgnomeprint-1.113.0
@@ -0,0 +1 @@
+MD5 fc99e013dd40450c8ff93ed2cb58f908 libgnomeprint-1.113.0.tar.bz2 426715
diff --git a/gnome-extra/libgnomeprint/libgnomeprint-1.113.0.ebuild b/gnome-extra/libgnomeprint/libgnomeprint-1.113.0.ebuild
new file mode 100644
index 000000000000..de64ad964261
--- /dev/null
+++ b/gnome-extra/libgnomeprint/libgnomeprint-1.113.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomeprint/libgnomeprint-1.113.0.ebuild,v 1.1 2002/05/22 22:35:57 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Printer handling for Gnome"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+
+RDEPEND=">=gnome-base/libbonobo-1.112.0-r1
+ >=media-libs/libart_lgpl-2.3.8
+ >=x11-libs/pango-1.0.0
+ >=dev-libs/libxml2-2.4.17
+ >=dev-libs/glib-2.0.0
+ >=media-libs/freetype-2.0.8"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ local myconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --disable-font-install \
+ --enable-platform-gnome-2 || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog* INSTALL NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Fonts"
+ libgnomeprint-2.0-font-install \
+ --debug \
+ --smart \
+ --static \
+ --aliases=/usr/share/gnome/libgnomeprint-2.0/fonts/adobe-urw.font \
+ --target=/usr/share/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
+
+}
+
+
diff --git a/gnome-extra/libgnomeprintui/ChangeLog b/gnome-extra/libgnomeprintui/ChangeLog
new file mode 100644
index 000000000000..9d6deaa31152
--- /dev/null
+++ b/gnome-extra/libgnomeprintui/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for gnome-extra/libgnomeprintui
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomeprintui/ChangeLog,v 1.1 2002/05/22 22:38:24 spider Exp $
+
+*libgnomeprintui-1.113.0 (22 May 2002)
+ 22 May 2002; Spider <spider@gentoo.org> libgnomeprintui-1.113.0.ebuild:
+ addition from the gnome2 tree
diff --git a/gnome-extra/libgnomeprintui/files/digest-libgnomeprintui-1.113.0 b/gnome-extra/libgnomeprintui/files/digest-libgnomeprintui-1.113.0
new file mode 100644
index 000000000000..89efb599ade7
--- /dev/null
+++ b/gnome-extra/libgnomeprintui/files/digest-libgnomeprintui-1.113.0
@@ -0,0 +1 @@
+MD5 0e6b2263d3f606679fa729a7f5105025 libgnomeprintui-1.113.0.tar.bz2 271090
diff --git a/gnome-extra/libgnomeprintui/libgnomeprintui-1.113.0.ebuild b/gnome-extra/libgnomeprintui/libgnomeprintui-1.113.0.ebuild
new file mode 100644
index 000000000000..3d1b9afef5ab
--- /dev/null
+++ b/gnome-extra/libgnomeprintui/libgnomeprintui-1.113.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomeprintui/libgnomeprintui-1.113.0.ebuild,v 1.1 2002/05/22 22:38:24 spider Exp $
+
+
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="user interface libraries for gnome print"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND=">=gnome-base/libgnomeui-1.112.1
+ >=gnome-extra/libgnomeprint-1.112.0
+ >=gnome-base/libgnomecanvas-1.112.1"
+
+DEPEND="${RDEPEND} >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog INSTALL NEWS README
+}
+
diff --git a/gnome-extra/libgtkhtml/ChangeLog b/gnome-extra/libgtkhtml/ChangeLog
new file mode 100644
index 000000000000..2473ecdd7d72
--- /dev/null
+++ b/gnome-extra/libgtkhtml/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for gnome-extra/libgtkhtml
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/ChangeLog,v 1.1 2002/05/22 22:36:08 spider Exp $
+
+*libgtkhtml-1.99.7 (22 May 2002)
+ 22 May 2002; Spider <spider@gentoo.org> libgtkhtml-1.99.7.ebuild:
+ addition from the gnome2 tree
diff --git a/gnome-extra/libgtkhtml/files/digest-libgtkhtml-1.99.7 b/gnome-extra/libgtkhtml/files/digest-libgtkhtml-1.99.7
new file mode 100644
index 000000000000..7b93004a4046
--- /dev/null
+++ b/gnome-extra/libgtkhtml/files/digest-libgtkhtml-1.99.7
@@ -0,0 +1 @@
+MD5 3dd0a733c35c132020921e94d7522c9d libgtkhtml-1.99.7.tar.bz2 329663
diff --git a/gnome-extra/libgtkhtml/libgtkhtml-1.99.7.ebuild b/gnome-extra/libgtkhtml/libgtkhtml-1.99.7.ebuild
new file mode 100644
index 000000000000..46bd225a7332
--- /dev/null
+++ b/gnome-extra/libgtkhtml/libgtkhtml-1.99.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-1.99.7.ebuild,v 1.1 2002/05/22 22:36:08 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="a Gtk+ based HTML rendering library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/libgtkhtml/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="1"
+LICENSE="LGPL-2.1 GPL-2"
+
+RDEPEND=">=x11-libs/gtk+-2.0.1
+ >=dev-libs/libxml2-2.4.17
+ >=gnome-base/gnome-vfs-1.9.10
+ >=gnome-base/gail-0.9"
+
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die "configure failure"
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die "install failure"
+
+ dodoc AUTHORS COPYING* ChangeLog INSTALL NEWS README* TODO
+ dodoc docs/IDEAS
+}
+