summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/horde-chora/horde-chora-1.2-r1.ebuild12
-rw-r--r--net-www/horde-imp/horde-imp-3.2.2.ebuild11
-rw-r--r--net-www/horde-kronolith/horde-kronolith-1.1.ebuild12
-rw-r--r--net-www/horde-pear/horde-pear-1.1.ebuild14
-rw-r--r--net-www/horde-turba/horde-turba-1.2.1.ebuild12
-rw-r--r--net-www/horde/horde-2.2.4.ebuild11
6 files changed, 41 insertions, 31 deletions
diff --git a/net-www/horde-chora/horde-chora-1.2-r1.ebuild b/net-www/horde-chora/horde-chora-1.2-r1.ebuild
index 6471dc5bdfda..def79333cf1b 100644
--- a/net-www/horde-chora/horde-chora-1.2-r1.ebuild
+++ b/net-www/horde-chora/horde-chora-1.2-r1.ebuild
@@ -1,21 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-chora/horde-chora-1.2-r1.ebuild,v 1.8 2003/12/15 20:46:02 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-chora/horde-chora-1.2-r1.ebuild,v 1.9 2004/01/19 06:36:04 vapier Exp $
inherit webapp-apache
-DESCRIPTION="Chora ${PV} is the Horde CVS viewer."
-HOMEPAGE="http://www.horde.org"
MY_P=${P/horde-/}
+DESCRIPTION="Chora is the Horde CVS viewer"
+HOMEPAGE="http://www.horde.org/"
SRC_URI="ftp://ftp.horde.org/pub/chora/tarballs/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND=""
RDEPEND=">=net-www/horde-2.2.4
>=app-text/rcs-5.7-r1
>=dev-util/cvs-1.11.2"
-IUSE=""
+
S=${WORKDIR}/${MY_P}
webapp-detect || NO_WEBSERVER=1
@@ -25,7 +27,7 @@ pkg_setup() {
einfo "Installing into ${ROOT}${HTTPD_ROOT}."
}
-src_install () {
+src_install() {
webapp-mkdirs
local DocumentRoot=${HTTPD_ROOT}
diff --git a/net-www/horde-imp/horde-imp-3.2.2.ebuild b/net-www/horde-imp/horde-imp-3.2.2.ebuild
index e1187bc2b722..a32478b1482a 100644
--- a/net-www/horde-imp/horde-imp-3.2.2.ebuild
+++ b/net-www/horde-imp/horde-imp-3.2.2.ebuild
@@ -1,18 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2.2.ebuild,v 1.6 2003/12/15 20:53:08 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2.2.ebuild,v 1.7 2004/01/19 06:36:42 vapier Exp $
inherit webapp-apache
-DESCRIPTION="Horde IMP provides webmail access"
-HOMEPAGE="http://www.horde.org"
MY_P=${P/horde-/}
+DESCRIPTION="Horde IMP provides webmail access to IMAP/POP3 mailboxes"
+HOMEPAGE="http://www.horde.org/"
SRC_URI="ftp://ftp.horde.org/pub/imp/tarballs/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND=""
RDEPEND=">=net-www/horde-2.2.4"
+
S=${WORKDIR}/${MY_P}
webapp-detect || NO_WEBSERVER=1
@@ -30,7 +33,7 @@ pkg_setup() {
einfo "Installing into ${ROOT}${HTTPD_ROOT}."
}
-src_install () {
+src_install() {
webapp-mkdirs
local DocumentRoot=${HTTPD_ROOT}
diff --git a/net-www/horde-kronolith/horde-kronolith-1.1.ebuild b/net-www/horde-kronolith/horde-kronolith-1.1.ebuild
index 13a79809a61c..fa15b2fab34f 100644
--- a/net-www/horde-kronolith/horde-kronolith-1.1.ebuild
+++ b/net-www/horde-kronolith/horde-kronolith-1.1.ebuild
@@ -1,19 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/horde-kronolith-1.1.ebuild,v 1.7 2004/01/07 21:40:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/horde-kronolith-1.1.ebuild,v 1.8 2004/01/19 06:37:45 vapier Exp $
inherit webapp-apache
-DESCRIPTION="Kronolith ${PV} is the Horde calendar application"
-HOMEPAGE="http://www.horde.org"
MY_P=${P/horde-/}
+DESCRIPTION="Kronolith is the Horde calendar application"
+HOMEPAGE="http://www.horde.org/"
SRC_URI="ftp://ftp.horde.org/pub/kronolith/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND=""
RDEPEND=">=net-www/horde-2.2.4"
-IUSE=""
+
S=${WORKDIR}/${MY_P}
webapp-detect || NO_WEBSERVER=1
@@ -28,7 +30,7 @@ pkg_setup() {
einfo "Installing into ${ROOT}${HTTPD_ROOT}."
}
-src_install () {
+src_install() {
webapp-mkdirs
local DocumentRoot=${HTTPD_ROOT}
diff --git a/net-www/horde-pear/horde-pear-1.1.ebuild b/net-www/horde-pear/horde-pear-1.1.ebuild
index b5370b8524a2..c6832c24b0ec 100644
--- a/net-www/horde-pear/horde-pear-1.1.ebuild
+++ b/net-www/horde-pear/horde-pear-1.1.ebuild
@@ -1,20 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-pear/horde-pear-1.1.ebuild,v 1.4 2004/01/03 16:15:04 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-pear/horde-pear-1.1.ebuild,v 1.5 2004/01/19 06:38:19 vapier Exp $
-DESCRIPTION="Horde Application Framework PHP PEAR files ${PV}"
-HOMEPAGE="http://www.horde.org"
MY_P="${P/horde-/}"
MY_PN="${PN/horde-/}"
+DESCRIPTION="Horde Application Framework PHP PEAR files"
+HOMEPAGE="http://www.horde.org/"
SRC_URI="ftp://ftp.horde.org/pub/pear/${MY_P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND=""
RDEPEND=">=dev-php/mod_php-4.1.0
>=sys-devel/gettext-0.10.40
>=dev-libs/libxml2-2.4.21-r1"
-IUSE=""
+
S=${WORKDIR}/${MY_PN}
src_compile() {
@@ -22,7 +24,7 @@ src_compile() {
echo "Nothing to compile"
}
-src_install () {
- mkdir -p ${D}/usr/lib
+src_install() {
+ dodir /usr/lib
cp -a ${S} ${D}/usr/lib/php
}
diff --git a/net-www/horde-turba/horde-turba-1.2.1.ebuild b/net-www/horde-turba/horde-turba-1.2.1.ebuild
index 9461b5afda37..877836a3ec50 100644
--- a/net-www/horde-turba/horde-turba-1.2.1.ebuild
+++ b/net-www/horde-turba/horde-turba-1.2.1.ebuild
@@ -1,19 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/horde-turba-1.2.1.ebuild,v 1.6 2004/01/07 21:37:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/horde-turba-1.2.1.ebuild,v 1.7 2004/01/19 06:38:44 vapier Exp $
inherit webapp-apache
-DESCRIPTION="Turba ${PV} is the Horde address book / contact management program"
-HOMEPAGE="http://www.horde.org"
MY_P=${P/horde-/}
+DESCRIPTION="Turba is the Horde address book / contact management program"
+HOMEPAGE="http://www.horde.org/"
SRC_URI="ftp://ftp.horde.org/pub/turba/tarballs/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND=""
RDEPEND=">=net-www/horde-2.2.4"
-IUSE=""
+
S=${WORKDIR}/${MY_P}
webapp-detect || NO_WEBSERVER=1
@@ -33,7 +35,7 @@ pkg_setup() {
[ -f ${REGISTRY} ] || die "${REGISTRY} not found"
}
-src_install () {
+src_install() {
webapp-mkdirs
local DocumentRoot=${HTTPD_ROOT}
diff --git a/net-www/horde/horde-2.2.4.ebuild b/net-www/horde/horde-2.2.4.ebuild
index b0cf022f98d9..9c29f824a591 100644
--- a/net-www/horde/horde-2.2.4.ebuild
+++ b/net-www/horde/horde-2.2.4.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde/horde-2.2.4.ebuild,v 1.11 2004/01/07 21:41:15 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/horde-2.2.4.ebuild,v 1.12 2004/01/19 06:35:33 vapier Exp $
inherit webapp-apache
-S=${WORKDIR}/${P}
-
DESCRIPTION="Horde Application Framework"
-HOMEPAGE="http://www.horde.org"
+HOMEPAGE="http://www.horde.org/"
SRC_URI="http://ftp.horde.org/pub/horde/tarballs/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND=""
RDEPEND=">=dev-php/mod_php-4.1.0
>=sys-devel/gettext-0.10.40
>=dev-libs/libxml2-2.4.21
>=net-www/horde-pear-1.1"
-IUSE=""
webapp-detect || NO_WEBSERVER=1
@@ -32,7 +31,7 @@ pkg_setup() {
einfo "Installing into ${ROOT}${HTTPD_ROOT}."
}
-src_install () {
+src_install() {
webapp-mkdirs
local DocumentRoot=${HTTPD_ROOT}